summaryrefslogtreecommitdiff
path: root/mcs/class/Facades/System.Reflection.Emit.Lightweight/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mcs/class/Facades/System.Reflection.Emit.Lightweight/Makefile')
-rw-r--r--mcs/class/Facades/System.Reflection.Emit.Lightweight/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/mcs/class/Facades/System.Reflection.Emit.Lightweight/Makefile b/mcs/class/Facades/System.Reflection.Emit.Lightweight/Makefile
new file mode 100644
index 0000000000..751a8ec956
--- /dev/null
+++ b/mcs/class/Facades/System.Reflection.Emit.Lightweight/Makefile
@@ -0,0 +1,22 @@
+MCS_BUILD_DIR = ../../../build
+
+thisdir = class/Facades/System.Reflection.Emit.Lightweight
+SUBDIRS =
+include $(MCS_BUILD_DIR)/rules.make
+
+LIBRARY_SUBDIR = Facades
+LIBRARY_INSTALL_DIR = $(mono_libdir)/mono/$(FRAMEWORK_VERSION)/Facades
+
+LIBRARY = System.Reflection.Emit.Lightweight.dll
+
+KEY_FILE = ../../msfinal.pub
+SIGN_FLAGS = /delaysign /keyfile:$(KEY_FILE) /nowarn:1616,1699
+LIB_MCS_FLAGS = $(SIGN_FLAGS) /r:mscorlib
+
+PLATFORM_DEBUG_FLAGS =
+
+NO_TEST = yes
+
+include $(MCS_BUILD_DIR)/library.make
+
+