summaryrefslogtreecommitdiff
path: root/mcs/class/Facades/System.Runtime.Numerics/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mcs/class/Facades/System.Runtime.Numerics/Makefile')
-rw-r--r--mcs/class/Facades/System.Runtime.Numerics/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/mcs/class/Facades/System.Runtime.Numerics/Makefile b/mcs/class/Facades/System.Runtime.Numerics/Makefile
index eb821c8656..b21abddbab 100644
--- a/mcs/class/Facades/System.Runtime.Numerics/Makefile
+++ b/mcs/class/Facades/System.Runtime.Numerics/Makefile
@@ -1,15 +1,22 @@
+MCS_BUILD_DIR = ../../../build
+
thisdir = class/Facades/System.Runtime.Numerics
SUBDIRS =
-include ../../../build/rules.make
+include $(MCS_BUILD_DIR)/rules.make
LIBRARY_SUBDIR = Facades
LIBRARY_INSTALL_DIR = $(mono_libdir)/mono/$(FRAMEWORK_VERSION)/Facades
LIBRARY = System.Runtime.Numerics.dll
-LIB_MCS_FLAGS = /r:System.Numerics
+
+KEY_FILE = ../../msfinal.pub
+SIGN_FLAGS = /delaysign /keyfile:$(KEY_FILE) /nowarn:1616,1699
+LIB_MCS_FLAGS = $(SIGN_FLAGS) /r:mscorlib /r:System.Numerics
PLATFORM_DEBUG_FLAGS =
NO_TEST = yes
-include ../../../build/library.make
+include $(MCS_BUILD_DIR)/library.make
+
+