summaryrefslogtreecommitdiff
path: root/mono/metadata/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'mono/metadata/Makefile.am')
-rw-r--r--mono/metadata/Makefile.am30
1 files changed, 29 insertions, 1 deletions
diff --git a/mono/metadata/Makefile.am b/mono/metadata/Makefile.am
index c4d7c9c562..0b47ca6093 100644
--- a/mono/metadata/Makefile.am
+++ b/mono/metadata/Makefile.am
@@ -117,6 +117,7 @@ common_sources = \
filewatcher.c \
filewatcher.h \
gc-internal.h \
+ gc-memfuncs.c \
icall.c \
icall-def.h \
image.c \
@@ -253,7 +254,8 @@ sgen_sources = \
sgen-stw.c \
sgen-fin-weak-hash.c \
sgen-layout-stats.c \
- sgen-layout-stats.h
+ sgen-layout-stats.h \
+ sgen-qsort.c
libmonoruntime_la_SOURCES = $(common_sources) $(gc_dependent_sources) $(boehm_sources)
libmonoruntime_la_CFLAGS = $(BOEHM_DEFINES)
@@ -331,3 +333,29 @@ else
Makefile.am: Makefile.am.in
cp $< $@
endif
+
+if !HOST_WIN32
+if SUPPORT_BOEHM
+
+test_sgen_qsort_SOURCES = test-sgen-qsort.c
+test_sgen_qsort_CFLAGS = $(SGEN_DEFINES)
+test_sgen_qsort_LDADD = libmonoruntimesgen.la ../io-layer/libwapi.la ../utils/libmonoutils.la \
+ $(LIBGC_LIBS) $(GLIB_LIBS) -lm $(LIBICONV)
+if PLATFORM_DARWIN
+test_sgen_qsort_LDFLAGS=-framework CoreFoundation
+endif
+
+test_gc_memfuncs_SOURCES = test-gc-memfuncs.c
+test_gc_memfuncs_CFLAGS = $(SGEN_DEFINES)
+test_gc_memfuncs_LDADD = libmonoruntimesgen.la ../io-layer/libwapi.la ../utils/libmonoutils.la \
+ $(LIBGC_LIBS) $(GLIB_LIBS) -lm $(LIBICONV)
+if PLATFORM_DARWIN
+test_gc_memfuncs_LDFLAGS=-framework CoreFoundation
+endif
+
+noinst_PROGRAMS = test-sgen-qsort test-gc-memfuncs
+
+TESTS = test-sgen-qsort test-gc-memfuncs
+
+endif SUPPORT_BOEHM
+endif !HOST_WIN32