summaryrefslogtreecommitdiff
path: root/mono/tests/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'mono/tests/Makefile.in')
-rw-r--r--mono/tests/Makefile.in175
1 files changed, 113 insertions, 62 deletions
diff --git a/mono/tests/Makefile.in b/mono/tests/Makefile.in
index 31a965ae3a..1acf2e0dd3 100644
--- a/mono/tests/Makefile.in
+++ b/mono/tests/Makefile.in
@@ -1,8 +1,9 @@
-# Makefile.in generated by automake 1.12.1 from Makefile.am.
+# Makefile.in generated by automake 1.11.6 from Makefile.am.
# @configure_input@
-# Copyright (C) 1994-2012 Free Software Foundation, Inc.
-
+# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -69,8 +70,7 @@ target_triplet = @target@
@NACL_CODEGEN_FALSE@am__append_3 = bug-438454.cs bug-438454.exe.stdout.expected threadpool-in-processexit.cs threadpool-in-processexit.exe.stdout.expected
subdir = mono/tests
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
- $(srcdir)/tests-config.in $(top_srcdir)/depcomp \
- $(top_srcdir)/mkinstalldirs ChangeLog
+ $(srcdir)/tests-config.in ChangeLog
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/iconv.m4 \
$(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
@@ -105,7 +105,7 @@ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
AM_V_CC = $(am__v_CC_@AM_V@)
am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
-am__v_CC_0 = @echo " CC " $@;
+am__v_CC_0 = @echo " CC " $@;
AM_V_at = $(am__v_at_@AM_V@)
am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
am__v_at_0 = @
@@ -115,10 +115,10 @@ LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
AM_V_CCLD = $(am__v_CCLD_@AM_V@)
am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
-am__v_CCLD_0 = @echo " CCLD " $@;
+am__v_CCLD_0 = @echo " CCLD " $@;
AM_V_GEN = $(am__v_GEN_@AM_V@)
am__v_GEN_ = $(am__v_GEN_@AM_DEFAULT_V@)
-am__v_GEN_0 = @echo " GEN " $@;
+am__v_GEN_0 = @echo " GEN " $@;
SOURCES = $(libtest_la_SOURCES)
DIST_SOURCES = $(libtest_la_SOURCES)
RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
@@ -378,7 +378,11 @@ MKBUNDLE = \
PKG_CONFIG_PATH=$(top_builddir):$(PKG_CONFIG_PATH) \
$(RUNTIME) $(mcs_topdir)/class/lib/net_4_5/mkbundle.exe
-MCS = $(RUNTIME) $(mcs_topdir)/class/lib/build/mcs.exe -unsafe -nowarn:0162 -nowarn:0168 -nowarn:0219 -debug
+MCS = $(RUNTIME) $(mcs_topdir)/class/lib/build/mcs.exe -unsafe -debug \
+ -nowarn:0162 -nowarn:0168 -nowarn:0219 -nowarn:0414 -nowarn:0618 \
+ -nowarn:0169 -nowarn:1690 -nowarn:0649 -nowarn:0612 -nowarn:3021 \
+ -nowarn:0197
+
ILASM = $(RUNTIME) $(mcs_topdir)/class/lib/net_4_5/ilasm.exe
BENCHSRC = fib.cs random.cs nested-loops.cs ackermann.cs tight-loop.cs sieve.cs
STRESS_TESTS_SRC = \
@@ -745,7 +749,8 @@ BASE_TEST_CS_SRC = \
allow-synchronous-major.cs \
unload-appdomain-on-shutdown.cs \
block_guard_restore_aligment_on_exit.cs \
- finally_block_ending_in_dead_bb.cs
+ finally_block_ending_in_dead_bb.cs \
+ thread_static_gc_layout.cs
TEST_CS_SRC_DIST = \
$(BASE_TEST_CS_SRC) \
@@ -957,9 +962,10 @@ EXTRA_DIST = test-driver $(TEST_CS_SRC_DIST) $(TEST_IL_SRC) \
sgen-bridge-major-fragmentation.cs sgen-domain-unload.cs \
sgen-weakref-stress.cs sgen-cementing-stress.cs \
sgen-case-23400.cs finalizer-wait.cs critical-finalizers.cs \
- sgen-domain-unload-2.cs sgen-suspend.cs gen-runtime-invoke.cs \
- make-imt-test.cs test-inline-call-stack-library.cs \
- test-inline-call-stack.cs \
+ sgen-domain-unload-2.cs sgen-suspend.cs \
+ sgen-new-threads-dont-join-stw.cs sgen-bridge-xref.cs \
+ gen-runtime-invoke.cs make-imt-test.cs \
+ test-inline-call-stack-library.cs test-inline-call-stack.cs \
unhandled-exception-base-configuration.config \
unhandled-exception-legacy-configuration.config \
appdomain-unload.exe.config unhandled-exception-test-case.2.cs \
@@ -986,7 +992,8 @@ SGEN_TESTS = \
sgen-domain-unload.exe \
sgen-weakref-stress.exe \
sgen-cementing-stress.exe \
- sgen-case-23400.exe
+ sgen-case-23400.exe \
+ sgen-new-threads-dont-join-stw.exe
SGEN_CONFIGURATIONS = \
"|plain" \
@@ -1003,6 +1010,10 @@ SGEN_BRIDGE_CONFIGURATIONS = \
",major=marksweep-conc|ms-conc" \
",minor=split|ms-split"
+AOT_CONFIGURATIONS = \
+ "|regular" \
+ "--gc=boehm|boehm"
+
GSHARED_TESTS = \
generics-sharing.2.exe shared-generic-methods.2.exe \
shared-generic-synchronized.2.exe generic-initobj.2.exe \
@@ -1087,14 +1098,12 @@ tests-config: $(top_builddir)/config.status $(srcdir)/tests-config.in
clean-noinstLTLIBRARIES:
-test -z "$(noinst_LTLIBRARIES)" || rm -f $(noinst_LTLIBRARIES)
- @list='$(noinst_LTLIBRARIES)'; \
- locs=`for p in $$list; do echo $$p; done | \
- sed 's|^[^/]*$$|.|; s|/[^/]*$$||; s|$$|/so_locations|' | \
- sort -u`; \
- test -z "$$locs" || { \
- echo rm -f $${locs}; \
- rm -f $${locs}; \
- }
+ @list='$(noinst_LTLIBRARIES)'; for p in $$list; do \
+ dir="`echo $$p | sed -e 's|/[^/]*$$||'`"; \
+ test "$$dir" != "$$p" || dir=.; \
+ echo "rm -f \"$${dir}/so_locations\""; \
+ rm -f "$${dir}/so_locations"; \
+ done
libtest.la: $(libtest_la_OBJECTS) $(libtest_la_DEPENDENCIES) $(EXTRA_libtest_la_DEPENDENCIES)
$(AM_V_CCLD)$(libtest_la_LINK) $(libtest_la_OBJECTS) $(libtest_la_LIBADD) $(LIBS)
@@ -1144,11 +1153,11 @@ clean-libtool:
-rm -rf .libs _libs
# This directory's subdirectories are mostly independent; you can cd
-# into them and run 'make' without going through this Makefile.
-# To change the values of 'make' variables: instead of editing Makefiles,
-# (1) if the variable is set in 'config.status', edit 'config.status'
-# (which will cause the Makefiles to be regenerated when you run 'make');
-# (2) otherwise, pass the desired values on the 'make' command line.
+# into them and run `make' without going through this Makefile.
+# To change the values of `make' variables: instead of editing Makefiles,
+# (1) if the variable is set in `config.status', edit `config.status'
+# (which will cause the Makefiles to be regenerated when you run `make');
+# (2) otherwise, pass the desired values on the `make' command line.
$(RECURSIVE_TARGETS):
@fail= failcom='exit 1'; \
for f in x $$MAKEFLAGS; do \
@@ -1212,10 +1221,6 @@ ctags-recursive:
list='$(SUBDIRS)'; for subdir in $$list; do \
test "$$subdir" = . || ($(am__cd) $$subdir && $(MAKE) $(AM_MAKEFLAGS) ctags); \
done
-cscopelist-recursive:
- list='$(SUBDIRS)'; for subdir in $$list; do \
- test "$$subdir" = . || ($(am__cd) $$subdir && $(MAKE) $(AM_MAKEFLAGS) cscopelist); \
- done
ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
@@ -1279,20 +1284,6 @@ GTAGS:
&& $(am__cd) $(top_srcdir) \
&& gtags -i $(GTAGS_ARGS) "$$here"
-cscopelist: cscopelist-recursive $(HEADERS) $(SOURCES) $(LISP)
- list='$(SOURCES) $(HEADERS) $(LISP)'; \
- case "$(srcdir)" in \
- [\\/]* | ?:[\\/]*) sdir="$(srcdir)" ;; \
- *) sdir=$(subdir)/$(srcdir) ;; \
- esac; \
- for i in $$list; do \
- if test -f "$$i"; then \
- echo "$(subdir)/$$i"; \
- else \
- echo "$$sdir/$$i"; \
- fi; \
- done >> $(top_builddir)/cscope.files
-
distclean-tags:
-rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
@@ -1460,24 +1451,22 @@ ps-am:
uninstall-am:
.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) check-am \
- cscopelist-recursive ctags-recursive install-am install-strip \
- tags-recursive
+ ctags-recursive install-am install-strip tags-recursive
.PHONY: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) CTAGS GTAGS \
all all-am check check-am check-local clean clean-generic \
- clean-libtool clean-noinstLTLIBRARIES cscopelist \
- cscopelist-recursive ctags ctags-recursive distclean \
- distclean-compile distclean-generic distclean-libtool \
- distclean-tags distdir dvi dvi-am html html-am info info-am \
- install install-am install-data install-data-am install-dvi \
- install-dvi-am install-exec install-exec-am install-html \
- install-html-am install-info install-info-am install-man \
- install-pdf install-pdf-am install-ps install-ps-am \
- install-strip installcheck installcheck-am installdirs \
- installdirs-am maintainer-clean maintainer-clean-generic \
- mostlyclean mostlyclean-compile mostlyclean-generic \
- mostlyclean-libtool pdf pdf-am ps ps-am tags tags-recursive \
- uninstall uninstall-am
+ clean-libtool clean-noinstLTLIBRARIES ctags ctags-recursive \
+ distclean distclean-compile distclean-generic \
+ distclean-libtool distclean-tags distdir dvi dvi-am html \
+ html-am info info-am install install-am install-data \
+ install-data-am install-dvi install-dvi-am install-exec \
+ install-exec-am install-html install-html-am install-info \
+ install-info-am install-man install-pdf install-pdf-am \
+ install-ps install-ps-am install-strip installcheck \
+ installcheck-am installdirs installdirs-am maintainer-clean \
+ maintainer-clean-generic mostlyclean mostlyclean-compile \
+ mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
+ tags tags-recursive uninstall uninstall-am
check-local: test
@@ -1604,7 +1593,9 @@ runtest: $(TESTSI_CS) $(TESTSI_IL) $(TESTBS) libtest.la $(PREREQSI_IL) $(PREREQS
@failed=0; \
passed=0; \
failed_tests="";\
- for i in $(TESTSI_CS) $(TESTBS) $(TESTSI_IL); do \
+ rm -f testlist testlist.sorted; \
+ for i in $(TESTSI_CS) $(TESTBS) $(TESTSI_IL); do echo $${i} >> testlist; sort testlist > testlist.sorted; done; \
+ for i in `cat testlist.sorted`; do \
rm -f $${i}.so; \
if [ x$(AOT) = x1 ]; then if echo $(AOT_DISABLED_TESTS) | grep -v -q $${i}; then $(with_mono_path) $(JITTEST_PROG_RUN) --aot --debug $${i} > $${i}.aotlog 2>&1 || exit 1; fi; fi; \
if $(srcdir)/test-driver '$(with_mono_path) $(JITTEST_PROG_RUN)' $$i '$(DISABLED_TESTS)' 'no-dump' $(RUNTIME_ARGS); \
@@ -1617,6 +1608,7 @@ runtest: $(TESTSI_CS) $(TESTSI_IL) $(TESTBS) libtest.la $(PREREQSI_IL) $(PREREQS
fi \
done; \
echo "$${passed} test(s) passed. $${failed} test(s) did not pass."; \
+ rm -f testlist testlist.sorted; \
if [ $${failed} != 0 ]; then echo -e "\nFailed tests:\n"; \
for i in $${failed_tests}; do echo $${i}; done; exit 1; fi
@@ -1705,7 +1697,7 @@ sgen-regular-tests: $(SGEN_TESTS)
if [ $${failed} != 0 ]; then echo -e "\nFailed tests:\n"; \
for i in $${failed_tests}; do echo $${i}; done; exit 1; fi
-sgen-bridge-tests: sgen-bridge.exe sgen-bridge-major-fragmentation.exe
+sgen-bridge-tests1: sgen-bridge.exe sgen-bridge-major-fragmentation.exe
@failed=0; \
passed=0; \
failed_tests="";\
@@ -1729,7 +1721,66 @@ sgen-bridge-tests: sgen-bridge.exe sgen-bridge-major-fragmentation.exe
if [ $${failed} != 0 ]; then echo -e "\nFailed tests:\n"; \
for i in $${failed_tests}; do echo $${i}; done; exit 1; fi
+sgen-bridge-tests2: sgen-bridge-xref.exe
+ @failed=0; \
+ passed=0; \
+ failed_tests="";\
+ for test in $+; do \
+ echo "...$$test"; \
+ for conf in $(SGEN_BRIDGE_CONFIGURATIONS); do \
+ name=`echo $$conf | cut -d\| -f 2`; \
+ params=`echo $$conf | cut -d\| -f 1`; \
+ test_name="$${test}|$${name}"; \
+ if MONO_GC_PARAMS="bridge=2Bridge$${params}" MONO_ENV_OPTIONS="--gc=sgen" $(srcdir)/test-driver '$(with_mono_path) $(JITTEST_PROG_RUN)' $$test_name "$(DISABLED_TESTS_SGEN)" 'dump-output' $(RUNTIME_ARGS); \
+ then \
+ passed=`expr $${passed} + 1`; \
+ else \
+ if [ $$? = 2 ]; then break; fi; \
+ failed=`expr $${failed} + 1`; \
+ failed_tests="$${failed_tests} $$test_name"; \
+ fi \
+ done \
+ done; \
+ echo "$${passed} test(s) passed. $${failed} test(s) did not pass."; \
+ if [ $${failed} != 0 ]; then echo -e "\nFailed tests:\n"; \
+ for i in $${failed_tests}; do echo $${i}; done; exit 1; fi
+
+sgen-bridge-tests: sgen-bridge-tests1 sgen-bridge-tests2
+
sgen-tests: sgen-regular-tests sgen-bridge-tests
+
+#LLVM crashes, got to fix it first.
+# "--llvm|llvm" \
+# "--llvm --gc=boehm|llvm+boehm"
+
+test-aot:
+ @failed=0; \
+ passed=0; \
+ failed_tests="";\
+ profile=net_4_5; \
+ tmpfile=`mktemp -t mono_aot_output` || exit 1; \
+ rm -f test-aot-$${name}.stdout test-aot-$${name}.stderr; \
+ for assembly in $(mcs_topdir)/class/lib/$$profile/*.dll ; do \
+ asm_name=`basename $$assembly`; \
+ echo "... $$asm_name"; \
+ for conf in $(AOT_CONFIGURATIONS); do \
+ name=`echo $$conf | cut -d\| -f 2`; \
+ params=`echo $$conf | cut -d\| -f 1`; \
+ test_name="$${asm_name}|$${name}"; \
+ echo " $$test_name"; \
+ if MONO_PATH=$(mcs_topdir)/class/lib/$$profile $(JITTEST_PROG_RUN) $$params --aot=outfile=$$tmpfile $$assembly >> test-aot-$${name}.stdout 2>> test-aot-$${name}.stderr; \
+ then \
+ passed=`expr $${passed} + 1`; \
+ else \
+ failed=`expr $${failed} + 1`; \
+ failed_tests="$${failed_tests} $$test_name"; \
+ fi \
+ done; \
+ done; \
+ rm $$tmpfile; \
+ echo "$${passed} test(s) passed. $${failed} test(s) did not pass."; \
+ if [ $${failed} != 0 ]; then echo -e "\nFailed tests:\n"; \
+ for i in $${failed_tests}; do echo $${i}; done; exit 1; fi
runtime-invoke.gen.exe: TestDriver.dll gen-runtime-invoke.exe
$(RUNTIME) gen-runtime-invoke.exe > runtime-invoke.gen.cs
$(MCS) -out:runtime-invoke.gen.exe -r:TestDriver.dll runtime-invoke.gen.cs