summaryrefslogtreecommitdiff
path: root/mono/utils/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'mono/utils/Makefile.in')
-rw-r--r--mono/utils/Makefile.in94
1 files changed, 41 insertions, 53 deletions
diff --git a/mono/utils/Makefile.in b/mono/utils/Makefile.in
index d5c142c2a4..aaa3cac165 100644
--- a/mono/utils/Makefile.in
+++ b/mono/utils/Makefile.in
@@ -1,8 +1,9 @@
-# Makefile.in generated by automake 1.12.1 from Makefile.am.
+# Makefile.in generated by automake 1.11.6 from Makefile.am.
# @configure_input@
-# Copyright (C) 1994-2012 Free Software Foundation, Inc.
-
+# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
+# 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011 Free Software
+# Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -68,8 +69,7 @@ target_triplet = @target@
@S390X_TRUE@am__append_14 = mono-hwcap-s390x.c mono-hwcap-s390x.h
subdir = mono/utils
DIST_COMMON = $(libmonoutilsinclude_HEADERS) $(srcdir)/Makefile.am \
- $(srcdir)/Makefile.in $(top_srcdir)/depcomp \
- $(top_srcdir)/mkinstalldirs ChangeLog
+ $(srcdir)/Makefile.in ChangeLog
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
am__aclocal_m4_deps = $(top_srcdir)/m4/iconv.m4 \
$(top_srcdir)/m4/lib-ld.m4 $(top_srcdir)/m4/lib-link.m4 \
@@ -112,14 +112,15 @@ am__libmonoutils_la_SOURCES_DIST = mono-md5.c mono-sha1.c \
lock-free-array-queue.h mono-linked-list-set.c \
mono-linked-list-set.h mono-threads.c mono-threads-posix.c \
mono-threads-mach.c mono-threads-windows.c mono-threads.h \
- mono-tls.h linux_magic.h mono-memory-model.h atomic.h atomic.c \
- mono-hwcap.h mono-hwcap.c bsearch.h bsearch.c \
- mach-support-x86.c mach-support-amd64.c mach-support-arm.c \
- mach-support-unknown.c mono-hwcap-x86.c mono-hwcap-x86.h \
- mono-hwcap-arm.c mono-hwcap-arm.h mono-hwcap-mips.c \
- mono-hwcap-mips.h mono-hwcap-ppc.c mono-hwcap-ppc.h \
- mono-hwcap-sparc.c mono-hwcap-sparc.h mono-hwcap-ia64.c \
- mono-hwcap-ia64.h mono-hwcap-s390x.c mono-hwcap-s390x.h
+ mono-tls.h mono-tls.c linux_magic.h mono-memory-model.h \
+ atomic.h atomic.c mono-hwcap.h mono-hwcap.c bsearch.h \
+ bsearch.c mono-signal-handler.h mach-support-x86.c \
+ mach-support-amd64.c mach-support-arm.c mach-support-unknown.c \
+ mono-hwcap-x86.c mono-hwcap-x86.h mono-hwcap-arm.c \
+ mono-hwcap-arm.h mono-hwcap-mips.c mono-hwcap-mips.h \
+ mono-hwcap-ppc.c mono-hwcap-ppc.h mono-hwcap-sparc.c \
+ mono-hwcap-sparc.h mono-hwcap-ia64.c mono-hwcap-ia64.h \
+ mono-hwcap-s390x.c mono-hwcap-s390x.h
am__objects_1 = mono-md5.lo mono-sha1.lo mono-logger.lo \
mono-codeman.lo dlmalloc.lo mono-counters.lo mono-dl.lo \
mono-internal-hash.lo mono-io-portability.lo monobitset.lo \
@@ -131,8 +132,8 @@ am__objects_1 = mono-md5.lo mono-sha1.lo mono-logger.lo \
mach-support.lo mono-context.lo hazard-pointer.lo \
lock-free-queue.lo lock-free-alloc.lo lock-free-array-queue.lo \
mono-linked-list-set.lo mono-threads.lo mono-threads-posix.lo \
- mono-threads-mach.lo mono-threads-windows.lo atomic.lo \
- mono-hwcap.lo bsearch.lo
+ mono-threads-mach.lo mono-threads-windows.lo mono-tls.lo \
+ atomic.lo mono-hwcap.lo bsearch.lo
@CROSS_COMPILE_FALSE@@X86_TRUE@am__objects_2 = mach-support-x86.lo
@AMD64_TRUE@@CROSS_COMPILE_FALSE@am__objects_3 = \
@AMD64_TRUE@@CROSS_COMPILE_FALSE@ mach-support-amd64.lo
@@ -166,7 +167,7 @@ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
$(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
AM_V_CC = $(am__v_CC_@AM_V@)
am__v_CC_ = $(am__v_CC_@AM_DEFAULT_V@)
-am__v_CC_0 = @echo " CC " $@;
+am__v_CC_0 = @echo " CC " $@;
AM_V_at = $(am__v_at_@AM_V@)
am__v_at_ = $(am__v_at_@AM_DEFAULT_V@)
am__v_at_0 = @
@@ -176,10 +177,10 @@ LINK = $(LIBTOOL) $(AM_V_lt) --tag=CC $(AM_LIBTOOLFLAGS) \
$(AM_LDFLAGS) $(LDFLAGS) -o $@
AM_V_CCLD = $(am__v_CCLD_@AM_V@)
am__v_CCLD_ = $(am__v_CCLD_@AM_DEFAULT_V@)
-am__v_CCLD_0 = @echo " CCLD " $@;
+am__v_CCLD_0 = @echo " CCLD " $@;
AM_V_GEN = $(am__v_GEN_@AM_V@)
am__v_GEN_ = $(am__v_GEN_@AM_DEFAULT_V@)
-am__v_GEN_0 = @echo " GEN " $@;
+am__v_GEN_0 = @echo " GEN " $@;
SOURCES = $(libmonoutils_la_SOURCES)
DIST_SOURCES = $(am__libmonoutils_la_SOURCES_DIST)
am__can_run_installinfo = \
@@ -510,6 +511,7 @@ monoutils_sources = \
mono-threads-windows.c \
mono-threads.h \
mono-tls.h \
+ mono-tls.c \
linux_magic.h \
mono-memory-model.h \
atomic.h \
@@ -517,7 +519,8 @@ monoutils_sources = \
mono-hwcap.h \
mono-hwcap.c \
bsearch.h \
- bsearch.c
+ bsearch.c \
+ mono-signal-handler.h
arch_sources = $(am__append_1) $(am__append_2) $(am__append_3) \
$(am__append_4) $(am__append_5) $(am__append_6) \
@@ -571,14 +574,12 @@ $(am__aclocal_m4_deps):
clean-noinstLTLIBRARIES:
-test -z "$(noinst_LTLIBRARIES)" || rm -f $(noinst_LTLIBRARIES)
- @list='$(noinst_LTLIBRARIES)'; \
- locs=`for p in $$list; do echo $$p; done | \
- sed 's|^[^/]*$$|.|; s|/[^/]*$$||; s|$$|/so_locations|' | \
- sort -u`; \
- test -z "$$locs" || { \
- echo rm -f $${locs}; \
- rm -f $${locs}; \
- }
+ @list='$(noinst_LTLIBRARIES)'; for p in $$list; do \
+ dir="`echo $$p | sed -e 's|/[^/]*$$||'`"; \
+ test "$$dir" != "$$p" || dir=.; \
+ echo "rm -f \"$${dir}/so_locations\""; \
+ rm -f "$${dir}/so_locations"; \
+ done
libmonoutils.la: $(libmonoutils_la_OBJECTS) $(libmonoutils_la_DEPENDENCIES) $(EXTRA_libmonoutils_la_DEPENDENCIES)
$(AM_V_CCLD)$(LINK) $(libmonoutils_la_OBJECTS) $(libmonoutils_la_LIBADD) $(LIBS)
@@ -636,6 +637,7 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mono-threads-windows.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mono-threads.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mono-time.Plo@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mono-tls.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mono-uri.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/mono-value-hash.Plo@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/monobitset.Plo@am__quote@
@@ -742,20 +744,6 @@ GTAGS:
&& $(am__cd) $(top_srcdir) \
&& gtags -i $(GTAGS_ARGS) "$$here"
-cscopelist: $(HEADERS) $(SOURCES) $(LISP)
- list='$(SOURCES) $(HEADERS) $(LISP)'; \
- case "$(srcdir)" in \
- [\\/]* | ?:[\\/]*) sdir="$(srcdir)" ;; \
- *) sdir=$(subdir)/$(srcdir) ;; \
- esac; \
- for i in $$list; do \
- if test -f "$$i"; then \
- echo "$(subdir)/$$i"; \
- else \
- echo "$$sdir/$$i"; \
- fi; \
- done >> $(top_builddir)/cscope.files
-
distclean-tags:
-rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
@@ -903,18 +891,18 @@ uninstall-am: uninstall-libmonoutilsincludeHEADERS
.MAKE: all check install install-am install-strip
.PHONY: CTAGS GTAGS all all-am check check-am clean clean-generic \
- clean-libtool clean-noinstLTLIBRARIES cscopelist ctags \
- distclean distclean-compile distclean-generic \
- distclean-libtool distclean-tags distdir dvi dvi-am html \
- html-am info info-am install install-am install-data \
- install-data-am install-dvi install-dvi-am install-exec \
- install-exec-am install-html install-html-am install-info \
- install-info-am install-libmonoutilsincludeHEADERS install-man \
- install-pdf install-pdf-am install-ps install-ps-am \
- install-strip installcheck installcheck-am installdirs \
- maintainer-clean maintainer-clean-generic mostlyclean \
- mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
- pdf pdf-am ps ps-am tags uninstall uninstall-am \
+ clean-libtool clean-noinstLTLIBRARIES ctags distclean \
+ distclean-compile distclean-generic distclean-libtool \
+ distclean-tags distdir dvi dvi-am html html-am info info-am \
+ install install-am install-data install-data-am install-dvi \
+ install-dvi-am install-exec install-exec-am install-html \
+ install-html-am install-info install-info-am \
+ install-libmonoutilsincludeHEADERS install-man install-pdf \
+ install-pdf-am install-ps install-ps-am install-strip \
+ installcheck installcheck-am installdirs maintainer-clean \
+ maintainer-clean-generic mostlyclean mostlyclean-compile \
+ mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
+ tags uninstall uninstall-am \
uninstall-libmonoutilsincludeHEADERS