summaryrefslogtreecommitdiff
path: root/debian/patches/mips-groonga-atomic.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/mips-groonga-atomic.patch')
-rw-r--r--debian/patches/mips-groonga-atomic.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/patches/mips-groonga-atomic.patch b/debian/patches/mips-groonga-atomic.patch
new file mode 100644
index 0000000..d41c648
--- /dev/null
+++ b/debian/patches/mips-groonga-atomic.patch
@@ -0,0 +1,34 @@
+From: Debian MySQL Maintainers <pkg-mysql-maint@lists.alioth.debian.org>
+Date: Thu, 10 Aug 2017 20:40:28 +0200
+Subject: mips-groonga-atomic
+
+---
+ storage/mroonga/vendor/groonga/CMakeLists.txt | 2 ++
+ storage/mroonga/vendor/groonga/lib/CMakeLists.txt | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/storage/mroonga/vendor/groonga/CMakeLists.txt b/storage/mroonga/vendor/groonga/CMakeLists.txt
+index 2d8a59f..c1805a3 100644
+--- a/storage/mroonga/vendor/groonga/CMakeLists.txt
++++ b/storage/mroonga/vendor/groonga/CMakeLists.txt
+@@ -234,6 +234,8 @@ endmacro()
+ include(build/ac_macros/check_headers.m4)
+ include(build/ac_macros/check_functions.m4)
+
++ac_check_lib(atomic __atomic_store_8)
++
+ ac_check_symbols(fpclassify math.h)
+ ac_check_lib(m fpclassify)
+
+diff --git a/storage/mroonga/vendor/groonga/lib/CMakeLists.txt b/storage/mroonga/vendor/groonga/lib/CMakeLists.txt
+index 7825878..975bdd5 100644
+--- a/storage/mroonga/vendor/groonga/lib/CMakeLists.txt
++++ b/storage/mroonga/vendor/groonga/lib/CMakeLists.txt
+@@ -62,6 +62,7 @@ endif()
+ set_target_properties(libgroonga PROPERTIES OUTPUT_NAME "groonga")
+
+ set(GRN_ALL_LIBRARIES
++ ${ATOMIC_LIBS}
+ ${EXECINFO_LIBS}
+ ${RT_LIBS}
+ ${PTHREAD_LIBS}