summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Gevers <elbrus@debian.org>2013-12-14 20:27:35 +0100
committerPaul Gevers <elbrus@debian.org>2013-12-14 20:27:35 +0100
commit65485b6d567ee871ef49df76ed604f3867d67925 (patch)
tree549abc51db680378b9c0ba9c51b46f526fcd009f
parent63bb27a28f2a01f76bb8c619367f9df42a53b7ed (diff)
downloadfpc-65485b6d567ee871ef49df76ed604f3867d67925.tar.gz
Update d/rules for first kfreebsd bootstrapping effort
-rwxr-xr-xdebian/rules16
1 files changed, 14 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 96ce2508..afee26bf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -60,7 +60,9 @@ endif
PPNEW=$(PPPRE)$(PPSUF)
-FPCTARGET=$(CPU_TARGET)-linux
+OS_TARGET=$(subst kfreebsd,freebsd,$(shell dpkg-architecture -qDEB_HOST_ARCH_OS))
+
+FPCTARGET=$(CPU_TARGET)-$(OS_TARGET)
# Get version information from changelog file
DEB_VERSION:=$(shell dpkg-parsechangelog | grep '^Version:' | cut -f 2 -d ' ')
DEB_UPSTREAM_VERSION:=$(shell echo $(DEB_VERSION) | cut -f 1 -d -)
@@ -108,6 +110,16 @@ INSTALLOPTS=INSTALL_PREFIX=$(INSTALL_DIR)/usr PP=$(NEWPP)
export GDBLIBDIR=/usr/lib
+ifeq ($(OS_TARGET),freebsd)
+#exclude some stuff that doesn't appear to be built on kfreebsd
+#long term it might be an idea to review this list and see if there
+#is actually a way to get some of this stuff to build on kfreebsd
+#but for now getting stuff bootstrapped is the aim
+ DH_INSTALL_EXCLUDE_OPTS=-Xgrab_vcsa -Xuuid -Xopencl -Xptc -Xdbus -Xldap -Xproj4 -Xlibsee -Xlua -Xcdrom -Xnewt -Xa52 -Xdts -Xmad -Xmodplug -Xoggvorbis -Xopenal -Xdoc/fp -Xfpclasschart -Xmakeskel -Xunitdiff -Xfcl-web -Xfastcgi -Xzorba -Xfppkg
+else
+ DH_INSTALL_EXCLUDE_OPTS=
+endif
+
#specify arm variant explicitly so we can use a starting
#compiler from a different arm variant (for bootstrapping)
ifeq ($(CPU_TARGET),arm)
@@ -279,7 +291,7 @@ arrange-arch: install-arch arrange-arch-stamp install-man
arrange-arch-stamp:
dh_testdir
dh_testroot
- dh_install -s --sourcedir=debian/tmp --list-missing
+ dh_install -s --sourcedir=debian/tmp --list-missing $(DH_INSTALL_EXCLUDE_OPTS)
touch arrange-arch-stamp
build-indep: