summaryrefslogtreecommitdiff
path: root/buildconf
diff options
context:
space:
mode:
authorMark A. Hershberger <mah@debian.(none)>2009-03-25 00:34:21 -0400
committerMark A. Hershberger <mah@debian.(none)>2009-03-25 00:34:21 -0400
commit0e920280a2e04b110827bb766b9f29e3d581c4ee (patch)
tree8f2125f3d00fe3089e3b94adb06f04479ee15f2a /buildconf
downloadphp-0e920280a2e04b110827bb766b9f29e3d581c4ee.tar.gz
Imported Upstream version 5.0.4upstream/5.0.4
Diffstat (limited to 'buildconf')
-rwxr-xr-xbuildconf73
1 files changed, 73 insertions, 0 deletions
diff --git a/buildconf b/buildconf
new file mode 100755
index 000000000..1a74eeb8b
--- /dev/null
+++ b/buildconf
@@ -0,0 +1,73 @@
+#!/bin/sh
+# $Id: buildconf,v 1.62.2.2 2005/02/03 17:42:58 sniper Exp $
+
+eval `grep '^EXTRA_VERSION=' configure.in`
+case "$EXTRA_VERSION" in
+ *-dev)
+ dev=1
+ ;;
+ *)
+ dev=0
+ ;;
+esac
+
+devok=0
+debug=no
+
+while test $# -gt 0; do
+ if test "$1" = "--copy"; then
+ automake_flags=--copy
+ fi
+
+ if test "$1" = "--force"; then
+ devok=1
+ echo "Forcing buildconf"
+ fi
+
+ if test "$1" = "--debug"; then
+ debug=yes
+ fi
+
+ shift
+done
+
+if test "$dev" = "0" -a "$devok" = "0"; then
+ echo "You should not run buildconf in a release package."
+ echo "use buildconf --force to override this check."
+ exit 1
+fi
+
+if test -z "$ZENDDIR"; then
+ if grep "PHP_MAJOR_VERSION 5" main/php_version.h >/dev/null; then
+ v=5
+ else
+ v=4
+ fi
+
+ if test "$v" = "5"; then
+ if test -r "Zend/OBJECTS2_HOWTO"; then
+ :
+ else
+ mv Zend ZendEngine1 2>/dev/null
+ mv ZendEngine2 Zend
+ fi
+ else
+ if test -r "Zend/zend_execute_globals.h"; then
+ :
+ else
+ mv Zend ZendEngine2 2>/dev/null
+ mv ZendEngine1 Zend
+ fi
+ fi
+
+ ZENDDIR=Zend
+ echo "using default Zend directory"
+fi
+
+rm -f generated_lists
+
+if test "$debug" = "yes"; then
+ ${MAKE:-make} -s -f build/build.mk AMFLAGS="$automake_flags" ZENDDIR="$ZENDDIR" SUPPRESS_WARNINGS=""
+else
+ ${MAKE:-make} -s -f build/build.mk AMFLAGS="$automake_flags" ZENDDIR="$ZENDDIR"
+fi