summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorStig Sandbeck Mathisen <ssm@debian.org>2012-10-11 10:11:58 +0200
committerStig Sandbeck Mathisen <ssm@debian.org>2012-10-11 10:20:44 +0200
commit1071ecf84ae1ec4aec6cdb3336e28fed9f3948b8 (patch)
tree3efa553bf7c59f3f7b82392e6e87738ac37ebc2c /debian
parent7f49226fe04238c505e67d007d7510e9bc1baf54 (diff)
downloadpuppet-1071ecf84ae1ec4aec6cdb3336e28fed9f3948b8.tar.gz
Use upstream provided installer script
Diffstat (limited to 'debian')
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules14
2 files changed, 4 insertions, 11 deletions
diff --git a/debian/control b/debian/control
index 001e6bdd4..53ca231fc 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,7 @@ Maintainer: Puppet Package Maintainers <pkg-puppet-devel@lists.alioth.debian.org
Uploaders: Micah Anderson <micah@debian.org>, Andrew Pollock <apollock@debian.org>, Nigel Kersten <nigel@explanatorygap.net>, Stig Sandbeck Mathisen <ssm@debian.org>
Build-Depends:
debhelper (>= 9~),
+ facter,
gem2deb (>= 0.2.13~),
rake,
ruby-rspec,
diff --git a/debian/rules b/debian/rules
index a85f6e2f3..ec31230c8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,22 +11,14 @@ export DH_RUBY_USE_DH_AUTO_INSTALL_DESTDIR=1
%:
dh $@ --buildsystem=ruby --with ruby
-override_dh_auto_build:
- # This should really not be necessary: create gem, extract metadata, remove gem…
- # (dh_ruby will otherwise try to build everything in "ext/*")
- rake create_gem
- tar -O -x -f pkg/puppet-*.gem metadata.gz | gunzip -c > metadata.yml
- rake clobber_package
- # This should really not be necessary: copy "sbin" binaries into "bin"…
- # (dh_ruby does not support "sbindir", only "bindir")
- rake prepare_gem
- dh_auto_build -O--buildsystem=ruby
-
override_dh_installinit:
dh_installinit -ppuppetmaster
dh_installinit --name=puppetqd
dh_installinit -ppuppet --error-handler=true -- defaults 21
+override_dh_auto_install:
+ ./install.rb --destdir=debian/tmp --sitelibdir=/usr/lib/ruby/vendor_ruby
+
override_dh_install:
dh_install -O--buildsystem=ruby
mv debian/puppetmaster-passenger/usr/share/puppetmaster-passenger/apache2.conf \