summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules2
2 files changed, 6 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index f15ad2170..99acbb8c5 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -24,9 +24,11 @@ puppet (0.24.8-2) unstable; urgency=high
* debian/control: add rdoc, libopenssl-ruby and facter to build dependencies
* debian/control: depend on ruby1.8 instead of ruby to placate Lintian
* debian/puppet.install: brown paper bag release averted; install
- /usr/lib/ruby1.8
+ /usr/lib/ruby/1.8
+ * debian/rules: ensure permissions on everything under /usr/lib/ruby/1.8 is
+ correct
- -- Andrew Pollock <apollock@debian.org> Tue, 16 Jun 2009 23:29:22 -0700
+ -- Andrew Pollock <apollock@debian.org> Tue, 16 Jun 2009 23:37:22 -0700
puppet (0.24.8-1) unstable; urgency=low
diff --git a/debian/rules b/debian/rules
index ee690624e..ab08c2ba8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -51,6 +51,8 @@ install: build
# strip executable bit from all the non-executable files.
find debian/tmp/usr/lib/ruby/1.8 -type f -perm /u+x,g+x,o+x -exec chmod a-x {} \;
+ # fix the permissions on all of the directories
+ find debian/tmp/usr/lib/ruby/1.8 -type d -exec chmod 755 {} \;
# Vim auto-syntax-highlighting stuff
$(INSTALL) -m0644 ext/vim/syntax/puppet.vim \