summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules2
1 files changed, 2 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index ee690624e..ab08c2ba8 100755
--- a/debian/rules
+++ b/debian/rules
@@ -51,6 +51,8 @@ install: build
# strip executable bit from all the non-executable files.
find debian/tmp/usr/lib/ruby/1.8 -type f -perm /u+x,g+x,o+x -exec chmod a-x {} \;
+ # fix the permissions on all of the directories
+ find debian/tmp/usr/lib/ruby/1.8 -type d -exec chmod 755 {} \;
# Vim auto-syntax-highlighting stuff
$(INSTALL) -m0644 ext/vim/syntax/puppet.vim \