summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorbubulle <bubulle@alioth.debian.org>2009-08-20 19:46:16 +0000
committerbubulle <bubulle@alioth.debian.org>2009-08-20 19:46:16 +0000
commit0433fe32f154ea550c6d43fe443f91f0c9a36440 (patch)
treedb350c7c1e67d25850765ce8b80276c00de1427f
parent5eff92bd1873e33e0338c2e8bfef5443d7db9bb0 (diff)
downloadsamba-0433fe32f154ea550c6d43fe443f91f0c9a36440.tar.gz
Fix "invalid argument" when trying to copy a file from smb share
Use an upstream patch that will be included in 3.4.1 git-svn-id: svn://svn.debian.org/svn/pkg-samba/trunk/samba@2993 fc4039ab-9d04-0410-8cac-899223bdd6b0
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/536757.patch20
-rw-r--r--debian/patches/series1
3 files changed, 27 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 8841a051c4..ccf965f567 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,8 +1,14 @@
samba (2:3.4.0-3) UNRELEASED; urgency=low
+ [ Steve Langasek ]
* debian/control: samba-common-bin has no reason to depend on
libpam-modules.
+ [ Christian Perrier ]
+ * Fix "invalid argument" when trying to copy a file from smb share
+ Use an upstream patch that will be included in 3.4.1
+ Closes: #536757
+
-- Steve Langasek <vorlon@debian.org> Tue, 18 Aug 2009 18:34:30 -0700
samba (2:3.4.0-2) unstable; urgency=low
diff --git a/debian/patches/536757.patch b/debian/patches/536757.patch
new file mode 100644
index 0000000000..acc540858f
--- /dev/null
+++ b/debian/patches/536757.patch
@@ -0,0 +1,20 @@
+Goal: fix failure to copy files when the size returned from a read is
+ zero
+
+Fixes: bug #536757
+
+Upstream status: will be fixed in 3.4.1
+
+Index: samba/source3/libsmb/clireadwrite.c
+===================================================================
+--- samba.orig/source3/libsmb/clireadwrite.c 2009-08-20 15:52:33.000000000 +0200
++++ samba/source3/libsmb/clireadwrite.c 2009-08-20 16:06:12.000000000 +0200
+@@ -185,7 +185,7 @@
+ buf = (uint8_t *)smb_base(cli_req->inbuf) + SVAL(vwv+6, 0);
+
+ if (trans_oob(smb_len(cli_req->inbuf), SVAL(vwv+6, 0), size)
+- || (buf < bytes)) {
++ || (size && (buf < bytes))) {
+ DEBUG(5, ("server returned invalid read&x data offset\n"));
+ return NT_STATUS_INVALID_NETWORK_RESPONSE;
+ }
diff --git a/debian/patches/series b/debian/patches/series
index cbc2e57ae2..e9289c17f3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -12,3 +12,4 @@ smbtar-bashism.patch
no-unnecessary-cups.patch
fix-manpages-warnings.patch
codepages-location.patch
+536757.patch