summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Geyer <debfx-pkg@fobos.de>2009-09-19 12:55:33 +0200
committerFelix Geyer <debfx-pkg@fobos.de>2009-09-19 12:55:33 +0200
commitf448dabd1f75871f8a5e661ec75fd40c0fa8d5ee (patch)
tree596bef25f26a40a0d6f3515d01b0bda5c98fd5e8
parent1f8cbdb2d32f6bd619a422618749308fddb004c4 (diff)
downloadkbuild-f448dabd1f75871f8a5e661ec75fd40c0fa8d5ee.tar.gz
Added patch from Fedora to fix build on POSIX.1-2008 systems
-rw-r--r--debian/changelog6
-rw-r--r--debian/patches/kbuild-dprintf-posix2008.diff38
-rw-r--r--debian/patches/series1
3 files changed, 45 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 484b25b..baf3008 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+kbuild (1:0.1.98svn2318-4) UNRELEASED; urgency=low
+
+ * Added patch from Fedora to fix build on POSIX.1-2008 systems
+
+ -- Felix Geyer <debfx-pkg@fobos.de> Sat, 19 Sep 2009 12:06:17 +0200
+
kbuild (1:0.1.98svn2318-3) unstable; urgency=low
* Added patch to fix build on GNU/kFreeBSD. (Closes: #540665) - thanks
diff --git a/debian/patches/kbuild-dprintf-posix2008.diff b/debian/patches/kbuild-dprintf-posix2008.diff
new file mode 100644
index 0000000..58887f4
--- /dev/null
+++ b/debian/patches/kbuild-dprintf-posix2008.diff
@@ -0,0 +1,38 @@
+This dprintf() collides with POSIX.1-2008 dprintf() and is not used at all
+anyways. (Whoa! what a stupid name! standardized before invention of grep!)
+
+Lubomir Rintel <lkundrak@v3.sk>
+
+diff -up kBuild-0.1.5/src/ash/output.c.gcc44 kBuild-0.1.5/src/ash/output.c
+--- kBuild-0.1.5/src/ash/output.c.gcc44 2009-04-13 01:20:33.857017054 +0200
++++ kBuild-0.1.5/src/ash/output.c 2009-04-13 01:20:57.570033297 +0200
+@@ -230,6 +230,7 @@ out1fmt(const char *fmt, ...)
+ va_end(ap);
+ }
+
++#if 0
+ void
+ dprintf(const char *fmt, ...)
+ {
+@@ -240,6 +241,7 @@ dprintf(const char *fmt, ...)
+ va_end(ap);
+ flushout(out2);
+ }
++#endif
+
+ void
+ fmtstr(char *outbuf, size_t length, const char *fmt, ...)
+diff -up kBuild-0.1.5/src/ash/output.h.gcc44 kBuild-0.1.5/src/ash/output.h
+--- kBuild-0.1.5/src/ash/output.h.gcc44 2009-04-13 01:20:37.724140366 +0200
++++ kBuild-0.1.5/src/ash/output.h 2009-04-13 01:20:47.933142098 +0200
+@@ -65,8 +65,10 @@ void outfmt(struct output *, const char
+ __attribute__((__format__(__printf__,2,3)));
+ void out1fmt(const char *, ...)
+ __attribute__((__format__(__printf__,1,2)));
++#if 0
+ void dprintf(const char *, ...)
+ __attribute__((__format__(__printf__,1,2)));
++#endif
+ void fmtstr(char *, size_t, const char *, ...)
+ __attribute__((__format__(__printf__,3,4)));
+ void doformat(struct output *, const char *, va_list);
diff --git a/debian/patches/series b/debian/patches/series
index bb62ffc..e76b958 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,2 +1,3 @@
kbuild-gnukfreebsd.diff
kbuild-sh4.diff
+kbuild-dprintf-posix2008.diff