summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Meskes <meskes@debian.org>2008-01-01 13:56:33 +0000
committerMichael Meskes <meskes@debian.org>2008-01-01 13:56:33 +0000
commit6228b654879af7b676daf093b9ab8f938fa494d6 (patch)
tree127562a9988c176dfe73b38c683fc9f4dee77a08
parent138f913f6a15971d8e39d56feaa72ac48c4ccee8 (diff)
downloadvirtualbox-debian/1.5.4-dfsg-1.tar.gz
Release 1.5.4-dfsg-1debian/1.5.4-dfsg-1
-rw-r--r--debian/changelog9
-rw-r--r--debian/patches/00list2
-rw-r--r--debian/patches/02-host-module.dpatch18
-rwxr-xr-xdebian/patches/02-module-in-kernel.dpatch213
-rwxr-xr-xdebian/patches/08-module-build.dpatch20
-rwxr-xr-xdebian/rules2
-rw-r--r--debian/virtualbox-ose-guest-source.dirs4
-rw-r--r--debian/virtualbox-ose-guest-source.install24
-rw-r--r--debian/virtualbox-ose-guest-source.links4
9 files changed, 249 insertions, 47 deletions
diff --git a/debian/changelog b/debian/changelog
index 14b688f76..603a6fc4d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-virtualbox-ose (1.5.4-dfsg-1) UNRELEASED; urgency=low
+virtualbox-ose (1.5.4-dfsg-1) unstable; urgency=low
[ Michael Meskes ]
* Do not build guest-utils on amd64 because 64bit guests are nor support
@@ -21,6 +21,11 @@ virtualbox-ose (1.5.4-dfsg-1) UNRELEASED; urgency=low
* g++-multilib on amd64 depends on libc6-dev-i386, no need to specify both
as build dependency.
* Manually install missing include files for guest-sources.
+ * Changed layout of guest-sources package to not have to patch the Makefile.
+ * Changed patch accordingly.
+ * Removed old 02-host-module patch, it wasn't needed anymore.
+ * Added new patch 02-module-in-kernel to make sure modules build in a kernel
+ build environment.
[ Hilko Bengen ]
* Make dh_strip ignore symlink(s) in /usr/share
@@ -32,7 +37,7 @@ virtualbox-ose (1.5.4-dfsg-1) UNRELEASED; urgency=low
* Syncronising Uploaders of control with control.module.in.
* Rediffed all patches properly.
- -- Michael Meskes <meskes@debian.org> Sun, 30 Dec 2007 14:45:07 +0100
+ -- Michael Meskes <meskes@debian.org> Tue, 01 Jan 2008 14:26:51 +0100
virtualbox-ose (1.5.2-dfsg2-7) unstable; urgency=low
diff --git a/debian/patches/00list b/debian/patches/00list
index ec152a8e0..bf90af92e 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -1,5 +1,5 @@
01-no-64bit-guest.dpatch
-02-host-module.dpatch
+02-module-in-kernel.dpatch
03-config-kmk.dpatch
04-localconf-kmk.dpatch
05-vboxdrv-references.dpatch
diff --git a/debian/patches/02-host-module.dpatch b/debian/patches/02-host-module.dpatch
deleted file mode 100644
index 33f687d44..000000000
--- a/debian/patches/02-host-module.dpatch
+++ /dev/null
@@ -1,18 +0,0 @@
-#!/bin/sh /usr/share/dpatch/dpatch-run
-## 02-host-module.dpatch by Torsten Werner <twerner@debian.org>
-##
-## DP: Added KERN_DIR to the HostDrivers Makefile.
-
-@DPATCH@
-
-diff -Naurp virtualbox-ose-1.5.4-dfsg.orig/src/VBox/HostDrivers/Support/linux/Makefile virtualbox-ose-1.5.4-dfsg/src/VBox/HostDrivers/Support/linux/Makefile
---- virtualbox-ose-1.5.4-dfsg.orig/src/VBox/HostDrivers/Support/linux/Makefile 2007-10-12 21:19:22.000000000 +0000
-+++ virtualbox-ose-1.5.4-dfsg/src/VBox/HostDrivers/Support/linux/Makefile 2007-12-30 06:29:05.000000000 +0000
-@@ -59,6 +59,7 @@ endif
- ifneq ($(MAKECMDGOALS),clean)
-
- # kernel base directory
-+KERN_DIR := $(KDIR)
- ifndef KERN_DIR
- # build for the current kernel, version check
- KERN_DIR := /lib/modules/$(shell uname -r)/build
diff --git a/debian/patches/02-module-in-kernel.dpatch b/debian/patches/02-module-in-kernel.dpatch
new file mode 100755
index 000000000..be44f1eb0
--- /dev/null
+++ b/debian/patches/02-module-in-kernel.dpatch
@@ -0,0 +1,213 @@
+#!/bin/sh /usr/share/dpatch/dpatch-run
+## 02-module-in-kernel.dpatch by Michael Meskes <meskes@debian.org>
+##
+## DP: Make sure modules build in a kernel build environment.
+
+@DPATCH@
+
+--- virtualbox-ose-1.5.4-dfsg/src/VBox/Additions/linux/sharedfolders/Makefile.module.orig 2007-09-24 22:13:56.000000000 +0200
++++ virtualbox-ose-1.5.4-dfsg/src/VBox/Additions/linux/sharedfolders/Makefile.module 2008-01-01 13:03:53.000000000 +0100
+@@ -38,28 +38,30 @@
+
+ ifneq ($(MAKECMDGOALS),clean)
+
+-# kernel base directory
+-ifndef KERN_DIR
+- KERN_DIR := /lib/modules/$(shell uname -r)/build
+- ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
+- KERN_DIR := /usr/src/linux
++ifeq ($(KERNELRELEASE),)
++ # kernel base directory
++ ifndef KERN_DIR
++ KERN_DIR := /lib/modules/$(shell uname -r)/build
+ ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
+- $(error Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.)
++ KERN_DIR := /usr/src/linux
++ ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
++ $(error Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.)
++ endif
++ $(warning Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.)
++ endif
++ else
++ ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
++ $(error Error: KERN_DIR does not point to a directory.)
+ endif
+- $(warning Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.)
+- endif
+-else
+- ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
+- $(error Error: KERN_DIR does not point to a directory.)
+ endif
+-endif
+
+-# includes
+-ifndef KERN_INCL
+- KERN_INCL = $(KERN_DIR)/include
+-endif
+-ifneq ($(shell if test -d $(KERN_INCL); then echo yes; fi),yes)
+- $(error Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.)
++ # includes
++ ifndef KERN_INCL
++ KERN_INCL = $(KERN_DIR)/include
++ endif
++ ifneq ($(shell if test -d $(KERN_INCL); then echo yes; fi),yes)
++ $(error Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.)
++ endif
+ endif
+
+ # module install dir.
+@@ -95,7 +97,10 @@
+ # Compiler options
+ #
+ ifndef INCL
+- INCL := -I$(KERN_INCL) $(addprefix -I, $(EXTRA_INCL))
++ ifeq ($(KERNELRELEASE),)
++ INCL := -I$(KERN_INCL)
++ endif
++ INCL += $(addprefix -I, $(EXTRA_INCL))
+ ifndef KBUILD_EXTMOD
+ KBUILD_EXTMOD := $(shell pwd)
+ endif
+--- virtualbox-ose-1.5.4-dfsg/src/VBox/HostDrivers/Support/linux/Makefile.orig 2008-01-01 12:58:40.000000000 +0100
++++ virtualbox-ose-1.5.4-dfsg/src/VBox/HostDrivers/Support/linux/Makefile 2008-01-01 13:00:24.000000000 +0100
+@@ -58,37 +58,39 @@
+
+ ifneq ($(MAKECMDGOALS),clean)
+
+-# kernel base directory
+-ifndef KERN_DIR
+- # build for the current kernel, version check
+- KERN_DIR := /lib/modules/$(shell uname -r)/build
+- ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
+- KERN_DIR := /usr/src/linux
++ifeq ($(KERNELRELEASE),)
++ # kernel base directory
++ ifndef KERN_DIR
++ # build for the current kernel, version check
++ KERN_DIR := /lib/modules/$(shell uname -r)/build
+ ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
+- $(error Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.)
++ KERN_DIR := /usr/src/linux
++ ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
++ $(error Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.)
++ endif
++ $(warning Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.)
+ endif
+- $(warning Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.)
+- endif
+- # check if versions match -- works only for later 2.6 kernels
+- VBOX_KERN_VER := $(shell $(MAKE) -sC $(KERN_DIR) kernelrelease 2> /dev/null || true)
+- ifneq ($(VBOX_KERN_VER),)
+- ifneq ($(VBOX_KERN_VER),$(shell uname -r))
+- $(error Error: /usr/src/linux (version $(VBOX_KERN_VER)) does not match the current kernel (version $(shell uname -r)))
++ # check if versions match -- works only for later 2.6 kernels
++ VBOX_KERN_VER := $(shell $(MAKE) -sC $(KERN_DIR) kernelrelease 2> /dev/null || true)
++ ifneq ($(VBOX_KERN_VER),)
++ ifneq ($(VBOX_KERN_VER),$(shell uname -r))
++ $(error Error: /usr/src/linux (version $(VBOX_KERN_VER)) does not match the current kernel (version $(shell uname -r)))
++ endif
++ endif
++ else
++ # build for a dedicated kernel, no version check
++ ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
++ $(error Error: KERN_DIR does not point to a directory.)
+ endif
+ endif
+-else
+- # build for a dedicated kernel, no version check
+- ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
+- $(error Error: KERN_DIR does not point to a directory.)
+- endif
+-endif
+
+-# includes
+-ifndef KERN_INCL
+- KERN_INCL = $(KERN_DIR)/include
+-endif
+-ifneq ($(shell if test -d $(KERN_INCL); then echo yes; fi),yes)
+- $(error Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.)
++ # includes
++ ifndef KERN_INCL
++ KERN_INCL = $(KERN_DIR)/include
++ endif
++ ifneq ($(shell if test -d $(KERN_INCL); then echo yes; fi),yes)
++ $(error Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.)
++ endif
+ endif
+
+ # module install dir, only for current kernel
+@@ -118,7 +120,10 @@
+ # Compiler options
+ #
+ ifndef INCL
+- INCL := -I$(KERN_INCL) $(addprefix -I, $(EXTRA_INCL))
++ ifeq ($(KERNELRELEASE),)
++ INCL := -I$(KERN_INCL)
++ endif
++ INCL += $(addprefix -I, $(EXTRA_INCL))
+ ifndef KBUILD_EXTMOD
+ KBUILD_EXTMOD := $(shell pwd)
+ endif
+--- virtualbox-ose-1.5.4-dfsg/src/VBox/Additions/linux/module/Makefile.module.orig 2008-01-01 13:19:09.000000000 +0100
++++ virtualbox-ose-1.5.4-dfsg/src/VBox/Additions/linux/module/Makefile.module 2008-01-01 13:20:44.000000000 +0100
+@@ -31,28 +31,30 @@
+
+ ifneq ($(MAKECMDGOALS),clean)
+
+-# kernel base directory
+-ifndef KERN_DIR
+- KERN_DIR := /lib/modules/$(shell uname -r)/build
+- ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
+- KERN_DIR := /usr/src/linux
++ifeq ($(KERNELRELEASE),)
++ # kernel base directory
++ ifndef KERN_DIR
++ KERN_DIR := /lib/modules/$(shell uname -r)/build
+ ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
+- $(error Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.)
++ KERN_DIR := /usr/src/linux
++ ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
++ $(error Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.)
++ endif
++ $(warning Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.)
++ endif
++ else
++ ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
++ $(error Error: KERN_DIR does not point to a directory.)
+ endif
+- $(warning Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.)
+- endif
+-else
+- ifneq ($(shell if test -d $(KERN_DIR); then echo yes; fi),yes)
+- $(error Error: KERN_DIR does not point to a directory.)
+ endif
+-endif
+
+-# includes
+-ifndef KERN_INCL
+- KERN_INCL = $(KERN_DIR)/include
+-endif
+-ifneq ($(shell if test -d $(KERN_INCL); then echo yes; fi),yes)
+- $(error Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.)
++ # includes
++ ifndef KERN_INCL
++ KERN_INCL = $(KERN_DIR)/include
++ endif
++ ifneq ($(shell if test -d $(KERN_INCL); then echo yes; fi),yes)
++ $(error Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again.)
++ endif
+ endif
+
+ # module install dir.
+@@ -88,7 +90,10 @@
+ # Compiler options
+ #
+ ifndef INCL
+- INCL := -I$(KERN_INCL) $(addprefix -I, $(EXTRA_INCL))
++ ifeq ($(KERNELRELEASE),)
++ INCL := -I$(KERN_INCL)
++ endif
++ INCL += $(addprefix -I, $(EXTRA_INCL))
+ ifndef KBUILD_EXTMOD
+ KBUILD_EXTMOD := $(shell pwd)
+ endif
diff --git a/debian/patches/08-module-build.dpatch b/debian/patches/08-module-build.dpatch
index cfbca5680..77d5ca206 100755
--- a/debian/patches/08-module-build.dpatch
+++ b/debian/patches/08-module-build.dpatch
@@ -1,7 +1,7 @@
#!/bin/sh /usr/share/dpatch/dpatch-run
## 08-module-build.dpatch by Michael Meskes <meskes@debian.org>
##
-## DP: Build module correctly in linux-modules-extra.
+## DP: Build module with correct name in linux-modules-extra.
@DPATCH@
@@ -17,15 +17,6 @@ diff -Naurp virtualbox-ose-1.5.4-dfsg.orig/src/VBox/Additions/linux/module/Makef
OBJS = \
cmc.o \
hgcmcall.o \
-@@ -92,6 +92,8 @@ ifndef INCL
- ifndef KBUILD_EXTMOD
- KBUILD_EXTMOD := $(shell pwd)
- endif
-+# make sure we have a correct path
-+ KBUILD_EXTMOD := $(subst $(MODULE),,$(KBUILD_EXTMOD))/$(MODULE)
- INCL += $(addprefix -I$(KBUILD_EXTMOD),/ /include /r0drv/linux)
- export INCL
- endif
diff -Naurp virtualbox-ose-1.5.4-dfsg.orig/src/VBox/Additions/linux/sharedfolders/Makefile.module virtualbox-ose-1.5.4-dfsg/src/VBox/Additions/linux/sharedfolders/Makefile.module
--- virtualbox-ose-1.5.4-dfsg.orig/src/VBox/Additions/linux/sharedfolders/Makefile.module 2007-09-24 20:13:56.000000000 +0000
+++ virtualbox-ose-1.5.4-dfsg/src/VBox/Additions/linux/sharedfolders/Makefile.module 2007-12-30 06:33:32.000000000 +0000
@@ -38,15 +29,6 @@ diff -Naurp virtualbox-ose-1.5.4-dfsg.orig/src/VBox/Additions/linux/sharedfolder
OBJS = \
vfsmod.o \
vfs-utils.o \
-@@ -99,6 +99,8 @@ ifndef INCL
- ifndef KBUILD_EXTMOD
- KBUILD_EXTMOD := $(shell pwd)
- endif
-+# make sure we have a correct path
-+ KBUILD_EXTMOD := $(subst $(MODULE),,$(KBUILD_EXTMOD))/$(MODULE)
- INCL += $(addprefix -I$(KBUILD_EXTMOD),/ /include /r0drv/linux)
- export INCL
- endif
diff -Naurp virtualbox-ose-1.5.4-dfsg.orig/src/VBox/HostDrivers/Support/linux/Makefile virtualbox-ose-1.5.4-dfsg/src/VBox/HostDrivers/Support/linux/Makefile
--- virtualbox-ose-1.5.4-dfsg.orig/src/VBox/HostDrivers/Support/linux/Makefile 2007-10-12 21:19:22.000000000 +0000
+++ virtualbox-ose-1.5.4-dfsg/src/VBox/HostDrivers/Support/linux/Makefile 2007-12-30 06:33:32.000000000 +0000
diff --git a/debian/rules b/debian/rules
index fb4ded814..5cdbcc353 100755
--- a/debian/rules
+++ b/debian/rules
@@ -122,6 +122,7 @@ binary-indep: build install
# These files have incorrect permissions, fixing it.
chmod 755 debian/$(psource)/usr/src/modules/$(sname)/debian/rules
chmod 755 debian/$(gsource)/usr/src/modules/$(gname)/debian/rules
+ dh_link -i
# Create .tar.bz2 for virtualbox*source
cd debian/$(psource)/usr/src && \
tar -cjf $(sname).tar.bz2 modules && \
@@ -129,7 +130,6 @@ binary-indep: build install
cd debian/$(gsource)/usr/src && \
tar -cjf $(gname).tar.bz2 modules && \
rm -rf modules
- dh_link -i
dh_compress -i
dh_fixperms -i
dh_gencontrol -i
diff --git a/debian/virtualbox-ose-guest-source.dirs b/debian/virtualbox-ose-guest-source.dirs
index 39250eda6..b21f52b9e 100644
--- a/debian/virtualbox-ose-guest-source.dirs
+++ b/debian/virtualbox-ose-guest-source.dirs
@@ -1 +1,5 @@
usr/src/modules/virtualbox-ose-guest/debian
+usr/src/modules/virtualbox-ose-guest/include/iprt
+usr/src/modules/virtualbox-ose-guest/include/VBox
+usr/src/modules/virtualbox-ose-guest/include/internal
+usr/src/modules/virtualbox-ose-guest/r0drv/linux
diff --git a/debian/virtualbox-ose-guest-source.install b/debian/virtualbox-ose-guest-source.install
index ea5c8184c..6e800e892 100644
--- a/debian/virtualbox-ose-guest-source.install
+++ b/debian/virtualbox-ose-guest-source.install
@@ -1,10 +1,22 @@
-out/bin/additions/src/vboxadd /usr/src/modules/virtualbox-ose-guest
-out/bin/src/include/iprt/heap.h /usr/src/modules/virtualbox-ose-guest/vboxadd/include/iprt
-out/bin/src/include/iprt/spinlock.h /usr/src/modules/virtualbox-ose-guest/vboxadd/include/iprt
+out/bin/additions/src/vboxadd/*.* /usr/src/modules/virtualbox-ose-guest/vboxadd
+out/bin/additions/src/vboxadd/build_in_tmp /usr/src/modules/virtualbox-ose-guest/vboxadd
+out/bin/additions/src/vboxadd/Makefile /usr/src/modules/virtualbox-ose-guest/vboxadd
-out/bin/additions/src/vboxvfs /usr/src/modules/virtualbox-ose-guest
-out/bin/src/include/iprt/heap.h /usr/src/modules/virtualbox-ose-guest/vboxvfs/include/iprt
-out/bin/src/include/iprt/spinlock.h /usr/src/modules/virtualbox-ose-guest/vboxvfs/include/iprt
+out/bin/additions/src/vboxvfs/*.* /usr/src/modules/virtualbox-ose-guest/vboxvfs
+out/bin/additions/src/vboxvfs/build_in_tmp /usr/src/modules/virtualbox-ose-guest/vboxvfs
+out/bin/additions/src/vboxvfs/Makefile /usr/src/modules/virtualbox-ose-guest/vboxvfs
+
+out/bin/additions/src/vboxadd/include/iprt/* /usr/src/modules/virtualbox-ose-guest/include/iprt
+out/bin/src/include/iprt/heap.h /usr/src/modules/virtualbox-ose-guest/include/iprt
+out/bin/src/include/iprt/spinlock.h /usr/src/modules/virtualbox-ose-guest/include/iprt
+out/bin/additions/src/vboxadd/include/VBox/* /usr/src/modules/virtualbox-ose-guest/include/VBox
+out/bin/additions/src/vboxadd/include/internal/* /usr/src/modules/virtualbox-ose-guest/include/internal
+
+out/bin/additions/src/vboxvfs/include/iprt/* /usr/src/modules/virtualbox-ose-guest/include/iprt
+out/bin/additions/src/vboxvfs/include/VBox/* /usr/src/modules/virtualbox-ose-guest/include/VBox
+out/bin/additions/src/vboxvfs/include/internal/* /usr/src/modules/virtualbox-ose-guest/include/internal
+
+out/bin/additions/src/vboxadd/r0drv /usr/src/modules/virtualbox-ose-guest/
debian/control debian/changelog debian/copyright debian/compat /usr/src/modules/virtualbox-ose-guest/debian
debian/virtualbox-ose-guest-source.files/Makefile /usr/src/modules/virtualbox-ose-guest
diff --git a/debian/virtualbox-ose-guest-source.links b/debian/virtualbox-ose-guest-source.links
index 645a68c9f..2b350a390 100644
--- a/debian/virtualbox-ose-guest-source.links
+++ b/debian/virtualbox-ose-guest-source.links
@@ -1 +1,5 @@
/usr/share/modass/packages/default.sh /usr/share/modass/overrides/virtualbox-ose-guest-source
+/usr/src/modules/virtualbox-ose-guest/r0drv /usr/src/modules/virtualbox-ose-guest/vboxadd/r0drv
+/usr/src/modules/virtualbox-ose-guest/r0drv /usr/src/modules/virtualbox-ose-guest/vboxvfs/r0drv
+/usr/src/modules/virtualbox-ose-guest/include /usr/src/modules/virtualbox-ose-guest/vboxadd/include
+/usr/src/modules/virtualbox-ose-guest/include /usr/src/modules/virtualbox-ose-guest/vboxvfs/include