summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Meskes <meskes@debian.org>2008-10-03 16:30:47 +0000
committerMichael Meskes <meskes@debian.org>2008-10-03 16:30:47 +0000
commita83dde176e7f9ba2c82fe5a72a6f4c7a91afebf8 (patch)
tree2abeb541ab094b7ef3f3fb068cdd5cfa8719db6e
parentb9908a6b0deaa326a8e540caf6f9623c936d5beb (diff)
downloadvirtualbox-debian/1.6.2-dfsg-7.tar.gz
Started preparing a 1.6.2-dfsg-7 for Lenny.debian/1.6.2-dfsg-7
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/00list1
-rwxr-xr-xdebian/patches/15-rate-limit-PATM-messages.dpatch36
3 files changed, 44 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index de40ae98e..cd0af420c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+virtualbox-ose (1.6.2-dfsg-7) testing-proposed-updates; urgency=low
+
+ * Stop spamming log files by using patch provided by Stefan Lippers-Hollmann
+ <s.L-H@gmx.de>, closes: #500484
+
+ -- Michael Meskes <meskes@debian.org> Fri, 03 Oct 2008 17:28:55 +0200
+
virtualbox-ose (1.6.2-dfsg-6) unstable; urgency=medium
* Apply changesets 12299, 12303, 12305, 12307 and 12308 from upstream SVN
diff --git a/debian/patches/00list b/debian/patches/00list
index a613690ce..cd4324bce 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -12,3 +12,4 @@
12-make-module.dpatch
13-module-mismatch.dpatch
14-recompiler-flush-tb-cache.dpatch
+15-rate-limit-PATM-messages.dpatch
diff --git a/debian/patches/15-rate-limit-PATM-messages.dpatch b/debian/patches/15-rate-limit-PATM-messages.dpatch
new file mode 100755
index 000000000..ec24500a8
--- /dev/null
+++ b/debian/patches/15-rate-limit-PATM-messages.dpatch
@@ -0,0 +1,36 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 15-rate-limit-PATM-messages.dpatch by Stefan Lippers-Hollmann <s.l-h@gmx.de>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: http://www.virtualbox.de/ticket/1775
+## DP: rediff the following upstream commits against virtualbox-ose 1.6.6-dfsg-1:
+## DP: - r12524
+## DP: - r12525
+## DP: - r12527
+## DP: - r12532
+## DP: - r12534
+
+@DPATCH@
+diff -urNad virtualbox-ose-1.6.6-dfsg~/src/VBox/VMM/PATM/PATM.cpp virtualbox-ose-1.6.6-dfsg/src/VBox/VMM/PATM/PATM.cpp
+--- virtualbox-ose-1.6.6-dfsg~/src/VBox/VMM/PATM/PATM.cpp 2008-06-25 17:47:15.000000000 +0200
++++ virtualbox-ose-1.6.6-dfsg/src/VBox/VMM/PATM/PATM.cpp 2008-09-28 18:19:19.000000000 +0200
+@@ -97,6 +97,9 @@
+ };
+ #endif
+
++/* Don't want to break saved states, so put it here as a global variable. */
++static unsigned int cIDTHandlersDisabled = 0;
++
+ /**
+ * Initializes the PATM.
+ *
+@@ -4962,7 +4965,8 @@
+ if (iGate != (uint32_t)~0)
+ {
+ TRPMR3SetGuestTrapHandler(pVM, iGate, TRPM_INVALID_HANDLER);
+- LogRel(("PATM: Disabling IDT %x patch handler %VGv\n", iGate, pInstrGC));
++ if (++cIDTHandlersDisabled < 256)
++ LogRel(("PATM: Disabling IDT %x patch handler %VGv\n", iGate, pInstrGC));
+ }
+ }
+