summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog3
-rw-r--r--debian/patches/00list1
-rw-r--r--debian/patches/11-module-build.dpatch44
3 files changed, 48 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index a1843e969..37b983f57 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
virtualbox-ose (1.5.2-dfsg2-3) unstable; urgency=low
* Added patch to remove registration form, closes: #447626, #453784
+ * Added just another patch to make sure module is build with the correct
+ name when build by linux-modules-extra, closes: #453681, #454123
+ * Patched Makefile for guest modules for the same reason.
-- Michael Meskes <meskes@debian.org> Sun, 02 Dec 2007 18:06:27 +0100
diff --git a/debian/patches/00list b/debian/patches/00list
index f8868035d..e3b578970 100644
--- a/debian/patches/00list
+++ b/debian/patches/00list
@@ -8,4 +8,5 @@
08-no-kernel.dpatch
09-quiet-grep.dpatch
10-no-registration.dpatch
+11-module-build.dpatch
diff --git a/debian/patches/11-module-build.dpatch b/debian/patches/11-module-build.dpatch
new file mode 100644
index 000000000..a0a697b1f
--- /dev/null
+++ b/debian/patches/11-module-build.dpatch
@@ -0,0 +1,44 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 11-module-build.dpatch by <meskes@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Build module correctly in linux-modules-extra
+
+@DPATCH@
+
+diff -ruN virtualbox-ose-1.5.2-dfsg2.orig/src/VBox/Additions/linux/module/Makefile.module virtualbox-ose-1.5.2-dfsg2/src/VBox/Additions/linux/module/Makefile.module
+--- virtualbox-ose-1.5.2-dfsg2.orig/src/VBox/Additions/linux/module/Makefile.module 2007-10-18 13:07:28.000000000 +0200
++++ virtualbox-ose-1.5.2-dfsg2/src/VBox/Additions/linux/module/Makefile.module 2007-12-03 13:35:34.000000000 +0100
+@@ -14,7 +14,7 @@
+ # be useful, but WITHOUT ANY WARRANTY of any kind.
+
+ #
+-MODULE = vboxadd
++override MODULE = vboxadd
+ OBJS = \
+ cmc.o \
+ hgcmcall.o \
+diff -ruN virtualbox-ose-1.5.2-dfsg2.orig/src/VBox/Additions/linux/sharedfolders/Makefile.module virtualbox-ose-1.5.2-dfsg2/src/VBox/Additions/linux/sharedfolders/Makefile.module
+--- virtualbox-ose-1.5.2-dfsg2.orig/src/VBox/Additions/linux/sharedfolders/Makefile.module 2007-10-18 13:07:28.000000000 +0200
++++ virtualbox-ose-1.5.2-dfsg2/src/VBox/Additions/linux/sharedfolders/Makefile.module 2007-12-03 13:35:46.000000000 +0100
+@@ -14,7 +14,7 @@
+ # be useful, but WITHOUT ANY WARRANTY of any kind.
+
+ #
+-MODULE = vboxvfs
++override MODULE = vboxvfs
+ OBJS = \
+ vfsmod.o \
+ vfs-utils.o \
+diff -ruN virtualbox-ose-1.5.2-dfsg2.orig/src/VBox/HostDrivers/Support/linux/Makefile virtualbox-ose-1.5.2-dfsg2/src/VBox/HostDrivers/Support/linux/Makefile
+--- virtualbox-ose-1.5.2-dfsg2.orig/src/VBox/HostDrivers/Support/linux/Makefile 2007-10-18 13:07:28.000000000 +0200
++++ virtualbox-ose-1.5.2-dfsg2/src/VBox/HostDrivers/Support/linux/Makefile 2007-12-03 13:33:25.000000000 +0100
+@@ -40,7 +40,7 @@
+ endif
+
+
+-MODULE = vboxdrv
++override MODULE = vboxdrv
+ OBJS = \
+ linux/SUPDrv-linux.o \
+ SUPDRVShared.o \