summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2008-03-29 12:14:35 +0100
committerMichael Biebl <biebl@debian.org>2008-03-29 12:14:35 +0100
commit4c6437ca18921f789bb02f527a1449d2c7a951a5 (patch)
treea9ed5b761c48918e1da0e5f6de6d8e96d98c4f9e
parentb0dbc76eaaf1c7f51b3aea1ea359b3a7e9882d20 (diff)
downloadrsyslog-4c6437ca18921f789bb02f527a1449d2c7a951a5.tar.gz
Imported Debian patch 1.19.7-2debian/1.19.7-2
-rw-r--r--debian/changelog9
-rw-r--r--debian/control5
-rw-r--r--debian/patches/series1
-rw-r--r--debian/patches/udp_msg_reception.patch48
4 files changed, 59 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index 76592eb..af69621 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+rsyslog (1.19.7-2) unstable; urgency=low
+
+ * debian/patches/udp_msg_reception.patch
+ - Pull patch from CVS which fixes broken UDP message reception.
+ * debian/control
+ - Use the new "Homepage:" field to specify the upstream URL.
+
+ -- Michael Biebl <biebl@debian.org> Fri, 28 Sep 2007 15:30:06 +0200
+
rsyslog (1.19.7-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/control b/debian/control
index 601f7e0..e912603 100644
--- a/debian/control
+++ b/debian/control
@@ -4,6 +4,7 @@ Priority: extra
Maintainer: Michael Biebl <biebl@debian.org>
Build-Depends: debhelper (>= 5), quilt, autotools-dev, zlib1g-dev, libmysqlclient15-dev
Standards-Version: 3.7.2
+Homepage: http://www.rsyslog.com/
Package: rsyslog
Architecture: any
@@ -27,8 +28,6 @@ Description: enhanced multi-threaded syslogd
replacement. Its advanced features make it suitable for enterprise-class,
encryption protected syslog relay chains while at the same time being very
easy to setup for the novice user.
- .
- Homepage: http://www.rsyslog.com/
Package: rsyslog-mysql
Architecture: any
@@ -36,5 +35,3 @@ Depends: ${shlibs:Depends}, ${misc:Depends}, rsyslog (= ${binary:Version}), dbco
Recommends: mysql-server
Description: MySQL output plugin for rsyslog
This plugin allows rsyslog to write the syslog messages into a MySQL database.
- .
- Homepage: http://www.rsyslog.com/
diff --git a/debian/patches/series b/debian/patches/series
index f6e71f8..cc77b34 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
ignore_non_conf_files.patch -p0
no_create_db.patch
man_page_format.patch -p0
+udp_msg_reception.patch -p0
diff --git a/debian/patches/udp_msg_reception.patch b/debian/patches/udp_msg_reception.patch
new file mode 100644
index 0000000..b8ab15c
--- /dev/null
+++ b/debian/patches/udp_msg_reception.patch
@@ -0,0 +1,48 @@
+--- net.c 2007/09/24 13:32:25 1.9
++++ net.c 2007/09/26 12:28:56 1.10
+@@ -190,8 +190,11 @@
+ }
+
+ finalize_it:
++dbgprintf("hname() iRet: %d\n", iRet);
+ return iRet;
+ }
++
++
+ /* Return a printable representation of a host address.
+ * Now (2007-07-16) also returns the full host name (if it could be obtained)
+ * in the second param [thanks to mildew@gmail.com for the patch].
+@@ -242,7 +245,6 @@
+ if ((p = (uchar*) strchr((char*)pszHost, '.'))) { /* find start of domain name "machine.example.com" */
+ if(strcmp((char*) (p + 1), LocalDomain) == 0) {
+ *p = '\0'; /* simply terminate the string */
+- return 1;
+ } else {
+ /* now check if we belong to any of the domain names that were specified
+ * in the -s command line option. If so, remove and we are done.
+@@ -252,7 +254,7 @@
+ while (StripDomains[count]) {
+ if (strcmp((char*)(p + 1), StripDomains[count]) == 0) {
+ *p = '\0';
+- return 1;
++ FINALIZE; /* we are done */
+ }
+ count++;
+ }
+@@ -270,7 +272,7 @@
+ while (LocalHosts[count]) {
+ if (!strcmp((char*)pszHost, LocalHosts[count])) {
+ *p = '\0';
+- return 1;
++ break; /* we are done */
+ }
+ count++;
+ }
+@@ -279,6 +281,7 @@
+ }
+
+ finalize_it:
++dbgprintf("cvthname() iRet: %d\n", iRet);
+ return iRet;
+ }
+