summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2013-03-20 11:43:25 +0100
committerMichael Biebl <biebl@debian.org>2013-03-20 11:43:27 +0100
commit84c8b39deb879d1c70312966c877325b1911d51a (patch)
tree8fade8810e8b9bd121f637ba49633c8f7d6d2cfc
parent28947a6e531c5a488f487b5e391848defbf906c6 (diff)
downloadrsyslog-84c8b39deb879d1c70312966c877325b1911d51a.tar.gz
Fix build on non-Linux
The previous fix was incomplete. Cherry-pick another upstream patch to fix the build failure on non-Linux. (Closes: #703429)
-rw-r--r--debian/changelog7
-rw-r--r--debian/patches/03-build-non-linux.patch23
-rw-r--r--debian/patches/series1
3 files changed, 31 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 15fdf8b..79558b3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+rsyslog (7.3.8-3) UNRELEASED; urgency=low
+
+ * The previous fix was incomplete. Cherry-pick another upstream patch to fix
+ the build failure on non-Linux. (Closes: #703429)
+
+ -- Michael Biebl <biebl@debian.org> Wed, 20 Mar 2013 11:42:10 +0100
+
rsyslog (7.3.8-2) experimental; urgency=low
* Cherry pick patch from upstream which fixes the build on architectures
diff --git a/debian/patches/03-build-non-linux.patch b/debian/patches/03-build-non-linux.patch
new file mode 100644
index 0000000..6b08104
--- /dev/null
+++ b/debian/patches/03-build-non-linux.patch
@@ -0,0 +1,23 @@
+commit 7784b65d8709fba647a7beeb934c18b7cb8cb6f1
+Author: Rainer Gerhards <rgerhards@adiscon.com>
+Date: Wed Mar 20 10:24:36 2013 +0100
+
+ bugfix: build on non-linux platforms failed
+
+ The previous fix for this was incomplete.
+
+diff --git a/runtime/wtp.c b/runtime/wtp.c
+index f8d3588..19151e7 100644
+--- a/runtime/wtp.c
++++ b/runtime/wtp.c
+@@ -381,9 +381,9 @@ wtpWorker(void *arg) /* the arg is actually a wti object, even though we are in
+ if(prctl(PR_SET_NAME, thrdName, 0, 0, 0) != 0) {
+ DBGPRINTF("prctl failed, not setting thread name for '%s'\n", wtpGetDbgHdr(pThis));
+ }
++ dbgOutputTID((char*)thrdName);
+ # endif
+
+- dbgOutputTID((char*)thrdName);
+ pthread_cleanup_push(wtpWrkrExecCancelCleanup, pWti);
+ wtiWorker(pWti);
+ pthread_cleanup_pop(0);
diff --git a/debian/patches/series b/debian/patches/series
index 8bc190a..567658e 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -1,3 +1,4 @@
# Debian patches for rsyslog
01-dont_create_db.patch
02-sys-gettid.patch
+03-build-non-linux.patch