summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2008-03-29 12:14:41 +0100
committerMichael Biebl <biebl@debian.org>2008-03-29 12:14:41 +0100
commit81367522c83c4b1b8cb157925e103edc9f148cd4 (patch)
tree0e1a01f2e2787fa9044c33acef57171308499d97 /configure.ac
parent8a0b3535fa5eb747cf28cee9c3b281a2fe00c6b4 (diff)
downloadrsyslog-81367522c83c4b1b8cb157925e103edc9f148cd4.tar.gz
Imported Upstream version 1.19.12upstream/1.19.12
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 5 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2856fee..8425ea5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT([rsyslog],[1.19.10],[rsyslog@lists.adiscon.com.])
+AC_INIT([rsyslog],[1.19.12],[rsyslog@lists.adiscon.com.])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([syslogd.c])
AC_CONFIG_HEADER([config.h])
@@ -143,8 +143,10 @@ if test "x$enable_pthreads" != "xno"; then
[pthread_create],
[
AC_DEFINE([USE_PTHREADS], [1], [Multithreading support enabled.])
- pthreads_libs="-lpthread"
- AC_SUBST(pthreads_libs)
+ pthreads_libs="-lpthread"
+ pthreads_cflags="-pthread"
+ AC_SUBST(pthreads_libs)
+ AC_SUBST(pthreads_cflags)
],
[AC_MSG_FAILURE([pthread is missing])],
[-lpthread]