summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2013-01-09 00:02:49 +0100
committerMichael Biebl <biebl@debian.org>2013-01-09 00:02:49 +0100
commit3793efd744861415cbb0e10df6ac9eab7b21e78e (patch)
tree41b82e478e0e35e6583057eb1196409265d4dabc /configure.ac
parented0fad5385d95f30f7073bf3013e4ecabc4b29e4 (diff)
downloadrsyslog-3793efd744861415cbb0e10df6ac9eab7b21e78e.tar.gz
Imported Upstream version 7.2.5upstream/7.2.5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 7 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index e1f7b37..14a33c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT([rsyslog],[7.2.4],[rsyslog@lists.adiscon.com])
+AC_INIT([rsyslog],[7.2.5],[rsyslog@lists.adiscon.com])
AM_INIT_AUTOMAKE
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -243,22 +243,7 @@ AM_CONDITIONAL(ENABLE_GSSAPI, test x$enable_gssapi_krb5 = xyes)
# multithreading via pthreads
-AC_ARG_ENABLE(pthreads,
- [AS_HELP_STRING([--enable-pthreads],[Enable multithreading via pthreads @<:@default=yes@:>@])],
- [case "${enableval}" in
- yes) enable_pthreads="yes" ;;
- no) enable_pthreads="no" ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-pthreads) ;;
- esac],
- [enable_pthreads=yes]
-)
-
-if test "x$enable_pthreads" = "xno"; then
- AC_MSG_ERROR(rsyslog v3+ does no longer support single threading mode -- use a previous version for that);
-fi
-
-if test "x$enable_pthreads" != "xno"; then
- AC_CHECK_HEADERS(
+AC_CHECK_HEADERS(
[pthread.h],
[
AC_CHECK_LIB(
@@ -279,8 +264,7 @@ if test "x$enable_pthreads" != "xno"; then
)
],
[AC_MSG_FAILURE([pthread is missing])]
- )
-fi
+)
AC_CHECK_FUNCS(
[pthread_setschedparam],
@@ -711,13 +695,13 @@ AC_SUBST(SNMP_LIBS)
AC_ARG_ENABLE(uuid,
[AS_HELP_STRING([--enable-uuid],[Enable support for uuid generation @<:@default=yes@:>@])],
[case "${enableval}" in
- yes) enable_elasticsearch="yes" ;;
- no) enable_elasticsearch="no" ;;
+ yes) enable_uuid="yes" ;;
+ no) enable_uuid="no" ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-uuid) ;;
esac],
[enable_uuid=yes]
)
-if test "x$enable_elasticsearch" = "xyes"; then
+if test "x$enable_uuid" = "xyes"; then
PKG_CHECK_MODULES([LIBUUID], [uuid])
AC_DEFINE(USE_LIBUUID, 1, [Define if you want to enable libuuid support])
fi
@@ -736,6 +720,7 @@ AC_ARG_ENABLE(elasticsearch,
)
if test "x$enable_elasticsearch" = "xyes"; then
PKG_CHECK_MODULES([CURL], [libcurl])
+ LT_LIB_M
fi
AM_CONDITIONAL(ENABLE_ELASTICSEARCH, test x$enable_elasticsearch = xyes)