summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2008-05-03 09:59:54 +0200
committerMichael Biebl <biebl@debian.org>2008-05-03 09:59:54 +0200
commit24b3073e74d910f3c45ccfb1ad56c8e601eb2bc7 (patch)
tree93dad4af1ef471584f16db99a8a5b53fd2a259df /configure.ac
parentd7b2091ccb935f85ad5ad43e8fb1d467ff63f979 (diff)
downloadrsyslog-upstream/3.16.1.tar.gz
Imported Upstream version 3.16.1upstream/3.16.1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 4 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index e2bda20..8f10720 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT([rsyslog],[3.14.2],[rsyslog@lists.adiscon.com])
+AC_INIT([rsyslog],[3.16.1],[rsyslog@lists.adiscon.com])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([syslogd.c])
AC_CONFIG_HEADERS([config.h])
@@ -466,26 +466,11 @@ AC_ARG_ENABLE(relp,
[enable_relp=no]
)
if test "x$enable_relp" = "xyes"; then
- AC_CHECK_HEADERS(
- [librelp.h],,
- [AC_MSG_FAILURE([RELP library is missing (no headers)])]
- )
-# I don't know how to tell that librelp needs -lrt, so I disable
-# this check for now - the header check should work well enough...
-# rgerhards, 2008-03-25
-# AC_CHECK_LIB(
-# [relp],
-# [relpEngineGetVersion],
-# [relp_cflags=""
- relp_libs="-lrelp"
-# ],
-# [AC_MSG_FAILURE([RELP library is missing])]
-# )
+ PKG_CHECK_MODULES(RELP, relp)
fi
AM_CONDITIONAL(ENABLE_RELP, test x$enable_relp = xyes)
-AC_SUBST(relp_cflags)
-AC_SUBST(relp_libs)
-
+AC_SUBST(RELP_CFLAGS)
+AC_SUBST(RELP_LIBS)
# RFC 3195 support
# WARNING: THIS IS NOT REALLY PRESENT YET - needs to be build manually!