summaryrefslogtreecommitdiff
path: root/plugins
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2008-03-29 12:14:41 +0100
committerMichael Biebl <biebl@debian.org>2008-03-29 12:14:41 +0100
commit81367522c83c4b1b8cb157925e103edc9f148cd4 (patch)
tree0e1a01f2e2787fa9044c33acef57171308499d97 /plugins
parent8a0b3535fa5eb747cf28cee9c3b281a2fe00c6b4 (diff)
downloadrsyslog-81367522c83c4b1b8cb157925e103edc9f148cd4.tar.gz
Imported Upstream version 1.19.12upstream/1.19.12
Diffstat (limited to 'plugins')
-rw-r--r--plugins/ommysql/Makefile.am2
-rw-r--r--plugins/ommysql/Makefile.in3
2 files changed, 3 insertions, 2 deletions
diff --git a/plugins/ommysql/Makefile.am b/plugins/ommysql/Makefile.am
index f388d1a..e6faa44 100644
--- a/plugins/ommysql/Makefile.am
+++ b/plugins/ommysql/Makefile.am
@@ -2,7 +2,7 @@ pkglibdir = $(libdir)/rsyslog
pkglib_LTLIBRARIES = ommysql.la
ommysql_la_SOURCES = ommysql.c ommysql.h
-ommysql_la_CPPFLAGS = $(mysql_cflags) -I$(srcdir)/../..
+ommysql_la_CPPFLAGS = $(mysql_cflags) -I$(srcdir)/../.. $(pthreads_cflags)
ommysql_la_LDFLAGS = -module -avoid-version
ommysql_la_LIBADD = $(mysql_libs)
diff --git a/plugins/ommysql/Makefile.in b/plugins/ommysql/Makefile.in
index df92d6d..c88933d 100644
--- a/plugins/ommysql/Makefile.in
+++ b/plugins/ommysql/Makefile.in
@@ -176,6 +176,7 @@ pdfdir = @pdfdir@
prefix = @prefix@
program_transform_name = @program_transform_name@
psdir = @psdir@
+pthreads_cflags = @pthreads_cflags@
pthreads_libs = @pthreads_libs@
sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
@@ -187,7 +188,7 @@ top_srcdir = @top_srcdir@
zlib_libs = @zlib_libs@
pkglib_LTLIBRARIES = ommysql.la
ommysql_la_SOURCES = ommysql.c ommysql.h
-ommysql_la_CPPFLAGS = $(mysql_cflags) -I$(srcdir)/../..
+ommysql_la_CPPFLAGS = $(mysql_cflags) -I$(srcdir)/../.. $(pthreads_cflags)
ommysql_la_LDFLAGS = -module -avoid-version
ommysql_la_LIBADD = $(mysql_libs)
EXTRA_DIST = createDB.sql contrib/delete_mysql