summaryrefslogtreecommitdiff
path: root/runtime
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2012-10-11 22:22:19 +0200
committerMichael Biebl <biebl@debian.org>2012-10-11 22:22:19 +0200
commit64b89c604c6cec4fd0de51f2776f95b34e388bae (patch)
treecfa1988f2f451baaa4a0e145d7263b8e888a8cef /runtime
parent5b0595cc98c012dfa5ac0f214dbc543a11c982cb (diff)
downloadrsyslog-64b89c604c6cec4fd0de51f2776f95b34e388bae.tar.gz
Imported Upstream version 7.1.10upstream/7.1.10
Diffstat (limited to 'runtime')
-rw-r--r--runtime/Makefile.in6
-rw-r--r--runtime/objomsr.c4
2 files changed, 6 insertions, 4 deletions
diff --git a/runtime/Makefile.in b/runtime/Makefile.in
index 7e5ea49..d606ec2 100644
--- a/runtime/Makefile.in
+++ b/runtime/Makefile.in
@@ -62,7 +62,11 @@ sbin_PROGRAMS =
subdir = runtime
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
-am__aclocal_m4_deps = $(top_srcdir)/configure.ac
+am__aclocal_m4_deps = $(top_srcdir)/m4/atomic_operations.m4 \
+ $(top_srcdir)/m4/atomic_operations_64bit.m4 \
+ $(top_srcdir)/m4/libtool.m4 $(top_srcdir)/m4/ltoptions.m4 \
+ $(top_srcdir)/m4/ltsugar.m4 $(top_srcdir)/m4/ltversion.m4 \
+ $(top_srcdir)/m4/lt~obsolete.m4 $(top_srcdir)/configure.ac
am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
$(ACLOCAL_M4)
mkinstalldirs = $(install_sh) -d
diff --git a/runtime/objomsr.c b/runtime/objomsr.c
index 9cf3781..e63eb68 100644
--- a/runtime/objomsr.c
+++ b/runtime/objomsr.c
@@ -42,9 +42,7 @@ rsRetVal OMSRdestruct(omodStringRequest_t *pThis)
/* free the strings */
if(pThis->ppTplName != NULL) {
for(i = 0 ; i < pThis->iNumEntries ; ++i) {
- if(pThis->ppTplName[i] != NULL) {
- free(pThis->ppTplName[i]);
- }
+ free(pThis->ppTplName[i]);
}
free(pThis->ppTplName);
}