summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorJan Christoph Nordholz <hesso@pool.math.tu-berlin.de>2007-07-22 13:39:43 +0200
committerAxel Beckert <abe@deuxchevaux.org>2011-09-03 14:05:29 +0200
commit0ecca7c3afba341ba769b9362703d32e993bd6da (patch)
tree0fe9c490fc6e93d034bcb0dbdcdcbee34d3dd011 /debian/rules
parent0711c7461923f458b557dc5b63f21b0be23221b4 (diff)
downloadscreen-0ecca7c3afba341ba769b9362703d32e993bd6da.tar.gz
Imported Debian patch 4.0.3-1debian/4.0.3-1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules62
1 files changed, 27 insertions, 35 deletions
diff --git a/debian/rules b/debian/rules
index c1e1d9d..da3bd0b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,18 +7,25 @@
# Uncomment me to turn on debugging
#export DH_VERBOSE=1
-# the debhelper compatability version
-export DH_COMPAT=3
-
-package = screen
-
-ROOT = $(shell pwd)/debian/$(package)
-
+package := screen
+ROOT := $(shell pwd)/debian/$(package)
# statically define this... sucko
-TTYGROUP = 5
+TTYGROUP := 5
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f configure-stamp build-stamp
+ test ! -s doc/Makefile || $(MAKE) -C doc realclean
+ test ! -s Makefile || ! grep -q clean Makefile || $(MAKE) realclean
+ rm -f config.log config.status Makefile
+ dpatch deapply-all
+ dh_clean
+configure: configure-stamp
configure-stamp:
dh_testdir
+ dpatch apply-all
./configure --prefix=/usr \
--infodir='$$(prefix)/share/info' \
--mandir='$$(prefix)/share/man' \
@@ -29,62 +36,47 @@ configure-stamp:
--enable-rxvt_osc \
--with-sys-screenrc=/etc/screenrc
# --enable-colors256
+ # Asserting the use of fifos instead of sockets
+ grep -q "define.*NAMEDPIPE.*1" config.h
touch $@
build: build-stamp
-build-stamp: configure-stamp
+build-stamp: configure
dh_testdir
$(MAKE) CFLAGS+='-O2 -g -Wall'
- for file in doc/screen.texinfo doc/screen.1 ; do \
- sed -f debian/mod_docs.sed $${file} > $${file}.new && \
- mv $${file}.new $${file} ; \
- done
+ $(MAKE) CFLAGS+='-O2 -g -Wall' -C doc
touch $@
-clean:
- dh_testdir
- dh_testroot
- rm -f configure-stamp build-stamp
- # clean up after the build process
- -$(MAKE) clean
- rm -rf config.status
- dh_clean
-
install: build
dh_testdir
dh_testroot
- dh_clean -k
+ dh_clean
dh_installdirs
# can't call the normal install target b/c it installs the info files
# and other crud
$(MAKE) prefix=$(ROOT)/usr SCREENENCODINGS='$$(prefix)/share/screen/utf8encodings' installdirs install_bin
# install the debian screenrc to etc
install -m 644 debian/screenrc $(ROOT)/etc
- # hack around the fact that the install target makes screen a symlink
- # to screen-$(VERSION)
+ # hack around the fact that the install target makes screen a symlink to screen-$(VERSION)
rm -f $(ROOT)/usr/bin/screen
mv -f $(ROOT)/usr/bin/screen* $(ROOT)/usr/bin/screen
# make it setgid utmp
chown root:utmp $(ROOT)/usr/bin/screen
chmod 2755 $(ROOT)/usr/bin/screen
- chown root:utmp $(ROOT)/var/run/screen
- chmod 775 $(ROOT)/var/run/screen
+ # don't distribute /var/run/screen, it is created in postinst
+ rm -rf $(ROOT)/var
# lintian overrides for the setgid bin etc
install -m 755 -d $(ROOT)/usr/share/lintian/overrides
install -m 644 debian/screen.lintian.overrides $(ROOT)/usr/share/lintian/overrides/screen
- # cheat a little here and copy the README.terminfo into the terminfo
- # dir for dh_installdocs to pick up later
- install -m 644 debian/README.terminfo terminfo
-
-binary-indep: build install
binary: binary-arch
-
+binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
dh_installdebconf
dh_installdocs
+ cp debian/README.terminfo $(ROOT)/usr/share/doc/screen/terminfo/
dh_installexamples
dh_installman || true
dh_installinfo
@@ -92,11 +84,11 @@ binary-arch: build install
dh_installinit --no-start --init-script='screen-cleanup' --update-rcd-params='start 70 S .'
dh_strip
dh_compress
- dh_fixperms -X/usr/bin/screen -X/var/run/screen
+ dh_fixperms -X/usr/bin/screen
dh_installdeb
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
-.PHONY: build clean binary-indep binary-arch binary install
+.PHONY: configure build clean binary-indep binary-arch binary install