summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard A Nelson (Rick) <cowboy@debian.org>2007-05-22 23:00:00 +0000
committerAndreas Beckmann <debian@abeckmann.de>2012-10-01 19:59:15 +0200
commit5f9f63b182081abcafc869a3fdfb164d3260431a (patch)
tree780f1bd4a13461d0e9bcd64751aa36b2696dcbe7
parentd6430271e61e46982620d351e0719280373717ab (diff)
downloadsendmail-5f9f63b182081abcafc869a3fdfb164d3260431a.tar.gz
Imported Debian patch 8.14.1-4debian/8.14.1-4
-rw-r--r--debian/build/autoconf.mk6
-rw-r--r--debian/build/site.config.m4.in106
-rw-r--r--debian/changelog6
-rw-r--r--debian/local/sendmail.in4
-rwxr-xr-xdebian/rules20
5 files changed, 82 insertions, 60 deletions
diff --git a/debian/build/autoconf.mk b/debian/build/autoconf.mk
index dbb2331..c99bc5a 100644
--- a/debian/build/autoconf.mk
+++ b/debian/build/autoconf.mk
@@ -2,7 +2,7 @@
#------------------------------------------------------------------------------
# vim: syntax=make
#
-# $Sendmail: autoconf.mk,v 8.14.1 2007-05-21 16:46:55 cowboy Exp $
+# $Sendmail: autoconf.mk,v 8.14.1 2007-05-22 16:57:59 cowboy Exp $
#
# Copyright (c) 1998-2007 Richard Nelson. All Rights Reserved.
#
@@ -16,7 +16,7 @@
# on Debian slink, potato, woody, testing, sid, ...
# but the generated file is customized to the version noted above.
#
-# Richard Nelson <cowboy@debian.org> 2007-05-21 16:46:55 (-0700)
+# Richard Nelson <cowboy@debian.org> 2007-05-22 16:57:59 (-0700)
#------------------------------------------------------------------------------
#SHELL := /bin/sh -x
@@ -62,7 +62,7 @@ INSTALL_SCRIPT := ${INSTALL} -m 0755
# AutoConfig generated
AC_CC := x86_64-linux-gnu-gcc
-AC_CFLAGS := -g -O2
+AC_CFLAGS := -fpie -fstack-protector-all -Wl,-z,relro -Wl,-z,now
AC_DEFS := -DPACKAGE_NAME=\"Sendmail\" -DPACKAGE_TARNAME=\"sendmail\" -DPACKAGE_VERSION=\"8.14.1\" -DPACKAGE_STRING=\"Sendmail\ 8.14.1\" -DPACKAGE_BUGREPORT=\"bug/reportbug\ or\ sendmail@packages.debian.org\" -DPACKAGE=\"sendmail\" -DVERSION=\"8.14.1\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_REGEX_H=1 -DHAVE_DB_H=1 -DHAVE_DB_185_H=1 -DHAVE_RPCSVC_YPCLNT_H=1 -DHAVE_RPCSVC_NIS_H=1 -DHAVE_LDAP_H=1 -DHAVE_RESOLV_H=1 -DHAVE_TCPD_H=1 -DHAVE_NETINET_IP6_H=1 -DHAVE_GETADDRINFO=1 -DHAVE_MAILLOCK_H=1 -DHAVE_SASL_SASL_H=1 -DHAVE_OPENSSL_SSL_H=1
AC_LDFLAGS :=
AC_LIBS :=
diff --git a/debian/build/site.config.m4.in b/debian/build/site.config.m4.in
index 1f1e410..93b5267 100644
--- a/debian/build/site.config.m4.in
+++ b/debian/build/site.config.m4.in
@@ -159,66 +159,66 @@ APPENDDEF(`conf_vacation_LIBS', `@sm_vacation_libs@')
# Global Build time configuration
#------------------------------------------------------------------
# compilation/link
-define(`confCC', `@CC@')dnl #Compiler
-define(`confOPTIMIZE', `@CFLAGS@')dnl #Optimization
-define(`confCCOPTS', `')dnl #CC options
-define(`confCCOPTS_SO' `-fPIC')dnl #Shared libraries
-define(`confLD', confCC)dnl #Linker
-define(`confLDOPTS', `')dnl #Linker opts
-define(`confLDOPTS_SO', `-shared -Wl')dnl #linker shared lib
-define(`confLIBDIRS', `')dnl #-L linker flags
-define(`confMTCCOPTS', `-D_REENTRANT')dnl #Multi-thread cc opts
-define(`confMTLDOPTS', `-lpthread')dnl #Multi-thread ld opts
-define(`confSHAREDLIB_EXT', `.so')dnl #
-define(`confSHAREDLIB_SUFFIX', `')dnl #
-define(`confSHAREDLIBDIR', `@libdir@')dnl #
-define(`confSONAME',`-soname') #
+define(`confCC', `@CC@')dnl #Compiler
+define(`confOPTIMIZE', `@CFLAGS@')dnl #Optimization
+define(`confCCOPTS', `')dnl #CC options
+define(`confCCOPTS_SO' `-fPIC')dnl #Shared libraries
+define(`confLD', confCC)dnl #Linker
+define(`confLDOPTS', `')dnl #Linker opts
+define(`confLDOPTS_SO', `-shared -Wl')dnl #linker shared lib
+define(`confLIBDIRS', `')dnl #-L linker flags
+define(`confMTCCOPTS', `-D_REENTRANT')dnl #Multi-thread cc opts
+define(`confMTLDOPTS', `-lpthread')dnl #Multi-thread ld opts
+define(`confSHAREDLIB_EXT', `.so')dnl #
+define(`confSHAREDLIB_SUFFIX', `')dnl #
+define(`confSHAREDLIBDIR', `@libdir@')dnl #
+define(`confSONAME',`-soname')dnl #
#
# paths, owners, and modes
# Note: can't use smmsp here, it is dynamically created
# Note: EBINDIR deserves a better home, suggestions?
-define(`confEBINDIR', `@libexecdir@')dnl #mail.local,smrsh,etc.
-define(`confGBINGRP', `mail')dnl #sgid binary group smmsp
-define(`confGBINMODE', `02755')dnl #sgid binary mode
-define(`confGBINOWN', `root')dnl #sgid binary owner
-define(`confHFDIR', `@sysconfdir@/mail')dnl #helpfile dir
-define(`confHFFILE', `helpfile')dnl #helpfile name
-define(`confINCGRP', `root')dnl #include group
-define(`confINCMODE', `0744')dnl #include mode
-define(`confINCOWN', `root')dnl #include owner
+define(`confEBINDIR', `@libexecdir@')dnl #mail.local,smrsh,etc.
+define(`confGBINGRP', `mail')dnl #sgid binary group smmsp
+define(`confGBINMODE', `02755')dnl #sgid binary mode
+define(`confGBINOWN', `root')dnl #sgid binary owner
+define(`confHFDIR', `@sysconfdir@/mail')dnl #helpfile dir
+define(`confHFFILE', `helpfile')dnl #helpfile name
+define(`confINCGRP', `root')dnl #include group
+define(`confINCMODE', `0744')dnl #include mode
+define(`confINCOWN', `root')dnl #include owner
ifelse(eval(@sm_version_math@ >= 527363), `1',dnl
-`define(`confINCLUDEDIR',`@includedir@')dnl #include target',
+`define(`confINCLUDEDIR',`@includedir@')dnl #include target',
`define(`confINCLUDEDIR',`@includedir@/libmilter')dnl #include target'
)dnl
-define(`confINST_DEP', `')dnl #submit.cf clientmqueue
-define(`confLIBDIR', `@libdir@/libmilter')dnl #library dir
-define(`confLIBGRP', `root')dnl #library group
-define(`confLIBMODE', `0744')dnl #library mode
-define(`confLIBOWN', `root')dnl #library owner
-define(`confMANROOT', `@mandir@/man')dnl #man root
-define(`confMANROOTMAN',`@mandir@/man')dnl #man root
-define(`confMANGRP', `root')dnl #man group
-define(`confMANMODE', `0744')dnl #man mode
-define(`confMANOWN', `root')dnl #man owner
-define(`confMBINDIR', `@libexecdir@')dnl #MTA bindir @sbindir@
-define(`confMBINGRP', `root')dnl #MTA bin grp
-define(`confMBINMODE', `0755')dnl #MTA bin mode
-define(`confMBINOWN', `root')dnl #MTA bin owner
-define(`confMSPQOWN', `mail')dnl #MSP queue owner smmsp
+define(`confINST_DEP', `')dnl #submit.cf clientmqueue
+define(`confLIBDIR', `@libdir@/libmilter')dnl #library dir
+define(`confLIBGRP', `root')dnl #library group
+define(`confLIBMODE', `0744')dnl #library mode
+define(`confLIBOWN', `root')dnl #library owner
+define(`confMANROOT', `@mandir@/man')dnl #man root
+define(`confMANROOTMAN',`@mandir@/man')dnl #man root
+define(`confMANGRP', `root')dnl #man group
+define(`confMANMODE', `0744')dnl #man mode
+define(`confMANOWN', `root')dnl #man owner
+define(`confMBINDIR', `@libexecdir@')dnl #MTA bindir @sbindir@
+define(`confMBINGRP', `root')dnl #MTA bin grp
+define(`confMBINMODE', `0755')dnl #MTA bin mode
+define(`confMBINOWN', `root')dnl #MTA bin owner
+define(`confMSPQOWN', `mail')dnl #MSP queue owner smmsp
define(`confMSP_QUEUE_DIR', `/var/spool/mqueue-client')dnl
-define(`confSBINDIR', `@libexecdir@')dnl #suid bin dir @sbindir@
-define(`confSBINGRP', `root')dnl #suid bin grp
-define(`confSBINMODE', `04755')dnl #suid bin mode
-define(`confSBINOWN', `root')dnl #suid bin owner
+define(`confSBINDIR', `@libexecdir@')dnl #suid bin dir @sbindir@
+define(`confSBINGRP', `root')dnl #suid bin grp
+define(`confSBINMODE', `04755')dnl #suid bin mode
+define(`confSBINOWN', `root')dnl #suid bin owner
# Note, STDIR in /var/lib/sendmail... default is /var/spool/mqueue
-define(`confSTDIR', `@localstatedir@/lib/sendmail')dnl #Statistics dir
-define(`confSTFILE', `statistics')dnl #statistics name
-define(`confMSP_STFILE',`sm-client.st')dnl #MSP statistics name
-define(`confSTMODE', `0660')dnl #statistics mode
-define(`confUBINDIR', `@libexecdir@')dnl #usr bin dir @bindir@
-define(`confUBINGRP', `mail')dnl #usr bin grp smmsp
-define(`confUBINMODE', `0755')dnl #usr bin mode
-define(`confUBINOWN', `root')dnl #usr bin owner
+define(`confSTDIR', `@localstatedir@/lib/sendmail')dnl #Statistics dir
+define(`confSTFILE', `statistics')dnl #statistics name
+define(`confMSP_STFILE',`sm-client.st')dnl #MSP statistics name
+define(`confSTMODE', `0660')dnl #statistics mode
+define(`confUBINDIR', `@libexecdir@')dnl #usr bin dir @bindir@
+define(`confUBINGRP', `mail')dnl #usr bin grp smmsp
+define(`confUBINMODE', `0755')dnl #usr bin mode
+define(`confUBINOWN', `root')dnl #usr bin owner
#
# don't provide links, I'll do them myself later
# sigh... must have something in there or $(make install) croaks -- temp file
@@ -233,8 +233,8 @@ dnl define(`confNO_MAN_INSTALL')dnl
dnl define(`confNO_MAN_BUILD')dnl
define(`confINSTALL_RAWMAN')dnl
define(`confDONT_INSTALL_CATMAN', `')dnl # for 8.12
-define(`confMANDOC', `')dnl # for 8.9.3
-define(`confNROFF', `cat')dnl # for 8.9.3
+define(`confMANDOC', `')dnl # for 8.9.3
+define(`confNROFF', `cat')dnl # for 8.9.3
define(`confNO_STATISTICS_INSTALL')dnl
#
# flags
diff --git a/debian/changelog b/debian/changelog
index 14b27bf..c6fa5fe 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+sendmail (8.14.1-4) unstable; urgency=low
+
+ * Fix occasional mailq failures caused by set -e and lsb scripts :(
+
+ -- Richard A Nelson (Rick) <cowboy@debian.org> Tue, 22 May 2007 23:00:00 -0000
+
sendmail (8.14.1-3) unstable; urgency=low
* Add missing build-depends for linux-kernel-headers
diff --git a/debian/local/sendmail.in b/debian/local/sendmail.in
index 33eb7b8..6e8a11d 100644
--- a/debian/local/sendmail.in
+++ b/debian/local/sendmail.in
@@ -15,7 +15,6 @@
#
#-----------------------------------------------------------------------------
#
-set -e;
DEBUG=0;
# Support stand-alone execution
@@ -40,6 +39,9 @@ if [ -z "$DAEMON" ]; then
. /lib/lsb/init-functions
fi;
+# Can't do this earlier, the lsb inclusion is unsafe :(
+set -e;
+
#------------------------------------------------------------------------------
# Parameters for the sendmail daemon
# Do *NOT* touch these lines, instead, edit /etc/mail/sendmail.conf
diff --git a/debian/rules b/debian/rules
index 3d36ce9..1245151 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,7 +4,7 @@
#
# $Sendmail: rules,v 8.12.10 2003-07-13 21:46:03 cowboy Exp $
#
-# Copyright (c) 1998-2003 Richard Nelson. All Rights Reserved.
+# Copyright (c) 1998-2007 Richard Nelson. All Rights Reserved.
#
# ./rules. Generated from rules.in by configure.
#
@@ -73,9 +73,9 @@
# nodev Disable generation of libmilter-dev package
# nodoc Disable generation of sendmail-doc package
#
-# This make file uses scripts from the DBS (0.8) package!
+# This make file uses scripts from the DBS (0.8) package :(
#
-# Richard Nelson <cowboy@debian.org> 2004-11-16 16:17:00 (-0800)
+# Richard Nelson <cowboy@debian.org> 2007-05-22 22:39:00 (+0000)
#------------------------------------------------------------------------------
#SHELL := /bin/sh -x
@@ -88,6 +88,19 @@
# This has to be exported to make some magic below work.
export DH_OPTIONS
+# PIE support
+#CFLAGS += -fpie --warn-shared-textrel
+#export CFLAGS
+#LDFLAGS += -pie
+#export LDFLAGS
+
+# Make it even harder to exploit sendmail.
+# Well, almost impossible now 8-)
+#CFLAGS += -fstack-protector-all -Wl,-z,relro -Wl,-z,now
+#export CFLAGS
+#LDOPTS += -Wl,-z,relro -Wl,-z,now
+#export LDOPTS
+
# Support separate debian directory
ifeq (yes, $(shell test -d debian && echo 'yes'))
debian_dir := ./debian
@@ -809,6 +822,7 @@ else
(cd ${BUILD_TREE}/obj*/libmilter && \
gcc -shared -pthread -o libmilter.so.${sm_libmilter_version} \
-Wl,-soname,libmilter.so.${sm_libmilter_version} \
+ ${LDOPTS} \
main.o engine.o listener.o handler.o comm.o \
smfi.o signal.o sm_gethost.o errstring.o strl.o;); \
fi; \