summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard A Nelson (Rick) <cowboy@debian.org>2007-12-07 20:15:00 +0000
committerAndreas Beckmann <debian@abeckmann.de>2012-10-01 20:07:34 +0200
commit7d8d824e23d828c84fada5fb3b0180a0a0aa4409 (patch)
treed02fe68c5f16b12a959fe6d6b7b53c4d70d0e3e4
parentd920c2bbf44af5fa0af8d4112290cb55a0de3c94 (diff)
downloadsendmail-7d8d824e23d828c84fada5fb3b0180a0a0aa4409.tar.gz
Imported Debian patch 8.14.2-3debian/8.14.2-3
-rw-r--r--debian/Makefile.in25
-rw-r--r--debian/build/autoconf.mk4
-rw-r--r--debian/build/debian/control.m4.in2
-rw-r--r--debian/build/debian/sendmail-base.postrm.in9
-rw-r--r--debian/cf/Makefile.in4
-rw-r--r--debian/cf/debian/sendmail.mc.in4
-rw-r--r--debian/cf/debian/submit.mc.in3
-rw-r--r--debian/changelog25
-rw-r--r--debian/configure4
-rw-r--r--debian/configure.ac2
-rw-r--r--debian/control2
-rw-r--r--debian/examples/Makefile.in4
-rw-r--r--debian/examples/tls/starttls.m4.in5
-rw-r--r--debian/local/Makefile.in4
-rw-r--r--debian/local/Parse_mc.pm.in2
-rw-r--r--debian/local/update_tls.in14
-rw-r--r--debian/local/update_tlsm4.in4
-rw-r--r--debian/sendmail-base.sendmail.logrotate2
-rw-r--r--debian/sensible_mda/Makefile.in17
19 files changed, 93 insertions, 43 deletions
diff --git a/debian/Makefile.in b/debian/Makefile.in
index 0ff62fd..1fda743 100644
--- a/debian/Makefile.in
+++ b/debian/Makefile.in
@@ -1,8 +1,8 @@
-# Makefile.in generated by automake 1.10 from Makefile.am.
+# Makefile.in generated by automake 1.10.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -591,8 +591,8 @@ ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
+ $(AWK) '{ files[$$0] = 1; nonemtpy = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
mkid -fID $$unique
tags: TAGS
@@ -617,8 +617,8 @@ TAGS: tags-recursive $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
test -n "$$unique" || unique=$$empty_fix; \
$(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
@@ -628,13 +628,12 @@ ctags: CTAGS
CTAGS: ctags-recursive $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
$(TAGS_FILES) $(LISP)
tags=; \
- here=`pwd`; \
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
test -z "$(CTAGS_ARGS)$$tags$$unique" \
|| $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
$$tags $$unique
@@ -705,6 +704,10 @@ dist-bzip2: distdir
tardir=$(distdir) && $(am__tar) | bzip2 -9 -c >$(distdir).tar.bz2
$(am__remove_distdir)
+dist-lzma: distdir
+ tardir=$(distdir) && $(am__tar) | lzma -9 -c >$(distdir).tar.lzma
+ $(am__remove_distdir)
+
dist-tarZ: distdir
tardir=$(distdir) && $(am__tar) | compress -c >$(distdir).tar.Z
$(am__remove_distdir)
@@ -731,6 +734,8 @@ distcheck: dist
GZIP=$(GZIP_ENV) gunzip -c $(distdir).tar.gz | $(am__untar) ;;\
*.tar.bz2*) \
bunzip2 -c $(distdir).tar.bz2 | $(am__untar) ;;\
+ *.tar.lzma*) \
+ unlzma -c $(distdir).tar.lzma | $(am__untar) ;;\
*.tar.Z*) \
uncompress -c $(distdir).tar.Z | $(am__untar) ;;\
*.shar.gz*) \
@@ -881,7 +886,7 @@ uninstall-am:
.PHONY: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) CTAGS GTAGS \
all all-am am--refresh check check-am clean clean-generic \
ctags ctags-recursive dist dist-all dist-bzip2 dist-gzip \
- dist-shar dist-tarZ dist-zip distcheck distclean \
+ dist-lzma dist-shar dist-tarZ dist-zip distcheck distclean \
distclean-generic distclean-tags distcleancheck distdir \
distuninstallcheck dvi dvi-am html html-am info info-am \
install install-am install-data install-data-am install-dvi \
diff --git a/debian/build/autoconf.mk b/debian/build/autoconf.mk
index 03da1e2..24fdeac 100644
--- a/debian/build/autoconf.mk
+++ b/debian/build/autoconf.mk
@@ -2,7 +2,7 @@
#------------------------------------------------------------------------------
# vim: syntax=make
#
-# $Sendmail: autoconf.mk,v 8.14.2 2007-11-30 09:13:59 cowboy Exp $
+# $Sendmail: autoconf.mk,v 8.14.2 2008-02-10 13:47:11 cowboy Exp $
#
# Copyright (c) 1998-2007 Richard Nelson. All Rights Reserved.
#
@@ -16,7 +16,7 @@
# on Debian slink, potato, woody, testing, sid, ...
# but the generated file is customized to the version noted above.
#
-# Richard Nelson <cowboy@debian.org> 2007-11-30 09:13:59 (-0800)
+# Richard Nelson <cowboy@debian.org> 2008-02-10 13:47:11 (-0800)
#------------------------------------------------------------------------------
#SHELL := /bin/sh -x
diff --git a/debian/build/debian/control.m4.in b/debian/build/debian/control.m4.in
index f9647df..cf97ab8 100644
--- a/debian/build/debian/control.m4.in
+++ b/debian/build/debian/control.m4.in
@@ -25,7 +25,7 @@ Maintainer: Richard A Nelson (Rick) <cowboy@debian.org>
Standards-Version: 3.7.2
]]dnl # Sigh... build daemons ignore B-D-I, so replicate in B-D :(
[[Build-Depends-Indep: groff, bsdmainutils
-Build-Depends: make (>> 3.79.1-14), m4, cdbs, patchutils, dh-buildinfo, debhelper (>= 5), linux-libc-dev (>= 2.6.21-3) | linux-kernel-headers, groff, bsdmainutils @sm_badepends@
+Build-Depends: make (>> 3.79.1-14), m4, cdbs, patchutils, dh-buildinfo, debhelper (>= 5), linux-libc-dev (>= 2.6.21-3) [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386], groff, bsdmainutils @sm_badepends@
Build-Conflicts: libbind-dev, bind-dev, fakeroot (<< 0.4.5)
Homepage: http://www.sendmail.org]]dnl
dnl #
diff --git a/debian/build/debian/sendmail-base.postrm.in b/debian/build/debian/sendmail-base.postrm.in
index a440573..b07118b 100644
--- a/debian/build/debian/sendmail-base.postrm.in
+++ b/debian/build/debian/sendmail-base.postrm.in
@@ -65,6 +65,12 @@ case "$1" in
rm -f @libdir@/lib/sasl/Sendmail.conf;
rm -f @sysconfdir@/certs/sendmail.pem;
rm -f @datadir@/bug/sendmail*;
+ rmdir --ignore-fail-on-non-empty @datadir@/bug;
+ rm -f @sysconfdir@/logrotate.d/sendmail;
+ rmdir --ignore-fail-on-non-empty @sysconfdir@/logrotate.d;
+ rm -f @sysconfdir@/logcheck/violations.ignore.d/sendmail;
+ rmdir --ignore-fail-on-non-empty @sysconfdir@/logcheck/violations.ignore.d;
+ rmdir --ignore-fail-on-non-empty @sysconfdir@/logcheck;
# Can't touch these as they may be included in slapd.conf
#rm -rf @sysconfdir@/ldap/schema/sendmail.schema;
#rm -rf @sysconfdir@/openldap/sendmail.schema;
@@ -82,7 +88,8 @@ case "$1" in
@sysconfdir@/mail/default-auth-info \
;
rmdir @sysconfdir@/mail/peers 2>/dev/null || true;
- rmdir @sysconfdir@/mail 2>/dev/null || true;
+ rmdir @sysconfdir@/mail 2>/dev/null || true;
+ rmdir @docdir@/sendmail 2>/dev/null || true;
;;
diff --git a/debian/cf/Makefile.in b/debian/cf/Makefile.in
index 29e946a..522f761 100644
--- a/debian/cf/Makefile.in
+++ b/debian/cf/Makefile.in
@@ -1,8 +1,8 @@
-# Makefile.in generated by automake 1.10 from Makefile.am.
+# Makefile.in generated by automake 1.10.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
diff --git a/debian/cf/debian/sendmail.mc.in b/debian/cf/debian/sendmail.mc.in
index 2c97995..bb99681 100644
--- a/debian/cf/debian/sendmail.mc.in
+++ b/debian/cf/debian/sendmail.mc.in
@@ -55,8 +55,8 @@ dnl #
FEATURE(`no_default_msa')dnl
dnl DAEMON_OPTIONS(`Family=inet6, Name=MTA-v6, Port=smtp, Addr=::1')dnl
DAEMON_OPTIONS(`Family=inet, Name=MTA-v4, Port=smtp, Addr=127.0.0.1')dnl
-dnl DAEMON_OPTIONS(`Family=inet6, Name=MSP-v6, Port=submission, Addr=::1')dnl
-DAEMON_OPTIONS(`Family=inet, Name=MSP-v4, Port=submission, Addr=127.0.0.1')dnl
+dnl DAEMON_OPTIONS(`Family=inet6, Name=MSP-v6, Port=submission, M=Ea, Addr=::1')dnl
+DAEMON_OPTIONS(`Family=inet, Name=MSP-v4, Port=submission, M=Ea, Addr=127.0.0.1')dnl
dnl #
dnl # Be somewhat anal in what we allow
define(`confPRIVACY_FLAGS',dnl
diff --git a/debian/cf/debian/submit.mc.in b/debian/cf/debian/submit.mc.in
index b7c652f..945d080 100644
--- a/debian/cf/debian/submit.mc.in
+++ b/debian/cf/debian/submit.mc.in
@@ -46,8 +46,9 @@ dnl FEATURE(`masquerade_envelope')dnl
dnl #
dnl #---------------------------------------------------------------------
dnl # The real reason we're here: the FEATURE(msp)
+dnl # NOTE WELL: MSA (587) should have M=Ea, so we need to use stock 25
dnl #---------------------------------------------------------------------
-FEATURE(`msp', `[127.0.0.1]', `MSA')dnl
+FEATURE(`msp', `[127.0.0.1]', `25')dnl
dnl #
dnl #---------------------------------------------------------------------
dnl # Some minor cleanup from FEATURE(msp)
diff --git a/debian/changelog b/debian/changelog
index 73693bd..543b962 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,28 @@
+sendmail (8.14.2-3) unstable; urgency=low
+
+ * Correct the setup of Submission (587) and local injection
+ + sendmail.mc adds M=Ea to submission port
+ + submit.mc changed to use port 25
+ otherwise local mail injection fails (thanks to Ian Corbett)
+
+ If you have already installed sendmail, and are having issues
+ with AUTH required and local mail injection, check your .mc files
+ against /usr/share/doc/sendmail/examples/cf/debian/*.mc
+
+ * pedantry bug (proof that two heads are better than one) -
+ misspelling in logrotate.conf
+ * Cleanup better on purge of sendmail-base Closes: #454685
+ * FTBFS on non-linux arch Closes: #459610
+ control.m4.in
+ * Generate TLS DH/DS parameters Closes: #461802
+ This only affects new installs or certificate recreation
+ update_tls, update_tlsm4, starttls.m4, Parse_mc.pm
+ * Build using newer LDAP and DB2
+ * Define LDAP_DEPRECATED Closes: #463371
+ configure.ac
+
+ -- Richard A Nelson (Rick) <cowboy@debian.org> Fri, 07 Dec 2007 20:15:00 -0000
+
sendmail (8.14.2-2) unstable; urgency=low
* When creating /etc/sasldb2; use proper group (sasl)
diff --git a/debian/configure b/debian/configure
index 2a24632..961d6bb 100644
--- a/debian/configure
+++ b/debian/configure
@@ -8014,6 +8014,8 @@ echo "$as_me: WARNING: Could not find UMich -lldap or -llber" >&2;}
sm_sendmail_envdef="$sm_sendmail_envdef -D_FFR_LDAP_URI";
sm_libsm_envdef="$sm_libsm_envdef -D_FFR_LDAP_SETVERSION";
sm_sendmail_envdef="$sm_sendmail_envdef -D_FFR_LDAP_SETVERSION";
+ sm_libsm_envdef="$sm_libsm_envdef -DLDAP_DEPRECATED";
+ sm_sendmail_envdef="$sm_sendmail_envdef -DLDAP_DEPRECATED";
fi;
if test $sm_have_ldap_memfree = yes; then
sm_libsm_envdef="$sm_libsm_envdef -DSM_CONF_LDAP_MEMFREE";
@@ -11959,7 +11961,7 @@ echo "$as_me: executing $ac_file commands" >&6;}
# each Makefile.in and add a new line on top of each file to say so.
# Grep'ing the whole file is not good either: AIX grep has a line
# limit of 2048, but all sed's we know have understand at least 4000.
- if sed 10q "$mf" | grep '^#.*generated by automake' > /dev/null 2>&1; then
+ if sed -n 's,^#.*generated by automake.*,X,p' "$mf" | grep X >/dev/null 2>&1; then
dirpart=`$as_dirname -- "$mf" ||
$as_expr X"$mf" : 'X\(.*[^/]\)//*[^/][^/]*/*$' \| \
X"$mf" : 'X\(//\)[^/]' \| \
diff --git a/debian/configure.ac b/debian/configure.ac
index f231b10..13d39b2 100644
--- a/debian/configure.ac
+++ b/debian/configure.ac
@@ -1128,6 +1128,8 @@ if test $sm_enable_ldap != no; then
sm_sendmail_envdef="$sm_sendmail_envdef -D_FFR_LDAP_URI";
sm_libsm_envdef="$sm_libsm_envdef -D_FFR_LDAP_SETVERSION";
sm_sendmail_envdef="$sm_sendmail_envdef -D_FFR_LDAP_SETVERSION";
+ sm_libsm_envdef="$sm_libsm_envdef -DLDAP_DEPRECATED";
+ sm_sendmail_envdef="$sm_sendmail_envdef -DLDAP_DEPRECATED";
fi;
if test $sm_have_ldap_memfree = yes; then
sm_libsm_envdef="$sm_libsm_envdef -DSM_CONF_LDAP_MEMFREE";
diff --git a/debian/control b/debian/control
index b056034..09ecc35 100644
--- a/debian/control
+++ b/debian/control
@@ -4,7 +4,7 @@ Section: mail
Maintainer: Richard A Nelson (Rick) <cowboy@debian.org>
Standards-Version: 3.7.2
Build-Depends-Indep: groff, bsdmainutils
-Build-Depends: make (>> 3.79.1-14), m4, cdbs, patchutils, dh-buildinfo, debhelper (>= 5), linux-libc-dev (>= 2.6.21-3) | linux-kernel-headers, groff, bsdmainutils , libdb4.6-dev, libldap2-dev, libwrap0-dev, liblockfile-dev, libsasl2-dev, libssl-dev
+Build-Depends: make (>> 3.79.1-14), m4, cdbs, patchutils, dh-buildinfo, debhelper (>= 5), linux-libc-dev (>= 2.6.21-3) [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386], groff, bsdmainutils , libdb4.6-dev, libldap2-dev, libwrap0-dev, liblockfile-dev, libsasl2-dev, libssl-dev
Build-Conflicts: libbind-dev, bind-dev, fakeroot (<< 0.4.5)
Homepage: http://www.sendmail.org
diff --git a/debian/examples/Makefile.in b/debian/examples/Makefile.in
index 1dee680..496bdff 100644
--- a/debian/examples/Makefile.in
+++ b/debian/examples/Makefile.in
@@ -1,8 +1,8 @@
-# Makefile.in generated by automake 1.10 from Makefile.am.
+# Makefile.in generated by automake 1.10.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
diff --git a/debian/examples/tls/starttls.m4.in b/debian/examples/tls/starttls.m4.in
index dd45c0a..8f7a66e 100644
--- a/debian/examples/tls/starttls.m4.in
+++ b/debian/examples/tls/starttls.m4.in
@@ -54,8 +54,11 @@ dnl # NOTE: The key must *NOT* be encrypted !!!
define(`confCLIENT_CERT', `@sysconfdir@/mail/tls/sendmail-client.crt')dnl
define(`confCLIENT_KEY', `@sysconfdir@/mail/tls/sendmail-common.key')dnl
dnl #
+dnl # DH parameters
+define(`confDH_PARAMETERS',`@sysconfdir@/mail/tls/sendmail-common.prm')dnl
+dnl #
dnl # Optional settings
-define(`confTLS_SRV_OPTIONS', `V')dnl # do not request user certs
+define(`confTLS_SRV_OPTIONS', `')dnl # do not request user certs
dnl #
dnl # Do not touch anything below this line...
')')dnl
diff --git a/debian/local/Makefile.in b/debian/local/Makefile.in
index cbd9fec..32b6d15 100644
--- a/debian/local/Makefile.in
+++ b/debian/local/Makefile.in
@@ -1,8 +1,8 @@
-# Makefile.in generated by automake 1.10 from Makefile.am.
+# Makefile.in generated by automake 1.10.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
diff --git a/debian/local/Parse_mc.pm.in b/debian/local/Parse_mc.pm.in
index e21d61d..a1e40b0 100644
--- a/debian/local/Parse_mc.pm.in
+++ b/debian/local/Parse_mc.pm.in
@@ -191,6 +191,8 @@ my %smdb_hash = (
['-','-',["${smdb_loc}tls/sendmail-server.crt"],'-']
,'confSERVER_KEY' =>
['-','-',["${smdb_loc}tls/sendmail-common.key"],'-']
+ ,'confDH_PARAMETERS' =>
+ ['-','-',["${smdb_loc}tls/sendmail-common.prm"],'-']
,'confTLS_SRV_OPTIONS' =>
['-','-',["V"],'-']
# ----------- SMTP AUTH (SASL)
diff --git a/debian/local/update_tls.in b/debian/local/update_tls.in
index 99358bf..524e651 100644
--- a/debian/local/update_tls.in
+++ b/debian/local/update_tls.in
@@ -123,7 +123,7 @@ echo 'Creating/Updating SSL(for TLS) information';
case "$1" in
[Nn][Ee][Ww]* | \
[Rr][Ee][Nn][Ee][Ww]* | \
- [Rr][Ee][Ss][Ii][Nn][Gg]*)
+ [Rr][Ee][Ss][Ii][Gg][Nn]*)
echo 'Removing any pre-existing sendmail certificates.';
if [ -x @bindir@/openssl ]; then
if [ -f $MTA_CRT ]; then
@@ -186,6 +186,7 @@ if [ -d "$CERT_DIR" ]; then
if [ -f $MTA_CRT ] && [ -f $MSP_CRT ]; then
echo 'You already have sendmail certificates';
echo ' ';
+ chown root:smmsp $COM_PRM;
chown root:smmsp $COM_KEY;
chown root:smmsp $MTA_CRT;
chown root:smmsp $MSP_CRT;
@@ -235,12 +236,11 @@ if [ -d "$CERT_DIR" ]; then
chmod 0600 $MSP_CFG;
fi;
# Create shared DSA/DH password parameters
- # Skip this for now...
- if [ ! -f $COM_PRM ]; then
- #openssl dsaparam 2048 -out $COM_PRM;
- #openssl dhparam -dsaparam -in $COM_PRM >> $COM_PRM;
- touch $COM_PRM;
- chmod 0600 $COM_PRM;
+ if [ ! -s $COM_PRM ]; then
+ openssl dsaparam 2048 -out $COM_PRM;
+ openssl dhparam -dsaparam -in $COM_PRM >> $COM_PRM;
+ chown root:smmsp $COM_PRM;
+ chmod 0640 $COM_PRM;
fi;
# Create shared DSA/RSA key (RSA preferred for browser support)
if [ ! -f $COM_KEY ]; then
diff --git a/debian/local/update_tlsm4.in b/debian/local/update_tlsm4.in
index a2951c4..9e321f4 100644
--- a/debian/local/update_tlsm4.in
+++ b/debian/local/update_tlsm4.in
@@ -114,6 +114,7 @@ sub get_data {
,'confCLIENT_KEY'
,'confSERVER_CERT'
,'confSERVER_KEY'
+ ,'confDH_PARAMETERS'
,'confTLS_SRV_OPTIONS'
);
@@ -239,6 +240,9 @@ dnl # NOTE: The key must *NOT* be encrypted !!!
define(\`confCLIENT_CERT\', \`$Def_Map{'confCLIENT_CERT'}\')dnl # <= EDIT
define(\`confCLIENT_KEY\', \`$Def_Map{'confCLIENT_KEY'}\')dnl # <= EDIT
dnl #
+dnl # DH parameters
+define(\`confDH_PARAMETERS\', \`$Def_Map{'confDH_PARAMETERS'}\')dnl # <= EDIT
+dnl #
dnl # Optional settings
define(\`confTLS_SRV_OPTIONS\', \`$Def_Map{'confTLS_SRV_OPTIONS'}\')dnl # <= EDIT
dnl #
diff --git a/debian/sendmail-base.sendmail.logrotate b/debian/sendmail-base.sendmail.logrotate
index 2c212e6..3f409e6 100644
--- a/debian/sendmail-base.sendmail.logrotate
+++ b/debian/sendmail-base.sendmail.logrotate
@@ -5,7 +5,7 @@
# If you're using the stock syslog package, do *NOT* enable anything
# in this file, doing so may result in dual rotations of the logfiles
# and/or loss of logged data. The syslog package, by default, will
-# rotate standard log files based upon various critera !!!
+# rotate standard log files based upon various criteria !!!
#
#/var/log/mail/mail.alert {
# notifempty
diff --git a/debian/sensible_mda/Makefile.in b/debian/sensible_mda/Makefile.in
index 21e8812..24f2b8a 100644
--- a/debian/sensible_mda/Makefile.in
+++ b/debian/sensible_mda/Makefile.in
@@ -1,8 +1,8 @@
-# Makefile.in generated by automake 1.10 from Makefile.am.
+# Makefile.in generated by automake 1.10.1 from Makefile.am.
# @configure_input@
# Copyright (C) 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002,
-# 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
+# 2003, 2004, 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
# This Makefile.in is free software; the Free Software Foundation
# gives unlimited permission to copy and/or distribute it,
# with or without modifications, as long as this notice is preserved.
@@ -398,8 +398,8 @@ ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
+ $(AWK) '{ files[$$0] = 1; nonemtpy = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
mkid -fID $$unique
tags: TAGS
@@ -411,8 +411,8 @@ TAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
if test -z "$(ETAGS_ARGS)$$tags$$unique"; then :; else \
test -n "$$unique" || unique=$$empty_fix; \
$(ETAGS) $(ETAGSFLAGS) $(AM_ETAGSFLAGS) $(ETAGS_ARGS) \
@@ -422,13 +422,12 @@ ctags: CTAGS
CTAGS: $(HEADERS) $(SOURCES) $(TAGS_DEPENDENCIES) \
$(TAGS_FILES) $(LISP)
tags=; \
- here=`pwd`; \
list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
unique=`for i in $$list; do \
if test -f "$$i"; then echo $$i; else echo $(srcdir)/$$i; fi; \
done | \
- $(AWK) ' { files[$$0] = 1; } \
- END { for (i in files) print i; }'`; \
+ $(AWK) '{ files[$$0] = 1; nonempty = 1; } \
+ END { if (nonempty) { for (i in files) print i; }; }'`; \
test -z "$(CTAGS_ARGS)$$tags$$unique" \
|| $(CTAGS) $(CTAGSFLAGS) $(AM_CTAGSFLAGS) $(CTAGS_ARGS) \
$$tags $$unique