summaryrefslogtreecommitdiff
path: root/debian/build/update_chaos
diff options
context:
space:
mode:
authorRichard A Nelson (Rick) <cowboy@debian.org>2008-05-17 22:47:00 +0000
committerAndreas Beckmann <debian@abeckmann.de>2012-10-01 20:07:40 +0200
commit905c8da2413479e6977ba8625e642f50e9c8ff82 (patch)
treeb8ac4288ddbc1b7e239699162e91bee0b944db6c /debian/build/update_chaos
parent6014a62ee0ac8a43c9a0a0ec04784c602c11daff (diff)
downloadsendmail-905c8da2413479e6977ba8625e642f50e9c8ff82.tar.gz
Imported Debian patch 8.14.3-2debian/8.14.3-2
Diffstat (limited to 'debian/build/update_chaos')
-rw-r--r--debian/build/update_chaos202
1 files changed, 0 insertions, 202 deletions
diff --git a/debian/build/update_chaos b/debian/build/update_chaos
deleted file mode 100644
index 6312f20..0000000
--- a/debian/build/update_chaos
+++ /dev/null
@@ -1,202 +0,0 @@
-#!/bin/sh
-#-----------------------------------------------------------------------------
-# $Sendmail: update_chaos,v 8.14.3 2008-05-04 22:26:20 cowboy Exp $
-#
-# Copyright (c) 2001-2008 Richard Nelson. All Rights Reserved.
-#
-# build/update_chaos. Generated from update_chaos.in by configure.
-#
-# Debian script to rationalize builds for Sendmail 8.14.3-1(@sm_math@)
-#
-# Note: the .in file supports 8.7.6 - 9.0.0, but the generated
-# file is customized to the version noted above.
-#
-#-----------------------------------------------------------------------------
-set -e;
-
-#------------------------------------------------------------------
-# Exit, stage left, even... if not needed (private dir, or >= 8.10.0)
-#------------------------------------------------------------------
-BUILD_TREE='./../../build-tree/sendmail-8.14.3';
-if [ ! -d ${BUILD_TREE} ]; then
- exit 0;
- fi;
-if [ -d ${BUILD_TREE}/devtools/bin ]; then
- exit 0;
- fi;
-
-echo "Rationalizing Sendmail-8.14.3 setup...";
-
-#------------------------------------------------------------------
-# List of subdirectories to work on
-#------------------------------------------------------------------
-SUBDIRS="editmap libmilter mail.local mailstats
- makemap praliases rmail sendmail smrsh vacation";
-
-#------------------------------------------------------------------
-# Match Sendmail's build directory conventions
-#------------------------------------------------------------------
-os=`uname -s | sed -e 's/\//-/g' -e 's/ //g'`;
-rel=`uname -r | sed -e 's/(/-/g' -e 's/)//g'`;
-arch=`uname -m | sed -e 's/ //g'`;
-OBJ_DIR="obj.${os}.${rel}.${arch}";
-
-#------------------------------------------------------------------
-# Function to escape quotes (to survive subsequent sed)
-#------------------------------------------------------------------
-esq () {
- result=$(echo "${1}" | sed -e 's?\"?\\\\\\\"?g');
- };
-
-#------------------------------------------------------------------
-# Prior to 8.10.0, sendmail source was in the src directory
-# Prior to 8.10.0, devtools was called BuildTools
-# Create compatibility links (to look like 8.10.0+)
-#------------------------------------------------------------------
-if [ ! -d ${BUILD_TREE}/sendmail ]; then
- echo "...Creating \${BUILD_TREE}/sendmail compatibility symlink";
- ln -sf src ${BUILD_TREE}/sendmail;
- if [ ! -d ${BUILD_TREE}/devtools ]; then
- echo "...Creating \${BUILD_TREE}/devtools compatibility symlink";
- ln -sf BuildTools ${BUILD_TREE}/devtools;
- fi;
- fi;
-
-#------------------------------------------------------------------
-# Prior to 8.10.0, objects were in the source directories, not separate
-# Create compatibility links (to look like 8.10.0+)
-#------------------------------------------------------------------
-echo "...Creating ${OBJ_DIR}/<dir> directories";
-mkdir -p ${BUILD_TREE}/${OBJ_DIR};
-for subdir in $SUBDIRS; do
- if [ -d ${BUILD_TREE}/${subdir} ]; then
- ln -sf "../${subdir}/${OBJ_DIR}" \
- ${BUILD_TREE}/${OBJ_DIR}/${subdir};
- fi;
- done;
-
-#------------------------------------------------------------------
-# If 8.9.0+, we're done, get the flock outa here...
-#------------------------------------------------------------------
-if [ -e ${BUILD_TREE}/sendmail/Build ]; then
- echo '...Done.';
- exit 0;
- fi;
-
-#------------------------------------------------------------------
-# Prior to 8.9.0, READ_ME was seen in a few places
-# Create compatibility links
-#------------------------------------------------------------------
-echo '...Creating READ_ME compatility symlinks';
-for file in $(find ${BUILD_TREE} -name 'READ_ME'); do
- ln -sf READ_ME $(echo "${file}" | sed -e 's/READ_ME/README/');
- done;
-
-#------------------------------------------------------------------
-# Prior to 8.9.0, MAKE was used instead of Build
-# We'll install a small wrapper for the earlier releases
-# Prior to 8.9.0, Only src directory had an obj.* subdirectory
-# Create compatibility links (to look like 8.9.0+)
-#------------------------------------------------------------------
-echo "...Creating <dir>/${OBJ_DIR}";
-for subdir in $SUBDIRS; do
- if [ -d ${BUILD_TREE}/${subdir} ]; then
- if [ ! -d ${BUILD_TREE}/${subdir}/Makefiles ]; then
- mkdir -p ${BUILD_TREE}/${subdir}/${OBJ_DIR};
- for file in `find ${BUILD_TREE}/${subdir} -type f`; do
- cp -a $file ${BUILD_TREE}/${subdir}/${OBJ_DIR};
- done;
- fi;
- cp -a debian/build/Build ${BUILD_TREE}/${subdir}/;
- fi;
- done;
-#
-#------------------------------------------------------------------
-# Kluge the Makefiles to comply with our file locations.
-#------------------------------------------------------------------
-echo '...Kluging Makefiles';
-for file in mailstats/Makefile.dist \
- mail.local/Makefile.dist \
- makemap/Makefile.dist \
- praliases/Makefile.dist \
- smrsh/Makefile.dist \
- src/Makefiles/Makefile.Linux \
- ; do
- cp -a ${BUILD_TREE}/${file} ${BUILD_TREE}/${file}.save;
- #
- # Set local variables to allow for quoting...
- esq " ";
- sm_incdirs=$result;
- esq " -DSOCKETMAP -DMAP_REGEX -DNEWDB -DNIS -DNISPLUS -DLDAPMAP";
- sm_mapdef=$result;
- esq " -DHASFCHMOD=1 -DHASSETRLIMIT=1 -DHASFLOCK=0 -DUSESETEUID=1 -DHASGETUSERSHELL=1 -DNETINET6";
- sm_envdef=$result;
- esq "";
- sm_libs=$result;
- #
- # global
- sed \
- -e 's?-I/usr/sww/include??' \
- -e 's?-I/usr/local/include??' \
- -e 's?-L/usr/sww/lib??' \
- -e 's?../src?../../src?g' \
- -e "s?^INCDIRS=\(.*\)\$?INCDIRS=\1 $sm_incdirs?" \
- -e "s?^DBMDEF=.*?DBMDEF=$sm_mapdef?" \
- -e "s?^ENVDEF=\(.*\)\$?ENVDEF=\1 $sm_envdef?" \
- -e "s?^LIBS=.*?LIBS=$sm_libs?" \
- ${BUILD_TREE}/${file} > ${BUILD_TREE}/${file}.new;
- mv ${BUILD_TREE}/${file}.new ${BUILD_TREE}/${file};
- #
- # compilation/link
- sed \
- -e 's?^O=.*?O=-g -Wall -O2 -fPIC -fstack-protector-all -g -Wall -O2 -fPIC -fstack-protector-all?' \
- -e 's?^LIBDIRS=.*?LIBDIRS=?' \
- ${BUILD_TREE}/${file} > ${BUILD_TREE}/${file}.new;
- mv ${BUILD_TREE}/${file}.new ${BUILD_TREE}/${file};
-
- #
- # paths, owners, and modes
- # Note: EBINDIR deserves a better home, suggestions?
- sed \
- -e 's?^BINDIR=.*?BINDIR=${DESTDIR}/usr/sbin?' \
- -e 's?^BINMODE=.*?BINMODE=04755?' \
- -e 's?^BINGRP=.*?BINGRP=mail?' \
- -e 's?^BINOWN=.*?BINOWN=root?' \
- -e 's?^HFDIR=.*?HFDIR=${DESTDIR}/etc/mail?' \
- -e 's?^STDIR=.*?STDIR=${DESTDIR}/var/lib/sendmail?' \
- ${BUILD_TREE}/${file} > ${BUILD_TREE}/${file}.new;
- mv ${BUILD_TREE}/${file}.new ${BUILD_TREE}/${file};
-
- if [ "${file}" = 'mail.local/Makefile.dist' \
- -o "${file}" = 'smrsh/Makefile.dist' \
- ]; then
- sed \
- -e 's?^BINDIR=.*?BINDIR=${DESTDIR}/usr/lib/sm.bin?' \
- -e 's?^BINMODE=.*?BINMODE=04755?' \
- -e 's?^BINGRP=.*?BINGRP=mail?' \
- -e 's?^BINOWN=.*?BINOWN=root?' \
- ${BUILD_TREE}/${file} > ${BUILD_TREE}/${file}.new;
- echo 'force-install: install' >> ${BUILD_TREE}/${file}.new;
- mv ${BUILD_TREE}/${file}.new ${BUILD_TREE}/${file};
-
- elif [ "${file}" = 'mailstats/Makefile.dist' \
- -o "${file}" = 'makemap/Makefile.dist' \
- -o "${file}" = 'praliases/Makefile.dist' \
- ]; then
- sed \
- -e 's?^BINDIR=.*?BINDIR=${DESTDIR}/usr/sbin?' \
- -e 's?^BINMODE=.*?BINMODE=0755?' \
- -e 's?^BINGRP=.*?BINGRP=mail?' \
- -e 's?^BINOWN=.*?BINOWN=root?' \
- ${BUILD_TREE}/${file} > ${BUILD_TREE}/${file}.new;
- mv ${BUILD_TREE}/${file}.new ${BUILD_TREE}/${file};
- fi;
-
- # For most directories, replace Makefile with our updated Makefile.dist
- if [ "${file}" != 'src/Makefiles/Makefile.Linux' ]; then
- cp ${BUILD_TREE}/${file} \
- $(dirname "${BUILD_TREE}/${file}")/${OBJ_DIR}/Makefile;
- fi;
- done;
-
-echo '...Done.';