summaryrefslogtreecommitdiff
path: root/debian/configure.ac
diff options
context:
space:
mode:
authorRichard A Nelson (Rick) <cowboy@debian.org>2008-04-21 18:04:00 +0000
committerAndreas Beckmann <debian@abeckmann.de>2012-10-01 20:07:38 +0200
commit2622d9465dc693e49e8409321c73bcffa61e8935 (patch)
tree43a68bed796f18aebb27552a2660d656d455f70f /debian/configure.ac
parent6063ecde2e4eff3ebd5259ff33058faf3e43dbcb (diff)
downloadsendmail-2622d9465dc693e49e8409321c73bcffa61e8935.tar.gz
Imported Debian patch 8.14.2-5debian/8.14.2-5
Diffstat (limited to 'debian/configure.ac')
-rw-r--r--debian/configure.ac78
1 files changed, 61 insertions, 17 deletions
diff --git a/debian/configure.ac b/debian/configure.ac
index 13d39b2..4f336c9 100644
--- a/debian/configure.ac
+++ b/debian/configure.ac
@@ -1,20 +1,20 @@
-#------------------------------------------------------------------------------
+]#------------------------------------------------------------------------------
#
# $Sendmail: ./configure.ac,v 8.14.1 2007/10/04 21:42:00 cowboy Exp $
#
-# Copyright (c) 1998-2007 Richard Nelson. All Rights Reserved.
+# Copyright (c) 1998-2008 Richard Nelson. All Rights Reserved.
#
# Debian configure file for building Sendmail
-# Note: this file supports Sendmail 8.7.6 - 8.14.1
+# Note: this file supports Sendmail 8.7.6 - 8.14.3
# and has been tested on autoconf 2.12, 2.13, 2.50, 2.52, 2.53
#
# Note: Most of this file is vanilla 2.12, but the copyright and
# ac_init portion are dual-pathed to better support 2.50+
#
#------------------------------------------------------------------------------
-define([_SM_CPYRT], [2007])dnl
-define([_SM_VERS], [8.14.2])dnl
-define([_SM_DATE], [2007-10-04 21:42:00])dnl
+define([_SM_CPYRT], [2008])dnl
+define([_SM_VERS], [8.14.3])dnl
+define([_SM_DATE], [2008-04-21 16:15:00])dnl
define([_SM_MAXVERS],[9.0.0])dnl
define([_SM_MINVERS],[8.7.6])dnl
@@ -84,7 +84,8 @@ EOF
AC_REVISION([$Revision: ]_SM_VERS[ $])
define([AC_INIT_BINSH],)dnl
ifdef([AC_COPYRIGHT],[
-AC_INIT([Sendmail],_SM_VERS,[bug/reportbug or sendmail@packages.debian.org])
+AC_INIT([Sendmail],[_SM_VERS],[bug/reportbug or sendmail@packages.debian.org])
+AC_CONFIG_MACRO_DIR(./build)
AC_CONFIG_SRCDIR([./build/site.config.m4.in])dnl
],[
AC_INIT(./build/site.config.m4.in)
@@ -93,7 +94,7 @@ AC_INIT(./build/site.config.m4.in)
AC_SUBST(PACKAGE_NAME) AC_SUBST(PACKAGE_STRING)
])dnl
AC_CONFIG_AUX_DIR([./build])dnl
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET
AC_ARG_PROGRAM
AC_PROG_MAKE_SET
AM_INIT_AUTOMAKE
@@ -172,7 +173,7 @@ PACKAGE_STRING="${PACKAGE_NAME} ${PACKAGE_VERSION}";]
# beta = suffix for beta version (8.12.0.Beta7 -> 7)
# math = for numeric (<, >=, etc.) comparisons
# 9.0.0 = 589824 (9.0 = 589824)
-# 8.14.1 = 527873 (8.14 = 527872)
+# 8.14.3 = 527875 (8.14 = 527872)
# 8.13.1 = 527617 (8.13 = 527616)
# 8.12.11 = 527371 (8.12 = 527360)
# 8.11.7 = 527111 (8.11 = 527104)
@@ -634,11 +635,50 @@ AC_SUBST(sm_enable_shm)
# Milter (_FFR_ on 8.10, 8.11, native on 8.12+)
if test "$sm_enable_milter" != "no"; then
sm_libmilter_envdef="$sm_libmilter_envdef -DSM_CONF_POLL=1";
+
+ # Determin which level of the milter interface we're using
sm_libmilter_version=0;
- v2i 8.14.0;
- if test $sm_version_math -ge $sm_version_test; then
- sm_libmilter_version=1;
+ old_cflags="$CFLAGS";
+ old_cppflags="$CFLAGS";
+ export CFLAGS="$CFLAGS -I $PWD/../build-tree/*/include";
+ export CPPFLAGS="$CPPFLAGS -I $PWD/../build-tree/*/include";
+ AC_CHECK_HEADERS(libmilter/mfapi.h,
+ [sm_have_mfapi=yes]
+ ,[sm_have_mfapi=no
+ sm_libmilter_version=0])
+ if test "$sm_have_mfapi" = 'yes'; then
+ AC_MSG_CHECKING([libmilter version])
+ SM_RESULT_IFELSE([[
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
+ #include "libmilter/mfapi.h"
+ char vers[30] = "0";
+ int main (void) {
+ snprintf(vers
+ ,sizeof(vers)
+ ,"%d%c%d%c%d"
+ ,SM_LM_VRS_MAJOR(SMFI_VERSION)
+ ,'.'
+ ,SM_LM_VRS_MINOR(SMFI_VERSION)
+ ,'.'
+ ,SM_LM_VRS_PLVL(SMFI_VERSION)
+ );
+ fprintf(stdout
+ ,"%s\n"
+ ,vers
+ );
+ return 0;
+ }
+ ]]
+ ,[AS_VAR_SET(sm_libmilter_version, "$(cat conftest.out)")]
+ ,[sm_libmilter_version=0]
+ )
+ AC_MSG_RESULT([$sm_libmilter_version])
fi;
+ export CFLAGS="$old_cflags";
+ export CPPFLAGS="$old_cppflags";
+
v2i 8.10.0;
if test $sm_version_math -ge $sm_version_test; then
sm_enable_milter=yes;
@@ -1277,11 +1317,15 @@ if test $sm_enable_tcpd != no; then
,[sm_have_tcpd=no])
if test $ac_cv_header_tcpd_h = yes ; then
- AC_TRY_COMPILE([
- int allow_severity = 0;
- int deny_severity = 0;
- ]
- ,[hosts_access()]
+ AC_COMPILE_IFELSE([
+ AC_LANG_PROGRAM([[
+ #include <tcpd.h>
+ extern int allow_severity;
+ extern int deny_severity;
+ struct request_info *request;
+ ]]
+ ,[[hosts_access(request);]]
+ )]
,[sm_have_tcpd=yes]
,[sm_have_tcpd=no])
fi;