summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog8
-rw-r--r--debian/patches/8.13/8.13.7/main.c.DaemonPid.p027
-rw-r--r--debian/patches/8.13/8.13.7/queue.c.2006061418
3 files changed, 53 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 7153e5a..1557b65 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+sendmail (8.13.7-2) unstable; urgency=low
+
+ * Two upstream errata
+ * shared memory failure
+ * daemon pidfile gone on a walkabout
+
+ -- Richard A Nelson (Rick) <cowboy@debian.org> Fri, 16 Jun 2006 12:00:00 -0000
+
sendmail (8.13.7-1) unstable; urgency=high
* potential denial of service problem with malformed MIME message
diff --git a/debian/patches/8.13/8.13.7/main.c.DaemonPid.p0 b/debian/patches/8.13/8.13.7/main.c.DaemonPid.p0
new file mode 100644
index 0000000..1fae8a0
--- /dev/null
+++ b/debian/patches/8.13/8.13.7/main.c.DaemonPid.p0
@@ -0,0 +1,27 @@
+Index: main.c
+===================================================================
+RCS file: /cvs/sendmail/main.c,v
+retrieving revision 8.944
+diff -u -r8.944 main.c
+--- sendmail-8.13.7/sendmail/main.c 21 Apr 2006 23:56:42 -0000 8.944
++++ main.c 15 Jun 2006 18:38:35 -0000
+@@ -2408,6 +2408,8 @@
+ {
+ char dtype[200];
+
++ /* avoid cleanup in finis(), DaemonPid will be set below */
++ DaemonPid = 0;
+ if (!run_in_foreground && !tTd(99, 100))
+ {
+ /* put us in background */
+@@ -2440,7 +2442,10 @@
+
+ dtype[0] = '\0';
+ if (OpMode == MD_DAEMON)
++ {
+ (void) sm_strlcat(dtype, "+SMTP", sizeof dtype);
++ DaemonPid = CurrentPid;
++ }
+ if (QueueIntvl > 0)
+ {
+ (void) sm_strlcat2(dtype,
diff --git a/debian/patches/8.13/8.13.7/queue.c.20060614 b/debian/patches/8.13/8.13.7/queue.c.20060614
new file mode 100644
index 0000000..6a0c85d
--- /dev/null
+++ b/debian/patches/8.13/8.13.7/queue.c.20060614
@@ -0,0 +1,18 @@
+Index: queue.c
+===================================================================
+RCS file: /cvs/sendmail/queue.c,v
+retrieving revision 8.954
+retrieving revision 8.954.2.2
+diff -u -r8.954 -r8.954.2.2
+--- sendmail-8.13.7/sendmail/queue.c 22 Apr 2006 01:07:00 -0000 8.954
++++ queue.c 14 Jun 2006 21:50:56 -0000 8.954.2.2
+@@ -6695,8 +6695,7 @@
+ static time_t nextupdate = 0;
+
+ #if SM_CONF_SHM
+- /* only the daemon updates this structure */
+- if (ShmId == SM_SHM_NO_ID || DaemonPid != CurrentPid)
++ if (ShmId == SM_SHM_NO_ID && DaemonPid != CurrentPid)
+ return;
+ #endif /* SM_CONF_SHM */
+ now = curtime();