summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/TODO4
-rw-r--r--debian/build/config.guess20
-rw-r--r--debian/build/config.sub19
-rw-r--r--debian/build/debian/control.m4.in2
-rw-r--r--debian/build/version.c2
-rw-r--r--debian/changelog12
-rw-r--r--debian/control2
-rw-r--r--debian/faq.txt9
-rw-r--r--debian/local/sendmail.in10
-rw-r--r--debian/local/update_sendmail1
-rwxr-xr-xdebian/rules2
11 files changed, 57 insertions, 26 deletions
diff --git a/debian/TODO b/debian/TODO
index acb9c6b..9349ed4 100644
--- a/debian/TODO
+++ b/debian/TODO
@@ -1,4 +1,8 @@
Important:
+ * qualify /usr/lib/sm.bin/sendmail with version number for coexistance
+> react=rvrs_name, ret=0, name=broadcast.localhost.
+FAIL: t-smar-3.sh
+* compile with tls, posix thread, pmilter
* Parse_mc.pm: scan include() and add as dependancies
* Complete RunAsUser setup for MTA
* udpate_mc: update stats file and RunAsUser accordingly
diff --git a/debian/build/config.guess b/debian/build/config.guess
index 8229471..45bee13 100644
--- a/debian/build/config.guess
+++ b/debian/build/config.guess
@@ -1,9 +1,9 @@
#! /bin/sh
# Attempt to guess a canonical system name.
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-# 2000, 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+# 2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
-timestamp='2004-11-12'
+timestamp='2005-04-22'
# This file is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
@@ -53,7 +53,7 @@ version="\
GNU config.guess ($timestamp)
Originally written by Per Bothner.
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
@@ -804,6 +804,9 @@ EOF
i*:UWIN*:*)
echo ${UNAME_MACHINE}-pc-uwin
exit 0 ;;
+ amd64:CYGWIN*:*:*)
+ echo x86_64-unknown-cygwin
+ exit 0 ;;
p*:CYGWIN*:*)
echo powerpcle-unknown-cygwin
exit 0 ;;
@@ -1137,6 +1140,10 @@ EOF
# From seanf@swdc.stratus.com.
echo i860-stratus-sysv4
exit 0 ;;
+ i*86:VOS:*:*)
+ # From Paul.Green@stratus.com.
+ echo ${UNAME_MACHINE}-stratus-vos
+ exit 0 ;;
*:VOS:*:*)
# From Paul.Green@stratus.com.
echo hppa1.1-stratus-vos
@@ -1197,6 +1204,9 @@ EOF
*:QNX:*:4*)
echo i386-pc-qnx
exit 0 ;;
+ NSE-?:NONSTOP_KERNEL:*:*)
+ echo nse-tandem-nsk${UNAME_RELEASE}
+ exit 0 ;;
NSR-?:NONSTOP_KERNEL:*:*)
echo nsr-tandem-nsk${UNAME_RELEASE}
exit 0 ;;
@@ -1413,7 +1423,9 @@ This script, last modified $timestamp, has failed to recognize
the operating system you are using. It is advised that you
download the most up to date version of the config scripts from
- ftp://ftp.gnu.org/pub/gnu/config/
+ http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.guess
+and
+ http://savannah.gnu.org/cgi-bin/viewcvs/*checkout*/config/config/config.sub
If the version you run ($0) is already up to date, please
send the following data and any information you think might be
diff --git a/debian/build/config.sub b/debian/build/config.sub
index 0f84ac2..87a1ee4 100644
--- a/debian/build/config.sub
+++ b/debian/build/config.sub
@@ -1,9 +1,9 @@
#! /bin/sh
# Configuration validation subroutine script.
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
-# 2000, 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+# 2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
-timestamp='2004-11-30'
+timestamp='2005-04-22'
# This file is (in principle) common to ALL GNU software.
# The presence of a machine in this file suggests that SOME GNU software
@@ -70,7 +70,7 @@ Report bugs and patches to <config-patches@gnu.org>."
version="\
GNU config.sub ($timestamp)
-Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004
+Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
@@ -231,13 +231,14 @@ case $basic_machine in
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
| am33_2.0 \
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
+ | bfin \
| c4x | clipper \
| d10v | d30v | dlx | dsp16xx \
| fr30 | frv \
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
| i370 | i860 | i960 | ia64 \
| ip2k | iq2000 \
- | m32r | m32rle | m68000 | m68k | m88k | mcore \
+ | m32r | m32rle | m68000 | m68k | m88k | maxq | mcore \
| mips | mipsbe | mipseb | mipsel | mipsle \
| mips16 \
| mips64 | mips64el \
@@ -262,7 +263,8 @@ case $basic_machine in
| pyramid \
| sh | sh[1234] | sh[23]e | sh[34]eb | shbe | shle | sh[1234]le | sh3ele \
| sh64 | sh64le \
- | sparc | sparc64 | sparc86x | sparclet | sparclite | sparcv8 | sparcv9 | sparcv9b \
+ | sparc | sparc64 | sparc64b | sparc86x | sparclet | sparclite \
+ | sparcv8 | sparcv9 | sparcv9b \
| strongarm \
| tahoe | thumb | tic4x | tic80 | tron \
| v850 | v850e \
@@ -298,7 +300,7 @@ case $basic_machine in
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
| avr-* \
- | bs2000-* \
+ | bfin-* | bs2000-* \
| c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
| clipper-* | craynv-* | cydra-* \
| d10v-* | d30v-* | dlx-* \
@@ -310,7 +312,7 @@ case $basic_machine in
| ip2k-* | iq2000-* \
| m32r-* | m32rle-* \
| m68000-* | m680[012346]0-* | m68360-* | m683?2-* | m68k-* \
- | m88110-* | m88k-* | mcore-* \
+ | m88110-* | m88k-* | maxq-* | mcore-* \
| mips-* | mipsbe-* | mipseb-* | mipsel-* | mipsle-* \
| mips16-* \
| mips64-* | mips64el-* \
@@ -336,7 +338,8 @@ case $basic_machine in
| romp-* | rs6000-* \
| sh-* | sh[1234]-* | sh[23]e-* | sh[34]eb-* | shbe-* \
| shle-* | sh[1234]le-* | sh3ele-* | sh64-* | sh64le-* \
- | sparc-* | sparc64-* | sparc86x-* | sparclet-* | sparclite-* \
+ | sparc-* | sparc64-* | sparc64b-* | sparc86x-* | sparclet-* \
+ | sparclite-* \
| sparcv8-* | sparcv9-* | sparcv9b-* | strongarm-* | sv1-* | sx?-* \
| tahoe-* | thumb-* \
| tic30-* | tic4x-* | tic54x-* | tic55x-* | tic6x-* | tic80-* \
diff --git a/debian/build/debian/control.m4.in b/debian/build/debian/control.m4.in
index af101bc..f37be12 100644
--- a/debian/build/debian/control.m4.in
+++ b/debian/build/debian/control.m4.in
@@ -207,7 +207,7 @@ dnl #
Package: sendmail-base
Architecture: all
Section: mail
-Depends: m4, make, adduser, netbase (>= 4.0.8), ${perl:Depends}
+Depends: m4, make, adduser, netbase (>= 4.08), ${perl:Depends}
Recommends: resolvconf
Suggests: sendmail-doc, ca-certificates, logcheck, logrotate
Conflicts: sendmail (<= 8.13.1-7)
diff --git a/debian/build/version.c b/debian/build/version.c
index f222e40..d3206f8 100644
--- a/debian/build/version.c
+++ b/debian/build/version.c
@@ -1 +1 @@
-char Version[] = "8.13.3";
+char Version[] = "8.13.4";
diff --git a/debian/changelog b/debian/changelog
index fe95af9..d9a0055 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+sendmail (8.13.4-2) unstable; urgency=high
+ * Important migration fixes
+ + Correct netbase depends (4.08, not 4.0.8) closes: #305513
+ + Remove /etc/mail/databases on upgrade to prevent duplication
+ of some entries.
+ + Build with current libldap2{,-dev} since they're in testing
+ + Sanitize PATH in sendmail script earlier closes: #304628
+
+ -- Richard A Nelson (Rick) <cowboy@debian.org> Mon, 25 Apr 2005 02:30:00 -0000
+
sendmail (8.13.4-1) unstable; urgency=low
* New upstream release
* Refit patches
@@ -11,7 +21,7 @@ sendmail (8.13.4-0) private; urgency=low
-- Richard A Nelson (Rick) <cowboy@debian.org> Mon, 28 Mar 2005 01:50:00 -0000
sendmail (8.13.3+8.13.4.Beta0-0) private; urgency=low
- * New upstream alpha
+ * New upstream beta
* Refit patches
-- Richard A Nelson (Rick) <cowboy@debian.org> Wed, 23 Mar 2005 16:37:00 -0000
diff --git a/debian/control b/debian/control
index 432b04a..f82cb6d 100644
--- a/debian/control
+++ b/debian/control
@@ -147,7 +147,7 @@ Description: powerful, efficient, and scalable Mail Transport Agent
Package: sendmail-base
Architecture: all
Section: mail
-Depends: m4, make, adduser, netbase (>= 4.0.8), ${perl:Depends}
+Depends: m4, make, adduser, netbase (>= 4.08), ${perl:Depends}
Recommends: resolvconf
Suggests: sendmail-doc, ca-certificates, logcheck, logrotate
Conflicts: sendmail (<= 8.13.1-7)
diff --git a/debian/faq.txt b/debian/faq.txt
index 840b762..437e1e5 100644
--- a/debian/faq.txt
+++ b/debian/faq.txt
@@ -4,7 +4,7 @@
Sendmail
Frequently Asked Questions (FAQ)
- Last updated January 12, 2005
+ Last updated March 27, 2005
Comments and questions on this FAQ should be directed to
sendmail+faq@sendmail.org.
@@ -463,7 +463,7 @@ Q2.7 -- Which version of sendmail should I run?
Q2.8 -- What is the latest release of sendmail?
Date: October 24, 1997
- Updated: January 12, 2005
+ Updated: March 27, 2005
For version 8 sendmail, there are five release trees.
@@ -474,6 +474,7 @@ Q2.8 -- What is the latest release of sendmail?
was 8.10.2; the last release of 8.11 was 8.11.6; the last release of
8.12 was 8.12.11 .
+ Version 8.13.4 was released on March 27, 2005.
Version 8.13.3 was released on January 11, 2005.
Version 8.13.2 was released on December 15, 2004.
Version 8.13.1 was released on July 30, 2004.
@@ -506,8 +507,8 @@ Q2.8 -- What is the latest release of sendmail?
Version 8.9.0 was released on May 20, 1998.
On machines exposed directly to the Internet, you should either
- already be running sendmail 8.13.3 or plan on upgrading in the
- immediate future. 8.13.3 is considered "stable", has fixes included
+ already be running sendmail 8.13.4 or plan on upgrading in the
+ immediate future. 8.13.4 is considered "stable", has fixes included
that will not be found in any previous release, and therefore
supercedes all previous releases.
diff --git a/debian/local/sendmail.in b/debian/local/sendmail.in
index c1a86cb..3ade92a 100644
--- a/debian/local/sendmail.in
+++ b/debian/local/sendmail.in
@@ -73,11 +73,6 @@ Get_Parameters () {
. @sysconfdir@/mail/sendmail.conf;
fi;
- # Sanitize some keyword entries
- DAEMON_MODE=$(echo "$DAEMON_MODE" | tr '[:upper:]' '[:lower:]');
- QUEUE_MODE=$(echo "$QUEUE_MODE" | tr '[:upper:]' '[:lower:]');
- MSP_MODE=$(echo "$MSP_MODE" | tr '[:upper:]' '[:lower:]');
-
# These can't be user customized
SM_Get_Parameters='yes';
PATH='/bin:/usr/bin:/sbin:/usr/sbin';
@@ -129,6 +124,11 @@ Get_Parameters () {
# Support for coexistance with smtpd package
SMTPD='/usr/sbin/smtpd';
+ # Sanitize some keyword entries
+ DAEMON_MODE=$(echo "$DAEMON_MODE" | tr '[:upper:]' '[:lower:]');
+ QUEUE_MODE=$(echo "$QUEUE_MODE" | tr '[:upper:]' '[:lower:]');
+ MSP_MODE=$(echo "$MSP_MODE" | tr '[:upper:]' '[:lower:]');
+
# See if we can share the listener and queue-runner daemon:
# * Both must be in daemon mode
# * They must have the same (possibly empty) parameters
diff --git a/debian/local/update_sendmail b/debian/local/update_sendmail
index 900044e..c0d80bb 100644
--- a/debian/local/update_sendmail
+++ b/debian/local/update_sendmail
@@ -54,6 +54,7 @@ if [ -x $sm_path/update_conf ]; then
# sure it is compatible with the current executables.
if [ -x $sm_path/update_mc ]; then
$sm_path/update_mc || changed=1;
+ rm -f /etc/mail/databases || true;
$sm_path/parse_mc || true;
fi;
diff --git a/debian/rules b/debian/rules
index ccbfd7c..53e4ac3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -112,7 +112,7 @@ ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
endif
# will want path info for some things... Like patches/changelogs...
-pwd_string := $(shell expr "${pwd_dir}" : '.*-\([0-9.].*\)')
+pwd_string := $(shell expr "${pwd_dir}" : '.*-\([X?0-9.].*\)')
ifeq (, $(findstring +,${pwd_string}))
pwd_version := ${pwd_string}
else