summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules25
1 files changed, 0 insertions, 25 deletions
diff --git a/debian/rules b/debian/rules
index eed85ff..99b92ca 100755
--- a/debian/rules
+++ b/debian/rules
@@ -352,31 +352,6 @@ common-install-arch::
$(MAKE) -C ${DEB_SRCDIR}/mail.local force-install DESTDIR="$(DEB_DESTDIR)"
# Debian stuff
$(MAKE) -C debian/sensible_mda install-arch DESTDIR="$(DEB_DESTDIR)"
- # Finally, install the whole enchilada
- for subdir in ${SM_SUBDIRS}; do \
- if [ -d ${DEB_SRCDIR}/$${subdir} ]; then \
- if [ "$${subdir}" = 'libmilter' ]; then \
- : ; \
- elif [ "$${subdir}" = 'mail.local' ] \
- || [ "$${subdir}" = 'rmail' ]; then \
- (cd ${DEB_SRCDIR}/obj*/$${subdir} && \
- $(MAKE) force-install \
- DESTDIR="../../../../${PKG_DIR}";); \
- else \
- (cd ${DEB_SRCDIR}/obj*/$${subdir} && \
- $(MAKE) install \
- DESTDIR="../../../../${PKG_DIR}";); \
- fi; \
- fi; \
- done;
- # Sendmail alias handling...
- # NOTE: whilst smptd is a valid alias for sendmail, we don't create
- # one so that we can co-exists with smtpd (a firewall frontend)
- # NOTE: newscache package also contains ${sbindir}/hoststat
- # NOTE: newalias, purgestat, etc. aren't for the general user..
- # yeah, yeah, I know... these can be done with -b<flag>!
- (cd ${PKG_DIR}${bindir} && \
- $(RM) hoststat mailq newaliases purgestat smtpd;)
# Handle man pages for the sendmail aliases
mv ${PKG_TMP}${mandir}/man5/aliases.5 \
${PKG_TMP}${mandir}/man5/aliases.sendmail.5