summaryrefslogtreecommitdiff
path: root/src/Makefiles/Makefile.FreeBSD
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefiles/Makefile.FreeBSD')
-rw-r--r--src/Makefiles/Makefile.FreeBSD52
1 files changed, 0 insertions, 52 deletions
diff --git a/src/Makefiles/Makefile.FreeBSD b/src/Makefiles/Makefile.FreeBSD
deleted file mode 100644
index f3ae29a..0000000
--- a/src/Makefiles/Makefile.FreeBSD
+++ /dev/null
@@ -1,52 +0,0 @@
-#
-# Makefile for FreeBSD
-#
-# @(#)Makefile.FreeBSD 8.8 (Berkeley) 8/7/97
-
-PROG= sendmail
-
-# define the database format to use for aliases et al. Can be -DNEWDB (for
-# the new BSD database package -- this is preferred) or -DNDBM for the NDBM
-# database package. The old putrescent V7 DBM package is no longer
-# supported.
-# You can define both NEWDB and NDBM during a transition period; old
-# databases are read, but the new format will be used on any rebuilds. On
-# really gnarly systems, you can set this to null; it will crawl like a high
-# spiral snail, but it will work.
-DBMDEF= -DNEWDB -DNIS
-
-CFLAGS+=-I${.CURDIR} ${DBMDEF}
-
-SRCS= alias.c arpadate.c clock.c collect.c conf.c convtime.c daemon.c \
- deliver.c domain.c envelope.c err.c headers.c macro.c main.c map.c \
- mci.c mime.c parseaddr.c queue.c readcf.c recipient.c safefile.c \
- savemail.c srvrsmtp.c stab.c stats.c sysexits.c trace.c udb.c \
- usersmtp.c util.c version.c
-DPADD= ${LIBUTIL}
-LDADD= -lutil
-#
-# FreeBSD 1.0 RELEASE has GNU man and doesn't need preformatted man pages anymore
-# (assuming you consider a slower "man" command a feature)
-#
-MAN1= mailq.1 newaliases.1
-MAN5= aliases.5
-MAN8= sendmail.8
-LINKS= /usr/sbin/sendmail /usr/bin/newaliases \
- /usr/sbin/sendmail /usr/bin/mailq \
- /usr/sbin/sendmail /usr/bin/hoststat \
- /usr/sbin/sendmail /usr/bin/purgestat
-INSTALL=install
-BINDIR= /usr/sbin
-BINOWN= root
-BINGRP= kmem
-BINMODE=4555
-
-beforeinstall:
-# ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 644 /dev/null \
-# ${DESTDIR}/etc/sendmail.fc
- ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 644 /dev/null \
- ${DESTDIR}/var/log/sendmail.st
- ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m 444 ${.CURDIR}/sendmail.hf \
- ${DESTDIR}/usr/share/misc
-
-.include <bsd.prog.mk>