summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKarel Zak <kzak@redhat.com>2008-05-13 14:00:39 +0200
committerKarel Zak <kzak@redhat.com>2008-05-13 14:00:39 +0200
commit2d281745d918b1c03bfde69f4b1f663cf2e2577d (patch)
tree16a997e28f4874118eabcaad4a7415d35d2dcf04 /configure.ac
parent8d48d75939cc40f1d6c0b6ebd732a9c9759812e9 (diff)
downloadutil-linux-old-2d281745d918b1c03bfde69f4b1f663cf2e2577d.tar.gz
setarch: add fallback for linux/personality
setarch.c:248: error: 'ADDR_NO_RANDOMIZE' undeclared (first use in this function) setarch.c:248: error: (Each undeclared identifier is reported only once setarch.c:248: error: for each function it appears in.) setarch.c:251: error: 'FDPIC_FUNCPTRS' undeclared (first use in this function) setarch.c:257: error: 'ADDR_COMPAT_LAYOUT' undeclared (first use in this function) setarch.c:260: error: 'READ_IMPLIES_EXEC' undeclared (first use in this function) Linux gzp1 2.4.36.1-gzp1 #1 SMP Tue Feb 19 10:23:48 CET 2008 i686 GNU/Linux Reported-By: Gabor Z. Papp <gzp@papp.hu> Signed-off-by: Karel Zak <kzak@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f767361f..a2887575 100644
--- a/configure.ac
+++ b/configure.ac
@@ -381,6 +381,16 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
[AC_DEFINE(HAVE_TM_GMTOFF,1,[Does struct tm have a field tm_gmtoff?])
])
+AC_CHECK_DECLS([
+ ADDR_NO_RANDOMIZE,
+ FDPIC_FUNCPTRS,
+ MMAP_PAGE_ZERO,
+ ADDR_COMPAT_LAYOUT,
+ READ_IMPLIES_EXEC,
+ ADDR_LIMIT_32BIT,
+ WHOLE_SECONDS,
+ STICKY_TIMEOUTS,
+ ADDR_LIMIT_3GB], [], [], [#include <linux/personality.h>])
AC_CHECK_HEADERS([sys/swap.h])