summaryrefslogtreecommitdiff
path: root/partx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'partx/Makefile.am')
-rw-r--r--partx/Makefile.am20
1 files changed, 14 insertions, 6 deletions
diff --git a/partx/Makefile.am b/partx/Makefile.am
index a26963ed..f7eeef88 100644
--- a/partx/Makefile.am
+++ b/partx/Makefile.am
@@ -1,15 +1,23 @@
include $(top_srcdir)/config/include-Makefile.am
-if BUILD_PARTX
+usrsbin_exec_PROGRAMS = addpart delpart
+dist_man_MANS = addpart.8 delpart.8
-usrsbin_exec_PROGRAMS = addpart delpart partx
-partx_SOURCES = bsd.c dos.c partx.c solaris.c unixware.c sun.c mac.c gpt.c crc32.c \
- efi.h gpt.h crc32.h partx.h dos.h $(top_srcdir)/lib/blkdev.c
+if BUILD_PARTX
+if BUILD_LIBBLKID
+usrsbin_exec_PROGRAMS += partx
+partx_SOURCES = partx.c partx.h \
+ $(top_srcdir)/lib/blkdev.c \
+ $(top_srcdir)/lib/tt.c \
+ $(top_srcdir)/lib/strutils.c
if LINUX
partx_SOURCES += $(top_srcdir)/lib/linux_version.c
endif
-dist_man_MANS = addpart.8 delpart.8 partx.8
-
+partx_CFLAGS = -I$(ul_libblkid_incdir)
+partx_LDADD = $(ul_libblkid_la)
+dist_man_MANS += partx.8
endif
+endif
+