summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMirco Bauer <meebey@debian.org>2004-10-11 20:06:54 +0000
committerMirco Bauer <meebey@debian.org>2004-10-11 20:06:54 +0000
commitb2b976192cb9ad6d85a853d0789a8429925771c5 (patch)
treeb0f9b75fe3c62c0ef62105c4205ef72d6fd488d8
parent01bb3c155fab44fb9b92fc53e3663550919e2d24 (diff)
downloadmono-1.0.2-1.tar.gz
- cleanups1.0.2-1
-rw-r--r--debian/changelog1
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules30
3 files changed, 17 insertions, 18 deletions
diff --git a/debian/changelog b/debian/changelog
index 7048b91d25..164139847f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -7,6 +7,7 @@ mono (1.0.2-1) unstable; urgency=high
(Closes: #265510 thanks to Kurt Roeckx <Q@ping.be>)
+ removed all not official supported architectures
(Closes: #272846, #259680)
+ + cosmetic cleanups in debian/rules
-- Debian Mono Group <pkg-mono-group@lists.alioth.debian.org> Thu, 11 Oct 2004 21:21:02 +0200
diff --git a/debian/control b/debian/control
index 0f7aed0dbd..ade55e528d 100644
--- a/debian/control
+++ b/debian/control
@@ -24,7 +24,7 @@ Description: common files for the Mono CLI runtimes
Package: mono-jit
Provides: cli-virtual-machine
Architecture: i386 powerpc s390
-Depends: ${shlibs:Depends}, mono-assemblies-base-${mono:upversion} | mono-assemblies-base-0.96, mono-common (= ${Source-Version})
+Depends: ${shlibs:Depends}, mono-assemblies-base-${mono:upversion}, mono-common (= ${Source-Version})
Description: fast CLI (.NET/Mono) JIT compiler
The Mono Project is an open development initiative sponsored by Ximian that is
working to develop an open source, Linux-based version of the Microsoft .NET
@@ -40,7 +40,7 @@ Provides: cli-virtual-machine
Architecture: s390
Conflicts: libmint0, libmint-dev
Replaces: libmint0, libmint-dev
-Depends: ${shlibs:Depends}, mono-assemblies-base-${mono:upversion} | mono-assemblies-base-0.96, mono-common (= ${Source-Version})
+Depends: ${shlibs:Depends}, mono-assemblies-base-${mono:upversion}, mono-common (= ${Source-Version})
Recommends: mono-jit
Description: generic CLI (.NET/Mono) code interpreter
The Mono Project is an open development initiative sponsored by Ximian that is
diff --git a/debian/rules b/debian/rules
index a2a96325f4..368074e76b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -6,24 +6,24 @@ export MONO_SHARED_DIR=$(CURDIR)
DEB_BUILD_ARCH := $(shell dpkg-architecture -qDEB_BUILD_ARCH)
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH),sparc)
-JIT = --with-jit=no
-endif
+#ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH),sparc)
+#JIT = --with-jit=no
+#endif
ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH),s390)
-JIT = --with-jit=no --with-nptl=no
+JIT = --with-jit=yes --with-nptl=no
ATG = arch_target=s390
endif
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH),alpha)
-JIT = --with-jit=no
-ATG = arch_target=alpha
-endif
+#ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH),alpha)
+#JIT = --with-jit=no
+#ATG = arch_target=alpha
+#endif
-ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH),arm)
-JIT = --with-jit=no
-ATG = arch_target=arm
-endif
+#ifeq ($(shell dpkg-architecture -qDEB_BUILD_ARCH),arm)
+#JIT = --with-jit=no
+#ATG = arch_target=arm
+#endif
VERSION = $(shell dpkg-parsechangelog | grep ^Vers | cut -d\ -f2)
UPVERSION = $(shell echo $(VERSION) | sed 's,-.*,,')
@@ -43,7 +43,6 @@ cli-wrapper: debian/cli-wrapper.c
$(CC) -o cli-wrapper debian/cli-wrapper.c `pkg-config glib-2.0 --cflags --libs`
build: patch build-stamp
-#build: build-stamp
build-stamp: cli-wrapper
dh_testdir
# using a better dllmap (should be fixed since beta1)
@@ -60,7 +59,6 @@ build-stamp: cli-wrapper
touch build-stamp
clean: unpatch
-#clean:
dh_testdir
dh_testroot
rm -f build-stamp
@@ -98,7 +96,7 @@ install: build
binary-indep: build install
dh_testdir -i
dh_testroot -i
- dh_install -i --list-missing
+ dh_install -i
dh_link -i
dh_installchangelogs -i ChangeLog
dh_installdocs -i
@@ -118,7 +116,7 @@ binary-indep: build install
binary-arch: build install
dh_testdir -s
dh_testroot -s
- dh_install -s --list-missing
+ dh_install -s
dh_link -s
install -m644 -D debian/lintian debian/mono/usr/share/lintian/overrides/mono
dh_installchangelogs -s