summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog12
-rw-r--r--debian/control4
-rw-r--r--debian/mono-jit.postinst1
-rw-r--r--debian/mono-jit.prerm2
-rw-r--r--debian/mono-mint.prerm3
-rwxr-xr-xdebian/rules2
6 files changed, 17 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index d5a4fec85c..b18d12c76f 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,11 +1,13 @@
-mono (0.30.1-2) unstable; urgency=low
+mono (0.30.2-1) unstable; urgency=low
- * NOT RELEASED YET
+ * New upstream release
* Eduard Bloch:
- + debian/control: limit all arch lists to those really supported by the
- Mono project
+ + debian/control: limited "any" arch lists to those really supported by the
+ Mono project. libmono0(-dev) to i386 powerpc (closes: #235315)
+ + added a workaround for gnomeui-2 symbolic name (closes: #235946)
+ + deleting the alternatives entries only on removal (closes: #234815)
- -- Eduard Bloch <blade@debian.org> Tue, 24 Feb 2004 19:28:29 +0100
+ -- Eduard Bloch <blade@debian.org> Sat, 6 Mar 2004 13:15:43 +0100
mono (0.30.1-1) unstable; urgency=low
diff --git a/debian/control b/debian/control
index 0acd8b16ee..cfeb616f64 100644
--- a/debian/control
+++ b/debian/control
@@ -76,7 +76,7 @@ Description: Mono utilities
monodis, pedump and monograph.
Package: libmono0
-Architecture: i386
+Architecture: i386 powerpc
Section: libs
Depends: ${shlibs:Depends}
Conflicts: libmint0
@@ -91,7 +91,7 @@ Description: libraries for the Mono interpreter
Package: libmono-dev
Section: devel
-Architecture: i386
+Architecture: i386 powerpc
Depends: libmono0 (= ${Source-Version})
Description: libraries for the Mono interpreter - Development files
Header files and static libraries for libmono and libmono-profiler-conv.
diff --git a/debian/mono-jit.postinst b/debian/mono-jit.postinst
index a69811cbb5..454f3d04cf 100644
--- a/debian/mono-jit.postinst
+++ b/debian/mono-jit.postinst
@@ -10,3 +10,4 @@ fi
update-alternatives --install /usr/bin/cli cli /usr/bin/mono 14 --slave /usr/share/man/man1/cli.1.gz cli.1.gz /usr/share/man/man1/mono.1.gz
#DEBHELPER#
+
diff --git a/debian/mono-jit.prerm b/debian/mono-jit.prerm
index b21b46dcc7..8b7f615c42 100644
--- a/debian/mono-jit.prerm
+++ b/debian/mono-jit.prerm
@@ -1,5 +1,7 @@
#!/bin/sh -e
+if [ "$1" = remove ]; then
update-alternatives --remove cli /usr/bin/mono
+fi
#DEBHELPER#
diff --git a/debian/mono-mint.prerm b/debian/mono-mint.prerm
index 715dc65784..6d1d72ac96 100644
--- a/debian/mono-mint.prerm
+++ b/debian/mono-mint.prerm
@@ -1,5 +1,8 @@
#!/bin/sh -e
+
+if [ "$1" = remove ]; then
update-alternatives --remove cli /usr/bin/mint
+fi
#DEBHELPER#
diff --git a/debian/rules b/debian/rules
index 8664eba965..6b21cdbf57 100755
--- a/debian/rules
+++ b/debian/rules
@@ -91,6 +91,8 @@ binary-arch: build install
install -m644 -D debian/lintian debian/mono/usr/share/lintian/overrides/mono
# the SONAMEs fix
perl -pe 's/-0.dll(.*)\.so/-0.dll$$1.so.0/; s/libgstreamer-0.6.so/libgstreamer-0.6.so.0/;' -i debian/mono-common/etc/mono/config
+ # gnomeui soname fix, it sucks
+ perl -pe 's!<configuration>!<configuration>\n<dllmap dll="gnomeui-2" target="libgnomeui-2.so.0" />!' -i debian/mono-common/etc/mono/config
# cd debian; for s in *.shlibs.in ; do sed -e "s/_VERSION_/$(VERSION)/g" < $$s | tee $${s%%.in} | tee $${s%%.shlibs.in}/DEBIAN/shlibs >> shlibs.local ; done
# cd debian; for s in *.shlibs.in ; do sed -e "s/_VERSION_/$(VERSION)/g" < $$s | tee $${s%%.in} >> shlibs.local ; done
dh_installchangelogs -s