summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Burrows <dburrows@debian.org>2009-06-30 22:09:50 -0700
committerDaniel Burrows <dburrows@debian.org>2009-06-30 22:09:50 -0700
commit383cf36aa48c84714dd3007cd3ef9f400172a03b (patch)
treea25ec603d563753dbc5f1e5ee766e3d2bb87e253 /configure.ac
parent90d18a6cdbf822d31f493b24857adcde544169a9 (diff)
downloadaptitude-383cf36aa48c84714dd3007cd3ef9f400172a03b.tar.gz
Switch to boost::flyweight from the custom memoization the resolver was doing.
In addition to eliminating that code, this change should make it easier to change the representation of dep_solvers (since I won't have to figure out how to memory-manage whatever-it-is).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 30d8dda3..50001354 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,7 @@ dnl Check for Boost headers. Place each one on a line by itself and
dnl write "dnl" at the end: the "dnl" deletes the newline, and without
dnl it you'll get an error when you run the configure script.
AC_CHECK_HEADERS( dnl
+boost/flyweight.hpp dnl
boost/functional/hash.hpp dnl
boost/optional.hpp dnl
boost/shared_ptr.hpp dnl