summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Burrows <dburrows@debian.org>2008-11-12 08:14:54 -0800
committerDaniel Burrows <dburrows@debian.org>2008-11-12 08:14:54 -0800
commit69c2f0e41739cffd44226c78cf1f47dcd43fd503 (patch)
treeb5c5da3be06611fa896d51dc878210655e899d90 /configure.ac
parent678c2615a5c587b8b5d9b004e7cd0d0e1d57c190 (diff)
downloadaptitude-69c2f0e41739cffd44226c78cf1f47dcd43fd503.tar.gz
Don't include GTK+ in the compile flags or link flags unless we were able to find it.
I'm not sure how we got these values set when HAVE_GTK was false, but when I disabled GTK+ yesterday, I still got a binary that linked against it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2785de37..99635624 100644
--- a/configure.ac
+++ b/configure.ac
@@ -92,8 +92,16 @@ then
AC_DEFINE([HAVE_GTK], [], [Define if the GTK+ frontend is included in the build.])
fi
-CXXFLAGS="$CXXFLAGS $SIGC_CFLAGS $CWIDGET_CFLAGS $GLIBMM_CFLAGS $GTHREAD_CFLAGS $GTKMM_CFLAGS $LIBGLADEMM_CFLAGS $VTE_CFLAGS $ept_CFLAGS"
-LIBS="$LIBS $SIGC_LIBS $CWIDGET_LIBS $GLIBMM_LIBS $GTHREAD_LIBS $GTKMM_LIBS $LIBGLADEMM_LIBS $VTE_LIBS $ept_LIBS"
+CXXFLAGS="$CXXFLAGS $SIGC_CFLAGS $CWIDGET_CFLAGS $ept_CFLAGS"
+LIBS="$LIBS $SIGC_LIBS $CWIDGET_LIBS $ept_LIBS"
+
+if test x$HAVE_GTK = x1
+then
+ CXXFLAGS="$CXXFLAGS $GLIBMM_CFLAGS $GTHREAD_CFLAGS $GTKMM_CFLAGS $LIBGLADEMM_CFLAGS $VTE_CFLAGS"
+ LIBS="$LIBS $GLIBMM_LIBS $GTHREAD_LIBS $GTKMM_LIBS $LIBGLADEMM_LIBS $VTE_LIBS"
+fi
+
+
AC_DEFINE_UNQUOTED(SIGC_VERSION, ["$(pkg-config --modversion sigc++-2.0)"], [The version of libsigc++ with which the program was compiled])
dnl Checks for header files.