summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Burrows <dburrows@debian.org>2009-01-30 10:20:51 -0800
committerDaniel Burrows <dburrows@debian.org>2009-01-30 10:20:51 -0800
commit9a54739b781237d1ab3698f52ba4a5ab92cfc086 (patch)
treee5184838c247ad93e6f100d18bfb6aaace7a90a1 /configure.ac
parent36bb27ecee2c5905f1631e889c5fa970656ae1a6 (diff)
downloadaptitude-9a54739b781237d1ab3698f52ba4a5ab92cfc086.tar.gz
Compile liblog4cxx into the program.
I've been meaning to do this for ages, to get better support for logging debug messages of various sorts. See, for instance, the proto-loglevel stuff in ProblemResolver. With log4cxx, I hope that I can start doing *serious* debug message logging without too much trouble. This is separate from storing a history of aptitude's own actions, which I'm still working on (the requirements are totally different). It's strictly for tracing what the program is up to.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 63b43c57..bf31f59e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -48,6 +48,8 @@ PKG_CHECK_MODULES(SIGC, sigc++-2.0)
PKG_CHECK_MODULES(CWIDGET, cwidget)
+PKG_CHECK_MODULES(LOG4CXX, liblog4cxx)
+
PKG_CHECK_MODULES(VTE, vte)
HAVE_GTK=1
@@ -92,8 +94,8 @@ then
AC_DEFINE([HAVE_GTK], [], [Define if the GTK+ frontend is included in the build.])
fi
-CXXFLAGS="$CXXFLAGS $SIGC_CFLAGS $CWIDGET_CFLAGS $ept_CFLAGS"
-LIBS="$LIBS $SIGC_LIBS $CWIDGET_LIBS $ept_LIBS"
+CXXFLAGS="$CXXFLAGS $LOG4CXX_CFLAGS $SIGC_CFLAGS $CWIDGET_CFLAGS $ept_CFLAGS"
+LIBS="$LIBS $LOG4CXX_LIBS $SIGC_LIBS $CWIDGET_LIBS $ept_LIBS"
if test x$HAVE_GTK = x1
then