summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Burrows <dburrows@debian.org>2008-09-03 10:50:26 -0700
committerDaniel Burrows <dburrows@debian.org>2008-09-03 10:50:26 -0700
commit99ffa86229344212e8b5b801b357c26d42a60788 (patch)
tree52cefca607786a5b98e282bd6995c92538cb3fa7 /src/Makefile.am
parenta6858d38a749f941a232652c8cc2adede022ad3c (diff)
downloadaptitude-99ffa86229344212e8b5b801b357c26d42a60788.tar.gz
Start working on a rewrite of the matching code: implemented the core structure to represent search patterns.
The matching code has been due for a rewrite for a long time. There are two goals in this rewrite: (1) Make the matchers not a black box, so that the various frontends can provide interactive editing of search patterns, so that it's easier to write new analysis and/or execution functions on search patterns, etc. The specific mechanism I chose is to make the pattern type be a "poor man's algebraic datatype": a single data type that can represent all the legal forms of a search pattern. This flips us to the other side of the expression problem; since the search expressions are actually a programming language, this is a more appropriate place to be. (2) Add support for Xapian. (3) Don't put all the code into one enormous file. (2) isn't necessarily dependent on (1), but if I did (2) first, I would have to do even more work to do (1). This commit is the first step in this direction, implementing the core pattern data type (untested).
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 65f553be..2c732c61 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -14,7 +14,8 @@ DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
bin_PROGRAMS=aptitude
LDADD=@LIBINTL@ $(MAYBE_LIBGTK) cmdline/libcmdline.a mine/libcmine.a \
- generic/util/libgeneric-util.a generic/apt/libgeneric-apt.a
+ generic/util/libgeneric-util.a generic/apt/libgeneric-apt.a \
+ generic/apt/matching/libgeneric-matching.a
aptitude_SOURCES= \
aptitude.h \