summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Burrows <dburrows@debian.org>2010-03-15 23:23:46 -0700
committerDaniel Burrows <dburrows@debian.org>2010-03-15 23:23:46 -0700
commit12e43bb43a8c30beb71da80f126f59b53df189be (patch)
tree0584f9458e2b307608d5de1aa5505225173e1e78 /tests/Makefile.am
parentbaa557f458167a43f96b1e3d88474e7dcdcefc61 (diff)
downloadaptitude-12e43bb43a8c30beb71da80f126f59b53df189be.tar.gz
Write basic unit tests for the new resolver cost code.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9f75a753..628ad2fc 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -20,7 +20,7 @@ EXTRA_DIST = file_caches
interactive_set_test_SOURCES = interactive_set_test.cc
test_choice.o test_choice_set.o test_resolver.o: $(top_srcdir)/src/generic/problemresolver/*.h
-test_promotion_set.o test_resolver_hints.o: $(top_srcdir)/src/generic/problemresolver/*.h
+test_promotion_set.o test_resolver_costs.o test_resolver_hints.o: $(top_srcdir)/src/generic/problemresolver/*.h
# Note: test_apt_universe is not built by default because it takes way
# too long. Of course, ideally this would be done in a less ad-hoc
@@ -35,6 +35,7 @@ cppunit_test_SOURCES = \
test_misc.cc \
test_promotion_set.cc \
test_resolver.cc \
+ test_resolver_costs.cc \
test_resolver_hints.cc \
test_setset.cc \
test_tags.cc \