summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorDaniel Burrows <Daniel Burrows Daniel_Burrows@alumni.brown.edu>2010-05-24 09:36:33 -0700
committerDaniel Burrows <Daniel Burrows Daniel_Burrows@alumni.brown.edu>2010-05-24 09:36:33 -0700
commit8b81c0c1e773819f1d531b4d44388193bb93fd9e (patch)
tree605bc7357c5cbb7aa870ec47d8de1fcd359926f2 /tests/Makefile.am
parent88e3dc1c2841098538d30c13fb2ce5d164ced183 (diff)
downloadaptitude-8b81c0c1e773819f1d531b4d44388193bb93fd9e.tar.gz
Start using google-mock to test the search input controller logic.
I use google-mock to create a mock implementation of the view, then test that the logic interacts with it as expected. Right now, it doesn't. The ability to do this was part of why I wanted to separate the logic from the view. I haven't added google-mock to configure.ac yet; need to do that later.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 9a630f0d..755c632d 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -2,13 +2,17 @@ MAINTAINERCLEANFILES = Makefile.in
INCLUDES = -I$(top_builddir) -I$(top_srcdir) -I$(top_srcdir)/src -I$(srcdir)
BOOST_TEST_LDFLAGS = @BOOST_UNIT_TEST_LIBS@
+GMOCK_LDFLAGS = -lgmock -lgtest
AM_CPPFLAGS = -DBOOST_TEST_DYN_LINK -DSRCDIR=\"$(srcdir)\"
LDADD = $(top_builddir)/src/loggers.o \
+$(top_builddir)/src/gtk/controllers/libgtk-controllers.a \
+$(top_builddir)/src/gtk/views/libgtk-views.a \
$(top_builddir)/src/generic/apt/matching/libgeneric-matching.a \
$(top_builddir)/src/generic/apt/libgeneric-apt.a \
$(top_builddir)/src/generic/apt/matching/libgeneric-matching.a \
$(top_builddir)/src/generic/problemresolver/libgeneric-problemresolver.a \
-$(top_builddir)/src/generic/util/libgeneric-util.a -lcppunit $(BOOST_TEST_LDFLAGS)
+$(top_builddir)/src/generic/util/libgeneric-util.a -lcppunit \
+$(BOOST_TEST_LDFLAGS) $(GMOCK_LDFLAGS)
check_PROGRAMS = cppunit_test boost_test
@@ -51,4 +55,5 @@ boost_test_SOURCES = \
test_dynamic_set.cc \
test_enumerator.cc \
test_file_cache.cc \
+ test_search_input_controller.cc \
test_sqlite.cc