summaryrefslogtreecommitdiff
path: root/doc/it/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/it/Makefile.am')
-rw-r--r--doc/it/Makefile.am23
1 files changed, 14 insertions, 9 deletions
diff --git a/doc/it/Makefile.am b/doc/it/Makefile.am
index 86408c5f..97e64ab8 100644
--- a/doc/it/Makefile.am
+++ b/doc/it/Makefile.am
@@ -1,14 +1,19 @@
-# automake doesn't play nicely with DocBook :(
+SUBDIRS = images
+EXTRA_DIST =
-include $(top_srcdir)/doc/common.mk
-include $(top_srcdir)/doc/po4a.mk
+LC = it
-SUBDIRS=images
-EXTRA_DIST=
-LANGCODE=it
+include $(top_srcdir)/buildlib/doc.mk
+include $(top_srcdir)/buildlib/po4a.mk
-README_encoding=utf-8
+README = README.it
+README_encoding = utf-8
-XMLSOURCES=aptitude.xml manpage.xml
+IMAGES := $(wildcard $(srcdir)/images/*.png) $(PO4A_IMAGES)
-IMAGES=$(wildcard $(srcdir)/images/*.png) images/safety-cost-level-diagram.png
+DOCBOOK_XML = aptitude.xml manpage.xml
+DOCBOOK_TARGETS = docbook-html docbook-man docbook-readme
+
+include $(top_srcdir)/buildlib/docbook.mk
+
+all-local: $(DOCBOOK_TARGETS)