Age | Commit message (Collapse) | Author | Files | Lines |
|
behavior, and fix setting safety levels using the old names.
aptitude's behavior should now be fully compatible with pre-0.6.2
releases (by default). The safety level change fixes the fact that
you could raise safety levels using the old names but not lower them.
|
|
is based on "cost" instead.
|
|
This also starts to introduce the concept of a "cost component": an
intermediate counter of some sort that can be used to assemble a cost.
The eventual goal is to haved named components, like "removals" and
"upgrade-cancels", and operators that combine them to form new cost
components, like "removals + upgrade-cancels".
"cost component" / "cost" is the terminology I eventually want to move
towards, in favor of the confusing and badly-chosen "tier level" and
"tier". This commit starts to introduce that terminology, and all my
new commits will use it (except where local consistency demands
otherwise). Eventually I need to make a pass over the code and rename
lots of stuff.
|
|
this is the first step towards being able to minimize the number of changes meeting a criterion.
The biggest change for this is that the new cost objects (tier operations)
are not totally ordered, so various places that used to take a maximum
now take a least-upper-bound instead; similarly for minimum and
greatest-lower-bound. Still to do: find a sound way to allow the resolver
to add together costs instead of upper-bounding them: "this change
will force us to remove 10 packages".
The new code seems to be a little too slow -- probably it lost some
optimizations by accident. It does seem to be correct, though.
|
|
The rule in this system is that you can increase tier levels either
by adding positive numbers to them or by lower-bounding them. Any given
slot in the tier has to be managed using only one of these operations,
but different slots can be managed using different operations. This
allows support for the new "add to tier" operation, while maintaining
the ability to do the old "increase to level" operation (both for
backwards-compatibility and for supporting pin priorities).
Currently the unit tests fail; this needs to be fixed.
|
|
|
|
The syntax is "increase-tier-to TIER PACKAGE [VERSION]". The tier is
either an integer, "conflict", or "minimum" (although "minimum" has no
effect, so there's no point in using it).
|
|
|
|
|
|
mandate versions.
|
|
|
|
|
|
|