summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNathan Scott <nathans@sgi.com>2001-07-16 11:49:03 +0000
committerNathan Scott <nathans@sgi.com>2001-07-16 11:49:03 +0000
commit42dbfb88f62c0811f542f535dc0773023f961b8c (patch)
tree048003b1aac299ffc1209af2360bcd96f88adceb /configure.in
parent31b10d190a941ead85cd53a258b6d59274b44aad (diff)
downloadattr-42dbfb88f62c0811f542f535dc0773023f961b8c.tar.gz
updates to integrate libtool into the build throughout the package.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index eafd654..ba963c3 100644
--- a/configure.in
+++ b/configure.in
@@ -35,7 +35,7 @@ pkg_release=$PKG_BUILD
AC_SUBST(pkg_version)
AC_SUBST(pkg_release)
-pkg_distribution="SGI ProPack"
+pkg_distribution="SGI XFS"
test -z "$DISTRIBUTION" || pkg_distribution="$DISTRIBUTION"
AC_SUBST(pkg_distribution)
@@ -98,6 +98,23 @@ test -z "$ECHO" && AC_PATH_PROG(ECHO, echo, /bin/echo)
echo=$ECHO
AC_SUBST(echo)
+dnl ensure libtool is installed
+AC_PATH_PROG(LIBTOOL, libtool,,/usr/bin)
+if test "$LIBTOOL" = ""; then
+ echo
+ echo 'FATAL ERROR: libtool does not seem to be installed.'
+ echo $pkg_name cannot be built without a working libtool installation.
+ exit 1
+fi
+libtool=$LIBTOOL
+AC_SUBST(libtool)
+
+dnl libtool to build libraries static only?
+AC_ARG_ENABLE(enable_shared,
+ [ --enable-shared=[yes/no] Enable use of shared libraries [default=yes].],
+ ,
+ enable_shared=yes)
+AC_SUBST(enable_shared)
dnl alternate root and usr prefixes
test -z "$ROOT_PREFIX" && ROOT_PREFIX=""