summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorNathan Scott <nathans@sgi.com>2001-01-15 03:18:30 +0000
committerNathan Scott <nathans@sgi.com>2001-01-15 03:18:30 +0000
commit02f43564629f54847c04cc32f77cb1b6ba3b89c2 (patch)
treeae1217c94a5d2659dcf985e1385941e20ef2f60f /debian
parent82129da6af3a2cddad3334623cfe415058036e4c (diff)
downloadattr-02f43564629f54847c04cc32f77cb1b6ba3b89c2.tar.gz
initial version for reworked extended attributes build environment.
Diffstat (limited to 'debian')
-rw-r--r--debian/Makefile40
-rw-r--r--debian/changelog9
-rw-r--r--debian/control24
-rw-r--r--debian/copyright14
-rwxr-xr-xdebian/rules60
5 files changed, 147 insertions, 0 deletions
diff --git a/debian/Makefile b/debian/Makefile
new file mode 100644
index 0000000..5987042
--- /dev/null
+++ b/debian/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (c) 2000 Silicon Graphics, Inc. All Rights Reserved.
+#
+# This program is free software; you can redistribute it and/or modify it
+# under the terms of version 2 of the GNU General Public License as
+# published by the Free Software Foundation.
+#
+# This program is distributed in the hope that it would be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+#
+# Further, this software is distributed without any warranty that it is
+# free of the rightful claim of any third person regarding infringement
+# or the like. Any license provided herein, whether implied or
+# otherwise, applies only to this software file. Patent licenses, if
+# any, provided herein do not apply to combinations of this program with
+# other software, or any other product whatsoever.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write the Free Software Foundation, Inc., 59
+# Temple Place - Suite 330, Boston MA 02111-1307, USA.
+#
+# Contact information: Silicon Graphics, Inc., 1600 Amphitheatre Pkwy,
+# Mountain View, CA 94043, or:
+#
+# http://www.sgi.com
+#
+# For further information regarding this notice, see:
+#
+# http://oss.sgi.com/projects/GenInfo/SGIGPLNoticeExplan/
+#
+
+TOPDIR = ..
+include $(TOPDIR)/include/builddefs
+
+LSRCFILES = changelog control copyright rules
+
+default install install-dev:
+
+include $(BUILDRULES)
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..0508f35
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,9 @@
+attr (1.0.0) unstable; urgency=low
+
+ * Initial release.
+
+ -- Nathan Scott <nathans@debian.org> Thu, 4 Jan 2001 11:15:11 -0500
+
+Local variables:
+mode: debian-changelog
+End:
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..e2961f2
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,24 @@
+Source: attr
+Section: admin
+Priority: optional
+Maintainer: Nathan Scott <nathans@debian.org>
+Build-Depends: autoconf, debmake
+Standards-Version: 3.1.1
+
+Package: attr
+Depends: ${shlibs:Depends}
+Architecture: any
+Description: Experimental utility for manipulating extended attributes
+ An *experimental* command to manipulate filesystem extended
+ attributes. Currently, only the XFS filesystem is supported.
+
+Package: attr-dev
+Section: devel
+Priority: extra
+Depends: libc6-dev, attr
+Architecture: any
+Description: Extended attribute static libraries and headers.
+ attr-dev contains the libraries and header files needed to
+ develop programs which make use of extended attributes.
+ This is an *experimental* interface, currently only XFS is
+ supported, and the interface is likely to change.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..d956166
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,14 @@
+This package was debianized by Nathan Scott nathans@debian.org on
+Sun, 19 Nov 2000 07:37:09 -0500.
+
+It can be downloaded from ftp://oss.sgi.com/projects/xfs/download/
+
+Copyright:
+
+Copyright (C) 2000 Silicon Graphics, Inc.
+
+You are free to distribute this software under the terms of
+the GNU General Public License.
+On Debian systems, the complete text of the GNU General Public
+License can be found in /usr/share/common-licenses/GPL file.
+
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..94b0062
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,60 @@
+#!/usr/bin/make -f
+
+package = attr
+develop = $(package)-dev
+
+dirtmp = debian/tmp
+dirdev = debian/$(develop)
+doctmp = /usr/share/doc/$(package)
+docdev = /usr/share/doc/$(develop)
+pkgtmp = DIST_ROOT=`pwd`/$(dirtmp); export DIST_ROOT;
+pkgdev = DIST_ROOT=`pwd`/$(dirdev); export DIST_ROOT;
+stdenv = GZIP=-q; export GZIP;
+
+options = DEBUG="-DNDEBUG"; OPTIMIZER="-O2 -g"; export DEBUG OPTIMIZER;
+checkdir = test -f debian/rules
+
+build: built
+built:
+ @echo "== dpkg-buildpackage: build" 1>&2
+ $(checkdir)
+ autoconf
+ $(options) ./configure
+ $(MAKE) default
+ touch built
+
+clean:
+ @echo "== dpkg-buildpackage: clean" 1>&2
+ $(checkdir)
+ -rm -f built
+ $(MAKE) distclean
+ -rm -rf $(dirtmp) $(dirdev) debian/*substvars debian/files*
+
+binary-indep:
+
+binary-arch: checkroot built
+ @echo "== dpkg-buildpackage: binary-arch" 1>&2
+ $(checkdir)
+ -rm -rf $(dirtmp) $(dirdev)
+ $(pkgtmp) $(MAKE) -C . install
+ $(pkgdev) $(MAKE) -C . install-dev
+ $(pkgtmp) $(MAKE) -C build src-manifest
+ $(pkgdev) ./install-sh -m 755 -d $(doctmp)
+ $(pkgdev) ./install-sh -m 755 -d $(docdev)
+ $(pkgdev) ./install-sh -m 644 debian/copyright $(docdev)
+ $(pkgdev) ./install-sh -m 644 debian/changelog $(docdev)
+ @echo "== dpkg-buildpackage: debstd" 1>&2
+ $(stdenv) debstd -m
+ dpkg-gencontrol -isp -p$(package) -P$(dirtmp)
+ dpkg-gencontrol -isp -p$(develop) -P$(dirdev)
+ chown -R root.root $(dirtmp) $(dirdev)
+ chmod -R go=rX $(dirtmp) $(dirdev)
+ dpkg --build $(dirtmp) ..
+ dpkg --build $(dirdev) ..
+
+binary: binary-indep binary-arch
+
+checkroot:
+ test 0 -eq `id -u`
+
+.PHONY: binary binary-arch binary-indep clean checkroot