summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorNathan Scott <nathans@sgi.com>2001-07-16 11:49:03 +0000
committerNathan Scott <nathans@sgi.com>2001-07-16 11:49:03 +0000
commit42dbfb88f62c0811f542f535dc0773023f961b8c (patch)
tree048003b1aac299ffc1209af2360bcd96f88adceb /debian
parent31b10d190a941ead85cd53a258b6d59274b44aad (diff)
downloadattr-42dbfb88f62c0811f542f535dc0773023f961b8c.tar.gz
updates to integrate libtool into the build throughout the package.
Diffstat (limited to 'debian')
-rw-r--r--debian/Makefile13
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules21
4 files changed, 32 insertions, 12 deletions
diff --git a/debian/Makefile b/debian/Makefile
index 5987042..4cad821 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -34,7 +34,18 @@ TOPDIR = ..
include $(TOPDIR)/include/builddefs
LSRCFILES = changelog control copyright rules
+DEV_DOC_DIR = $(PKG_DOC_DIR)/../$(PKG_NAME)-dev
-default install install-dev:
+default:
include $(BUILDRULES)
+
+install: default
+ $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
+ $(INSTALL) -m 644 changelog $(PKG_DOC_DIR)/changelog.Debian
+
+install-dev: default
+ $(INSTALL) -m 755 -d $(PKG_DOC_DIR)
+ $(INSTALL) -m 755 -d $(DEV_DOC_DIR)
+ $(INSTALL) -m 644 copyright $(DEV_DOC_DIR)
+ $(INSTALL) -m 644 changelog $(DEV_DOC_DIR)/changelog.Debian
diff --git a/debian/changelog b/debian/changelog
index 6623e88..31725ff 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+attr (1.1.0-1) unstable; urgency=low
+
+ * Reworked package slightly so that its not Debian native
+ * Debian-specific changes now documented in changelog.Debian.gz
+ * New upstream release (see /usr/share/doc/attr/changelog.gz)
+
+ -- Nathan Scott <nathans@debian.org> Mon, 16 Jul 2001 18:14:56 +1000
+
attr (1.0.4) unstable; urgency=low
* Work around syscall number collision on recent ia64 kernels
diff --git a/debian/control b/debian/control
index 7315eaf..69f1b30 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: attr
Section: utils
Priority: optional
Maintainer: Nathan Scott <nathans@debian.org>
-Build-Depends: autoconf, debmake
+Build-Depends: autoconf, debmake, libtool
Standards-Version: 3.1.1
Package: attr
diff --git a/debian/rules b/debian/rules
index 5067436..c2e1915 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,8 +5,6 @@ develop = $(package)-dev
dirtmp = debian/tmp
dirdev = debian/$(develop)
-doctmp = /usr/share/doc/$(package)
-docdev = /usr/share/doc/$(develop)
pkgtmp = DIST_ROOT=`pwd`/$(dirtmp); export DIST_ROOT;
pkgdev = DIST_ROOT=`pwd`/$(dirdev); export DIST_ROOT;
stdenv = GZIP=-q; export GZIP;
@@ -16,18 +14,23 @@ options = DEBUG="-DNDEBUG"; OPTIMIZER="-O1 -g"; DISTRIBUTION="debian"; \
checkdir = test -f debian/rules
build: built
-built:
+built: config
@echo "== dpkg-buildpackage: build" 1>&2
+ $(MAKE) default
+ touch built
+
+config: .census
+.census:
+ @echo "== dpkg-buildpackage: configure" 1>&2
$(checkdir)
autoconf
$(options) ./configure
- $(MAKE) default
- touch built
+ touch .census
clean:
@echo "== dpkg-buildpackage: clean" 1>&2
$(checkdir)
- -rm -f built
+ -rm -f built .census
$(MAKE) distclean
-rm -rf $(dirtmp) $(dirdev) debian/*substvars debian/files*
@@ -40,11 +43,9 @@ binary-arch: checkroot built
$(pkgtmp) $(MAKE) -C . install
$(pkgdev) $(MAKE) -C . install-dev
$(pkgtmp) $(MAKE) -C build src-manifest
- $(pkgdev) ./install-sh -m 755 -d $(doctmp)
- $(pkgdev) ./install-sh -m 755 -d $(docdev)
- $(pkgdev) ./install-sh -m 644 debian/copyright $(docdev)
- $(pkgdev) ./install-sh -m 644 debian/changelog $(docdev)
@echo "== dpkg-buildpackage: debstd" 1>&2
+ # Note: dev pkg with .so symlinks to base pkg confuses debstd;
+ # so the .so 'Dangling symlink' message below is benign.
$(stdenv) debstd -m
dpkg-gencontrol -isp -p$(package) -P$(dirtmp)
dpkg-gencontrol -isp -p$(develop) -P$(dirdev)