summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorNathan Scott <nathans@sgi.com>2001-07-20 08:18:35 +0000
committerNathan Scott <nathans@sgi.com>2001-07-20 08:18:35 +0000
commitef6f20ab2b102e276acf6b2ac2ff9a37418da86e (patch)
tree7fcd599f27fb67c523ba97c595e3a8d0b8088b57 /debian
parent150e66c73601fb7cac2f7f32fabdab47e756f53b (diff)
downloadattr-ef6f20ab2b102e276acf6b2ac2ff9a37418da86e.tar.gz
merge Deans changes to libtool build/install process from dmapi into the
other XFS packages.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules11
1 files changed, 7 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index c2e1915..dc0b3ed 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,7 +7,7 @@ dirtmp = debian/tmp
dirdev = debian/$(develop)
pkgtmp = DIST_ROOT=`pwd`/$(dirtmp); export DIST_ROOT;
pkgdev = DIST_ROOT=`pwd`/$(dirdev); export DIST_ROOT;
-stdenv = GZIP=-q; export GZIP;
+stdenv = @GZIP=-q; export GZIP;
options = DEBUG="-DNDEBUG"; OPTIMIZER="-O1 -g"; DISTRIBUTION="debian"; \
export DEBUG OPTIMIZER DISTRIBUTION;
@@ -36,6 +36,11 @@ clean:
binary-indep:
+# Note1: dev pkg with .so symlinks to base pkg confuses debstd;
+# so the .so 'Dangling symlink' message is benign.
+# Note2: absolute symlinks (required by policy) confuse debstd;
+# so we'll filter out symlink messages entirely now.
+#
binary-arch: checkroot built
@echo "== dpkg-buildpackage: binary-arch" 1>&2
$(checkdir)
@@ -44,9 +49,7 @@ binary-arch: checkroot built
$(pkgdev) $(MAKE) -C . install-dev
$(pkgtmp) $(MAKE) -C build src-manifest
@echo "== dpkg-buildpackage: debstd" 1>&2
- # Note: dev pkg with .so symlinks to base pkg confuses debstd;
- # so the .so 'Dangling symlink' message below is benign.
- $(stdenv) debstd -m
+ $(stdenv) debstd -m | grep -v 'Dangling symlink'
dpkg-gencontrol -isp -p$(package) -P$(dirtmp)
dpkg-gencontrol -isp -p$(develop) -P$(dirdev)
chown -R root.root $(dirtmp) $(dirdev)