summaryrefslogtreecommitdiff
path: root/debian/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/Makefile')
-rw-r--r--debian/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/debian/Makefile b/debian/Makefile
index 4cad821..b3d3d7b 100644
--- a/debian/Makefile
+++ b/debian/Makefile
@@ -41,11 +41,15 @@ default:
include $(BUILDRULES)
install: default
+ifeq ($(PKG_DISTRIBUTION), debian)
$(INSTALL) -m 755 -d $(PKG_DOC_DIR)
$(INSTALL) -m 644 changelog $(PKG_DOC_DIR)/changelog.Debian
+endif
install-dev: default
+ifeq ($(PKG_DISTRIBUTION), debian)
$(INSTALL) -m 755 -d $(PKG_DOC_DIR)
$(INSTALL) -m 755 -d $(DEV_DOC_DIR)
$(INSTALL) -m 644 copyright $(DEV_DOC_DIR)
$(INSTALL) -m 644 changelog $(DEV_DOC_DIR)/changelog.Debian
+endif