summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index ec9d67c..0bebccf 100755
--- a/debian/rules
+++ b/debian/rules
@@ -347,6 +347,9 @@ DEB_TARGET_MULTIARCHN32_mipselel = mips64el-linux-gnuabin32
DEB_TARGET_MULTIARCH32_arm64 = aarch64_ilp32-linux-gnu
+DEB_TARGET_MULTIARCH32_illumos-amd64 = i386-illumos
+DEB_TARGET_MULTIARCH64_illumos-i386 = x86_64-illumos
+
SET_MULTIARCH_ENV = \
DEB_TARGET_MULTIARCH=$(call _multiarch,$1) \
$(if $(DEB_TARGET_MULTIARCH32_$1) ,DEB_TARGET_MULTIARCH32=$(DEB_TARGET_MULTIARCH32_$1)) \
@@ -870,6 +873,14 @@ stamps/install: checkroot stamps/build $(install_stamps) $(if $(CROSS),debian/st
mandir=$(pwd)/$(d_bin)/$(PF)/share/man \
infodir=$(pwd)/$(d_doc)/$(PF)/share/info install
+ifeq (illumos,$(DEB_HOST_ARCH_OS))
+ ln -sf ld $(pwd)/$(d_bin)/$(PF)/bin/ld_sol2
+ for prog in ld as nm ; do \
+ ln -sf $$prog $(pwd)/$(d_bin)/$(PF)/bin/g$$prog ; \
+ ln -sf $$prog.1.gz $(pwd)/$(d_bin)/$(PF)/share/man/man1/g$$prog.1.gz ; \
+ done
+endif
+
ifeq ($(with_multiarch),yes)
: # now install binutils-multiarch stuff
env MAKE="$(MAKE) VERSION=$(MULTI_VERSION)" \